summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-06-25 13:19:28 +0200
committerMichał Górny <mgorny@gentoo.org>2022-06-25 15:07:32 +0200
commite1d1f3892492638d6037d1379330ca6566bc3ab5 (patch)
tree05ce84cc10fac7a6a6101a09563f2ed68ee23996 /sys-devel
parentsys-libs/libomp: Bump to 14.0.6 (diff)
downloadgentoo-e1d1f3892492638d6037d1379330ca6566bc3ab5.tar.gz
gentoo-e1d1f3892492638d6037d1379330ca6566bc3ab5.tar.bz2
gentoo-e1d1f3892492638d6037d1379330ca6566bc3ab5.zip
sys-devel/clang-runtime: Bump to 14.0.6
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/clang-runtime/clang-runtime-14.0.6.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/sys-devel/clang-runtime/clang-runtime-14.0.6.ebuild b/sys-devel/clang-runtime/clang-runtime-14.0.6.ebuild
new file mode 100644
index 000000000000..f0ec98510540
--- /dev/null
+++ b/sys-devel/clang-runtime/clang-runtime-14.0.6.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit multilib-build
+
+DESCRIPTION="Meta-ebuild for clang runtime libraries"
+HOMEPAGE="https://clang.llvm.org/"
+
+LICENSE="metapackage"
+SLOT="$(ver_cut 1-3)"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~ppc-macos ~x64-macos"
+IUSE="+compiler-rt libcxx openmp +sanitize"
+REQUIRED_USE="sanitize? ( compiler-rt )"
+
+RDEPEND="
+ compiler-rt? (
+ ~sys-libs/compiler-rt-${PV}:${SLOT}[abi_x86_32(+)?,abi_x86_64(+)?]
+ sanitize? (
+ ~sys-libs/compiler-rt-sanitizers-${PV}:${SLOT}[abi_x86_32(+)?,abi_x86_64(+)?]
+ )
+ )
+ libcxx? ( >=sys-libs/libcxx-${PV}[${MULTILIB_USEDEP}] )
+ openmp? ( >=sys-libs/libomp-${PV}[${MULTILIB_USEDEP}] )
+"