summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-05-26 06:47:46 +0100
committerSam James <sam@gentoo.org>2022-05-26 06:48:06 +0100
commit9c13495c430ca3e64bc09682c8a646fdaed843b0 (patch)
treee38ad60a1342a7ad5dd11e53fec6564de7a69374 /sys-devel
parentsys-devel/binutils: add --enable-warn-{execstack,rwx-segments} to 9999 only (diff)
downloadgentoo-9c13495c430ca3e64bc09682c8a646fdaed843b0.tar.gz
gentoo-9c13495c430ca3e64bc09682c8a646fdaed843b0.tar.bz2
gentoo-9c13495c430ca3e64bc09682c8a646fdaed843b0.zip
sys-devel/gdb: build tests in src_compile when enabled
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/gdb/gdb-12.1.ebuild16
1 files changed, 11 insertions, 5 deletions
diff --git a/sys-devel/gdb/gdb-12.1.ebuild b/sys-devel/gdb/gdb-12.1.ebuild
index b7ca1edd1937..4c59318f5d81 100644
--- a/sys-devel/gdb/gdb-12.1.ebuild
+++ b/sys-devel/gdb/gdb-12.1.ebuild
@@ -53,6 +53,9 @@ fi
IUSE="cet guile lzma multitarget nls +python +server source-highlight test vanilla xml xxhash"
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+# In fact, gdb's test suite needs some work to get passing.
+# See e.g. https://sourceware.org/gdb/wiki/TestingGDB.
+# As of 11.2, on amd64: "# of unexpected failures 8600"
# ia64 kernel crashes when gdb testsuite is running
# in fact, gdb's test suite needs some work to get passing.
# See e.g. https://sourceware.org/gdb/wiki/TestingGDB.
@@ -104,9 +107,8 @@ src_prepare() {
default
strip-linguas -u bfd/po opcodes/po
- export CC_FOR_BUILD="$(tc-getBUILD_CC)"
- # avoid using ancient termcap from host on Prefix systems
+ # Avoid using ancient termcap from host on Prefix systems
sed -i -e 's/termcap tinfow/tinfow/g' \
gdb/configure{.ac,} || die
}
@@ -135,13 +137,15 @@ src_configure() {
--with-pkgversion="$(gdb_branding)"
--with-bugurl='https://bugs.gentoo.org/'
--disable-werror
- # Disable modules that are in a combined binutils/gdb tree. #490566
+ # Disable modules that are in a combined binutils/gdb tree. bug #490566
--disable-{binutils,etc,gas,gold,gprof,ld}
# avoid automagic dependency on (currently prefix) systems
# systems with debuginfod library, bug #754753
--without-debuginfod
+ $(use_enable test unit-tests)
+
# Allow user to opt into CET for host libraries.
# Ideally we would like automagic-or-disabled here.
# But the check does not quite work on i686: bug #760926.
@@ -198,6 +202,8 @@ src_configure() {
# source-highlight is detected with pkg-config: bug #716558
export ac_cv_path_pkg_config_prog_path="$(tc-getPKG_CONFIG)"
+ export CC_FOR_BUILD="$(tc-getBUILD_CC)"
+
# ensure proper compiler is detected for Clang builds: bug #831202
export GCC_FOR_TARGET="${CC_FOR_TARGET:-$(tc-getCC)}"
@@ -209,7 +215,7 @@ src_install() {
find "${ED}"/usr -name libiberty.a -delete || die
- # Delete translations that conflict with binutils-libs. #528088
+ # Delete translations that conflict with binutils-libs. bug #528088
# Note: Should figure out how to store these in an internal gdb dir.
if use nls ; then
find "${ED}" \
@@ -253,7 +259,7 @@ src_install() {
# Remove shared info pages
rm -f "${ED}"/usr/share/info/{annotate,bfd,configure,ctf-spec,standards}.info*
- if use python; then
+ if use python ; then
python_optimize "${ED}"/usr/share/gdb/python/gdb
fi
}