summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2018-01-03 21:16:19 +0100
committerMichał Górny <mgorny@gentoo.org>2018-01-03 23:21:34 +0100
commit30941b64416340b5188c2aab7eed7a99b48ea1e2 (patch)
treeb2843fcb21c87b3e948d98d60e496b29b801771c /sys-devel/llvm-common
parentdev-python/pytest-qt: stable on amd64 (diff)
downloadgentoo-30941b64416340b5188c2aab7eed7a99b48ea1e2.tar.gz
gentoo-30941b64416340b5188c2aab7eed7a99b48ea1e2.tar.bz2
gentoo-30941b64416340b5188c2aab7eed7a99b48ea1e2.zip
sys-devel/llvm-common: Add a live ebuild for 6.0 branch
Diffstat (limited to 'sys-devel/llvm-common')
-rw-r--r--sys-devel/llvm-common/llvm-common-6.0.9999.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/sys-devel/llvm-common/llvm-common-6.0.9999.ebuild b/sys-devel/llvm-common/llvm-common-6.0.9999.ebuild
new file mode 100644
index 000000000000..e1149b770438
--- /dev/null
+++ b/sys-devel/llvm-common/llvm-common-6.0.9999.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit git-r3
+
+DESCRIPTION="Common files shared between multiple slots of LLVM"
+HOMEPAGE="https://llvm.org/"
+SRC_URI=""
+EGIT_REPO_URI="https://git.llvm.org/git/llvm.git
+ https://github.com/llvm-mirror/llvm.git"
+EGIT_BRANCH="release_60"
+
+LICENSE="UoI-NCSA"
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+RDEPEND="!sys-devel/llvm:0"
+
+src_unpack() {
+ git-r3_fetch
+ git-r3_checkout '' '' '' utils/vim
+}
+
+src_configure() { :; }
+src_compile() { :; }
+src_test() { :; }
+
+src_install() {
+ insinto /usr/share/vim/vimfiles
+ doins -r utils/vim/*/
+ # some users may find it useful
+ newdoc utils/vim/README README.vim
+ dodoc utils/vim/vimrc
+}