summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-10-01 14:36:26 +0200
committerMichał Górny <mgorny@gentoo.org>2021-10-01 15:26:43 +0200
commitdeb1ee926db9c33747e09a4655b83e569230f536 (patch)
treea5aa790cb6ca6e99d0936191296524bdeb8a37c3 /sys-devel/llvm-common/llvm-common-13.0.0.ebuild
parentsys-kernel/pf-sources: drop 5.14_p3 (diff)
downloadgentoo-deb1ee926db9c33747e09a4655b83e569230f536.tar.gz
gentoo-deb1ee926db9c33747e09a4655b83e569230f536.tar.bz2
gentoo-deb1ee926db9c33747e09a4655b83e569230f536.zip
sys-devel/llvm-common: Bump to 13.0.0 (final)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sys-devel/llvm-common/llvm-common-13.0.0.ebuild')
-rw-r--r--sys-devel/llvm-common/llvm-common-13.0.0.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/sys-devel/llvm-common/llvm-common-13.0.0.ebuild b/sys-devel/llvm-common/llvm-common-13.0.0.ebuild
new file mode 100644
index 000000000000..a2e51ece1ffb
--- /dev/null
+++ b/sys-devel/llvm-common/llvm-common-13.0.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit llvm.org
+
+DESCRIPTION="Common files shared between multiple slots of LLVM"
+HOMEPAGE="https://llvm.org/"
+
+LICENSE="Apache-2.0-with-LLVM-exceptions UoI-NCSA"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~ppc-macos ~x64-macos"
+IUSE=""
+
+RDEPEND="!sys-devel/llvm:0"
+
+LLVM_COMPONENTS=( llvm/utils/vim )
+llvm.org_set_globals
+
+src_install() {
+ insinto /usr/share/vim/vimfiles
+ doins -r */
+ # some users may find it useful
+ newdoc README README.vim
+ dodoc vimrc
+}