summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2019-06-30 20:38:40 +0200
committerJeroen Roovers <jer@gentoo.org>2019-06-30 20:39:21 +0200
commitcfade0ce971b76d22fef2e047a2d657a0987d791 (patch)
tree8b055e3b1a681e6ee9a62a3dc225502c9fee116d /sys-devel/kgcc64/kgcc64-9.1.0.ebuild
parentsys-fs/mp3fs: drop old (diff)
downloadgentoo-cfade0ce971b76d22fef2e047a2d657a0987d791.tar.gz
gentoo-cfade0ce971b76d22fef2e047a2d657a0987d791.tar.bz2
gentoo-cfade0ce971b76d22fef2e047a2d657a0987d791.zip
sys-devel/kgcc64: Version 9.1.0
Package-Manager: Portage-2.3.67, Repoman-2.3.16 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'sys-devel/kgcc64/kgcc64-9.1.0.ebuild')
-rw-r--r--sys-devel/kgcc64/kgcc64-9.1.0.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/sys-devel/kgcc64/kgcc64-9.1.0.ebuild b/sys-devel/kgcc64/kgcc64-9.1.0.ebuild
new file mode 100644
index 000000000000..c99331026f81
--- /dev/null
+++ b/sys-devel/kgcc64/kgcc64-9.1.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+case ${CHOST} in
+ hppa*) CTARGET=hppa64-${CHOST#*-};;
+ mips*) CTARGET=${CHOST/mips/mips64};;
+ powerpc*) CTARGET=${CHOST/powerpc/powerpc64};;
+ s390*) CTARGET=${CHOST/s390/s390x};;
+ sparc*) CTARGET=${CHOST/sparc/sparc64};;
+ i?86*) CTARGET=x86_64-${CHOST#*-};;
+esac
+export CTARGET
+TOOLCHAIN_ALLOWED_LANGS="c"
+GCC_TARGET_NO_MULTILIB=true
+
+PATCH_VER="1.1"
+inherit toolchain
+
+DESCRIPTION="64bit kernel compiler"
+
+# Works on hppa and mips; all other archs, refer to bug #228115
+KEYWORDS="~hppa ~mips"
+
+# unlike every other target, hppa has not unified the 32/64 bit
+# ports in binutils yet
+DEPEND="
+ hppa? ( sys-devel/binutils-hppa64 )
+ !sys-devel/gcc-hppa64
+ !sys-devel/gcc-mips64
+ !sys-devel/gcc-powerpc64
+ !sys-devel/gcc-sparc64"
+
+pkg_postinst() {
+ toolchain_pkg_postinst
+
+ cd "${ROOT}"/usr/bin
+ local x
+ for x in gcc cpp ; do
+ cat <<-EOF >${CTARGET%%-*}-linux-${x}
+ #!/bin/sh
+ exec ${CTARGET}-${x} "\$@"
+ EOF
+ chmod a+rx ${CTARGET%%-*}-linux-${x}
+ done
+}