summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2020-04-28 07:42:51 +0200
committerLars Wendler <polynomial-c@gentoo.org>2020-04-28 07:42:51 +0200
commit9e7e3d355dd66a695c0f69a511cd9c03c7e08a8a (patch)
treef09b93d16f73b52fcab46705694bb4ca5187fa2d /sys-devel/bin86
parentnet-nds/gssproxy: Bump to version 0.8.3 (diff)
downloadgentoo-9e7e3d355dd66a695c0f69a511cd9c03c7e08a8a.tar.gz
gentoo-9e7e3d355dd66a695c0f69a511cd9c03c7e08a8a.tar.bz2
gentoo-9e7e3d355dd66a695c0f69a511cd9c03c7e08a8a.zip
sys-devel/bin86: Don't use colons as sed delimiter
Closes: https://bugs.gentoo.org/710340 Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'sys-devel/bin86')
-rw-r--r--sys-devel/bin86/bin86-0.16.20-r2.ebuild12
-rw-r--r--sys-devel/bin86/bin86-0.16.21.ebuild12
2 files changed, 12 insertions, 12 deletions
diff --git a/sys-devel/bin86/bin86-0.16.20-r2.ebuild b/sys-devel/bin86/bin86-0.16.20-r2.ebuild
index 9e0088919ee0..ae8685567e43 100644
--- a/sys-devel/bin86/bin86-0.16.20-r2.ebuild
+++ b/sys-devel/bin86/bin86-0.16.20-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="5"
@@ -17,11 +17,11 @@ IUSE=""
src_prepare() {
sed -i \
- -e '/^PREFIX/s:=.*:=$(DESTDIR)/usr:' \
- -e '/^MANDIR/s:)/man/man1:)/share/man/man1:' \
- -e '/^INSTALL_OPTS/s:-s::' \
- -e "/^CFLAGS/s:=.*:=${CFLAGS} -D_POSIX_SOURCE ${CPPFLAGS}:" \
- -e "/^LDFLAGS/s:=.*:=${LDFLAGS}:" \
+ -e '/^PREFIX/s|=.*|=$(DESTDIR)/usr|' \
+ -e '/^MANDIR/s|)/man/man1|)/share/man/man1|' \
+ -e '/^INSTALL_OPTS/s|-s||' \
+ -e "/^CFLAGS/s|=.*|=${CFLAGS} -D_POSIX_SOURCE ${CPPFLAGS}|" \
+ -e "/^LDFLAGS/s|=.*|=${LDFLAGS}|" \
Makefile || die
epatch "${FILESDIR}"/${PN}-0.16.17-amd64-build.patch \
"${DISTDIR}"/${P}-fix_lilo_build.patch
diff --git a/sys-devel/bin86/bin86-0.16.21.ebuild b/sys-devel/bin86/bin86-0.16.21.ebuild
index 3e67dfb8467d..ad7a6449a569 100644
--- a/sys-devel/bin86/bin86-0.16.21.ebuild
+++ b/sys-devel/bin86/bin86-0.16.21.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="6"
@@ -17,11 +17,11 @@ IUSE=""
src_prepare() {
use elibc_musl && CPPFLAGS="${CPPFLAGS} -U__linux__"
sed -i \
- -e '/^PREFIX/s:=.*:=$(DESTDIR)/usr:' \
- -e '/^MANDIR/s:)/man/man1:)/share/man/man1:' \
- -e '/^INSTALL_OPTS/s:-s::' \
- -e "/^CFLAGS/s:=.*:=${CFLAGS} -D_POSIX_SOURCE ${CPPFLAGS}:" \
- -e "/^LDFLAGS/s:=.*:=${LDFLAGS}:" \
+ -e '/^PREFIX/s|=.*|=$(DESTDIR)/usr|' \
+ -e '/^MANDIR/s|)/man/man1|)/share/man/man1|' \
+ -e '/^INSTALL_OPTS/s|-s||' \
+ -e "/^CFLAGS/s|=.*|=${CFLAGS} -D_POSIX_SOURCE ${CPPFLAGS}|" \
+ -e "/^LDFLAGS/s|=.*|=${LDFLAGS}|" \
Makefile || die
epatch "${FILESDIR}"/${PN}-0.16.17-amd64-build.patch
eapply_user