summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArsen Arsenović <arsen@gentoo.org>2023-11-15 13:05:34 +0100
committerSam James <sam@gentoo.org>2023-11-22 00:00:08 +0000
commitc6d66d52fd0da4410f23ff947bf13a480c89aded (patch)
tree5f5dfb5b733eb8a49f035f1c0a816c00c10e1d69 /sys-devel/automake-vanilla
parentsys-devel/automake-vanilla: resolve conflicts with sys-devel/automake (diff)
downloadgentoo-c6d66d52fd0da4410f23ff947bf13a480c89aded.tar.gz
gentoo-c6d66d52fd0da4410f23ff947bf13a480c89aded.tar.bz2
gentoo-c6d66d52fd0da4410f23ff947bf13a480c89aded.zip
sys-devel/automake{,-vanilla}: fix idx computation for 9999
Signed-off-by: Arsen Arsenović <arsen@gentoo.org> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-devel/automake-vanilla')
-rw-r--r--sys-devel/automake-vanilla/automake-vanilla-9999.ebuild9
1 files changed, 7 insertions, 2 deletions
diff --git a/sys-devel/automake-vanilla/automake-vanilla-9999.ebuild b/sys-devel/automake-vanilla/automake-vanilla-9999.ebuild
index 878f8d02ab85..d6c826dc6125 100644
--- a/sys-devel/automake-vanilla/automake-vanilla-9999.ebuild
+++ b/sys-devel/automake-vanilla/automake-vanilla-9999.ebuild
@@ -104,8 +104,13 @@ src_install() {
done
popd >/dev/null || die
- local major="$(ver_cut 1)"
- local minor="$(ver_cut 2)"
+ if [[ ${PV} == 9999 ]]; then
+ local major="89"
+ local minor="999"
+ else
+ local major="$(ver_cut 1)"
+ local minor="$(ver_cut 2)"
+ fi
local idx="$((99999-(major*1000+minor)))"
newenvd - "07automake${idx}" <<-EOF
INFOPATH="${MY_INFODIR}"