summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-01-02 03:02:35 +0000
committerSam James <sam@gentoo.org>2022-01-02 03:02:35 +0000
commitfab20bbcbf246d0868b8d70b02ced33972f7c137 (patch)
tree508e152c79474de18cd8af12bcc8e5245a519175 /sys-cluster
parentnet-analyzer/alive: add 2.0.4 (diff)
downloadgentoo-fab20bbcbf246d0868b8d70b02ced33972f7c137.tar.gz
gentoo-fab20bbcbf246d0868b8d70b02ced33972f7c137.tar.bz2
gentoo-fab20bbcbf246d0868b8d70b02ced33972f7c137.zip
sys-cluster/openmpi: add upstream patch for build failure
Closes: https://bugs.gentoo.org/828123 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/openmpi/files/openmpi-4.1.2-missing-includes.patch32
-rw-r--r--sys-cluster/openmpi/openmpi-4.1.2.ebuild6
2 files changed, 37 insertions, 1 deletions
diff --git a/sys-cluster/openmpi/files/openmpi-4.1.2-missing-includes.patch b/sys-cluster/openmpi/files/openmpi-4.1.2-missing-includes.patch
new file mode 100644
index 000000000000..89abc049df4e
--- /dev/null
+++ b/sys-cluster/openmpi/files/openmpi-4.1.2-missing-includes.patch
@@ -0,0 +1,32 @@
+https://github.com/open-mpi/ompi/commit/927e9aa97373dac652f9cba4813e6ee609ca2830
+https://bugs.gentoo.org/828123
+
+From: George Bosilca <bosilca@icl.utk.edu>
+Date: Tue, 23 Nov 2021 14:28:11 -0500
+Subject: [PATCH] Fix compile failure with enable-heterogeneous.
+
+An internal header file was missing, leading to an incomplete type.
+
+Fixes #9697.
+
+Signed-off-by: George Bosilca <bosilca@icl.utk.edu>
+--- a/ompi/mca/coll/base/coll_base_alltoall.c
++++ b/ompi/mca/coll/base/coll_base_alltoall.c
+@@ -29,6 +29,7 @@
+ #include "mpi.h"
+ #include "ompi/constants.h"
+ #include "ompi/datatype/ompi_datatype.h"
++#include "opal/datatype/opal_convertor_internal.h"
+ #include "ompi/communicator/communicator.h"
+ #include "ompi/mca/coll/coll.h"
+ #include "ompi/mca/coll/base/coll_tags.h"
+--- a/ompi/mca/coll/base/coll_base_alltoallv.c
++++ b/ompi/mca/coll/base/coll_base_alltoallv.c
+@@ -31,6 +31,7 @@
+ #include "mpi.h"
+ #include "ompi/constants.h"
+ #include "ompi/datatype/ompi_datatype.h"
++#include "opal/datatype/opal_convertor_internal.h"
+ #include "ompi/communicator/communicator.h"
+ #include "ompi/mca/coll/coll.h"
+ #include "ompi/mca/coll/base/coll_tags.h"
diff --git a/sys-cluster/openmpi/openmpi-4.1.2.ebuild b/sys-cluster/openmpi/openmpi-4.1.2.ebuild
index 6652c805f75a..036f1cbe8cb6 100644
--- a/sys-cluster/openmpi/openmpi-4.1.2.ebuild
+++ b/sys-cluster/openmpi/openmpi-4.1.2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -71,6 +71,10 @@ MULTILIB_WRAPPED_HEADERS=(
/usr/include/openmpi/mpiext/mpiext_cuda_c.h
)
+PATCHES=(
+ "${FILESDIR}"/${PN}-4.1.2-missing-includes.patch
+)
+
pkg_setup() {
fortran-2_pkg_setup
java-pkg-opt-2_pkg_setup