summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2022-08-22 13:27:40 -0700
committerPatrick McLean <chutzpah@gentoo.org>2022-08-22 13:29:27 -0700
commitbf4283275302cbdf950f965f94920071068a2a8d (patch)
tree5c722841d3c50f5e401dec761dc5decbfb7cfd04 /sys-cluster
parentsys-cluster/ceph: Fix boost dep in 16.2.8 (bug #865509) (diff)
downloadgentoo-bf4283275302cbdf950f965f94920071068a2a8d.tar.gz
gentoo-bf4283275302cbdf950f965f94920071068a2a8d.tar.bz2
gentoo-bf4283275302cbdf950f965f94920071068a2a8d.zip
sys-cluster/ceph: gcc12 (bug #866039), boost dep (bug #865509)
Also reduce filesdir usage a bit. Closes: https://bugs.gentoo.org/865509 Closes: https://bugs.gentoo.org/866039 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/ceph/Manifest1
-rw-r--r--sys-cluster/ceph/ceph-16.2.10-r1.ebuild (renamed from sys-cluster/ceph/ceph-16.2.10.ebuild)5
-rw-r--r--sys-cluster/ceph/files/ceph-15.2.15-snappy-1.1.9.patch22
-rw-r--r--sys-cluster/ceph/files/ceph-16.2.10-gcc12.patch45
4 files changed, 49 insertions, 24 deletions
diff --git a/sys-cluster/ceph/Manifest b/sys-cluster/ceph/Manifest
index 1d0f28a97518..85706e051c7c 100644
--- a/sys-cluster/ceph/Manifest
+++ b/sys-cluster/ceph/Manifest
@@ -1,4 +1,5 @@
DIST ceph-15.2.17.tar.gz 148640102 BLAKE2B a10dd702ffca005a8741bff645eaf2f671300be969edf9e9e321e29abdc34a403de7c56684fd1509d30c2bd32b996fff3aaa88d1d08c3d258d6f5ef43ecefddf SHA512 952cd4db057fcab5efa3c6331fbc19cf1e904f5855266c2ed13e41ffb2e5a7d18ed133bd113fea493149005a182f429eef39931c4ceac7776aefe84a208a745a
+DIST ceph-16.2.10.tar.gz 157176743 BLAKE2B 065b6f1941f87fde150ab22ba45aa9f58069acf7f33a483456faf0a26e41936846944e800ccd7f99bd8863db8438ae70804621522f75065c0b2506522c4fdd7d SHA512 ae164c24462c3e08763d202acc3e2fe86ffc09f312b5059bae07863e804fc47bd158fc130aa2923246ffcfe26ae6d6d9317326aec96373226e6f9030d7123c8b
DIST ceph-16.2.9.tar.gz 157168096 BLAKE2B 0a667a9699925cfc920ca0cc535e5331cbcd95997fb0b9816a4d84c8add454b6b17813018bc1d1de07c802167ef50aa528704b10b01f42759189392ccdb5088f SHA512 bf369038ad6383f88abbed267f0239e9d8a1d33b46b34ed260aeeb1fda1b374cb6e658238e1ace013fbbb68e73b8cd2922b7def318d7a110e5f4560eeae8fca3
DIST ceph-17.2.3.tar.gz 168821857 BLAKE2B 21ec5ac33591ae8b22eae3d88680ae87340e639cc21cb9c79bc4fb2f7b6cc7e93aa6b5af0242a6c094a4af9808a2b6f86b6bd7e3c8f247a513c91defa6d4e4a9 SHA512 fd6e057ba8440f69423e870dddb2705d68015089ff8d97356bdc359c2ab41e19351fb1c914330de6ba05180f48e328e3ea4c877e9dd80be049e2ec5895068595
DIST ceph-xsimd-17.2.3.tar.gz 173025 BLAKE2B 54679c24804c195ae55b9f49589e331dde92c6d89aaa20e827539e9a4e0010c7549cdd5cf02a7ebed83f953ab2a6f1d9cc9a98cf45c3dc7758ae4938c9c43713 SHA512 ecc58e7909648aaa22aefbf76ee2c5a2bece4b1b88da9c7eda1b69a46247e619ff99c4366afd6015f95debd68c1a6b89292c677b9049462d0fc0255fbc0c2a33
diff --git a/sys-cluster/ceph/ceph-16.2.10.ebuild b/sys-cluster/ceph/ceph-16.2.10-r1.ebuild
index 7100183dd1ba..fab42ed01f7d 100644
--- a/sys-cluster/ceph/ceph-16.2.10.ebuild
+++ b/sys-cluster/ceph/ceph-16.2.10-r1.ebuild
@@ -40,7 +40,7 @@ DEPEND="
app-arch/bzip2:=
app-arch/lz4:=
app-arch/snappy:=
- || ( >=app-arch/snappy-1.1.9-r1 <app-arch/snappy-1.1.9 )
+ >=app-arch/snappy-1.1.9-r1
app-arch/zstd:=
app-shells/bash:0
app-misc/jq:=
@@ -92,7 +92,7 @@ DEPEND="
rdma? ( sys-cluster/rdma-core:= )
spdk? ( dev-util/cunit )
sqlite? ( dev-db/sqlite:= )
- system-boost? ( >=dev-libs/boost-1.72:=[threads(+),context,python,${PYTHON_USEDEP}] )
+ system-boost? ( >=dev-libs/boost-1.72:=[threads(+),context,python,${PYTHON_USEDEP},zlib] )
!system-boost? ( $(python_gen_impl_dep '' 3.8 3.9) )
uring? ( sys-libs/liburing:= )
xfs? ( sys-fs/xfsprogs:= )
@@ -218,6 +218,7 @@ PATCHES=(
"${FILESDIR}/ceph-16.2.7-string-includes.patch"
"${FILESDIR}/ceph-17.2.0-fuse3.patch"
"${FILESDIR}/ceph-16.2.9-python310.patch"
+ "${FILESDIR}/ceph-16.2.10-gcc12.patch"
)
check-reqs_export_vars() {
diff --git a/sys-cluster/ceph/files/ceph-15.2.15-snappy-1.1.9.patch b/sys-cluster/ceph/files/ceph-15.2.15-snappy-1.1.9.patch
index 3b38c1708733..3319f3989ff9 100644
--- a/sys-cluster/ceph/files/ceph-15.2.15-snappy-1.1.9.patch
+++ b/sys-cluster/ceph/files/ceph-15.2.15-snappy-1.1.9.patch
@@ -1,25 +1,3 @@
-From 4c13a798dcf2e783afd7558bf3541dc025de854a Mon Sep 17 00:00:00 2001
-From: Nathan Cutler <ncutler@suse.com>
-Date: Tue, 27 Jul 2021 15:27:58 +0200
-Subject: [PATCH] compression/snappy: use uint32_t to be compatible with 1.1.9
-
-The snappy project made the following change in snappy.h between version 1.1.8
-and 1.1.9:
-
-< bool GetUncompressedLength(Source* source, uint32_t* result);
----
-> bool GetUncompressedLength(Source* source, uint32* result);
-
-This causes Ceph to FTBFS with snappy 1.1.9.
-
-Thanks to Chris Denice for bringing this to our attention via Redmine.
-
-Fixes: https://tracker.ceph.com/issues/50934
-Signed-off-by: Nathan Cutler <ncutler@suse.com>
----
- src/compressor/snappy/SnappyCompressor.h | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
diff --git a/src/compressor/snappy/SnappyCompressor.h b/src/compressor/snappy/SnappyCompressor.h
index 25393f8dc1ff4..93206c4007bed 100644
--- a/src/compressor/snappy/SnappyCompressor.h
diff --git a/sys-cluster/ceph/files/ceph-16.2.10-gcc12.patch b/sys-cluster/ceph/files/ceph-16.2.10-gcc12.patch
new file mode 100644
index 000000000000..79bc5d41f410
--- /dev/null
+++ b/sys-cluster/ceph/files/ceph-16.2.10-gcc12.patch
@@ -0,0 +1,45 @@
+diff --git a/src/include/buffer.h b/src/include/buffer.h
+index 7c8f90e9fb5d3..71cb01935000b 100644
+--- a/src/include/buffer.h
++++ b/src/include/buffer.h
+@@ -41,6 +41,7 @@
+ #include <iosfwd>
+ #include <iomanip>
+ #include <list>
++#include <memory>
+ #include <vector>
+ #include <string>
+ #if __cplusplus >= 201703L
+
+diff --git a/src/rgw/rgw_string.h b/src/rgw/rgw_string.h
+index 257daa9c1fe6e..90e64f98a2587 100644
+--- a/src/rgw/rgw_string.h
++++ b/src/rgw/rgw_string.h
+@@ -8,6 +8,8 @@
+ #include <stdlib.h>
+ #include <limits.h>
+ #include <string_view>
++#include <string>
++#include <stdexcept>
+
+ #include <boost/container/small_vector.hpp>
+
+
+diff --git a/src/test/encoding.cc b/src/test/encoding.cc
+index 6d252fae18b71..f18901cbd27d9 100644
+--- a/src/test/encoding.cc
++++ b/src/test/encoding.cc
+@@ -334,11 +334,11 @@ void lame_decoder(int which) {
+ }
+
+ TEST(EncodingException, Macros) {
+- for (unsigned i = 0; i < sizeof(expected_what)/sizeof(expected_what[0]); i++) {
++ for (unsigned i = 0; i < std::size(expected_what); i++) {
+ try {
+ lame_decoder(i);
+ } catch (const exception& e) {
+- ASSERT_EQ(string(expected_what[i]), string(e.what()));
++ ASSERT_NE(string(e.what()).find(expected_what[i]), string::npos);
+ }
+ }
+ }