summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <patrick.mclean@sony.com>2021-10-29 13:49:25 -0700
committerPatrick McLean <chutzpah@gentoo.org>2021-10-29 13:49:25 -0700
commitaddb9b18a8f99b1be688372f1bb0e2d95cd4ace6 (patch)
tree1f109b34d12b25838d3fdb97d0bf20c4b4d5e93c /sys-cluster
parentdev-perl/Finance-Quote: Remove old (diff)
downloadgentoo-addb9b18a8f99b1be688372f1bb0e2d95cd4ace6.tar.gz
gentoo-addb9b18a8f99b1be688372f1bb0e2d95cd4ace6.tar.bz2
gentoo-addb9b18a8f99b1be688372f1bb0e2d95cd4ace6.zip
sys-cluster/ceph: 14.2.22 add fix for newer snappy
Copyright: Sony Interactive Entertainment Inc. Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/ceph/ceph-14.2.22.ebuild1
-rw-r--r--sys-cluster/ceph/files/ceph-14.2.22-snappy-uint32.patch13
2 files changed, 14 insertions, 0 deletions
diff --git a/sys-cluster/ceph/ceph-14.2.22.ebuild b/sys-cluster/ceph/ceph-14.2.22.ebuild
index 1288ebd6a786..7e642968cc1f 100644
--- a/sys-cluster/ceph/ceph-14.2.22.ebuild
+++ b/sys-cluster/ceph/ceph-14.2.22.ebuild
@@ -185,6 +185,7 @@ PATCHES=(
"${FILESDIR}/ceph-14.2.22-build-without-mgr.patch"
"${FILESDIR}/ceph-14.2.11-systemd-unit-fix.patch"
"${FILESDIR}/ceph-15.2.9-dont-compile-isal_compress-if-don-t-have-SSE4_1.patch"
+ "${FILESDIR}/ceph-14.2.22-snappy-uint32.patch"
)
check-reqs_export_vars() {
diff --git a/sys-cluster/ceph/files/ceph-14.2.22-snappy-uint32.patch b/sys-cluster/ceph/files/ceph-14.2.22-snappy-uint32.patch
new file mode 100644
index 000000000000..c783558a1758
--- /dev/null
+++ b/sys-cluster/ceph/files/ceph-14.2.22-snappy-uint32.patch
@@ -0,0 +1,13 @@
+diff --git a/src/compressor/snappy/SnappyCompressor.h b/src/compressor/snappy/SnappyCompressor.h
+index 0291a923112..352ab9a9bcf 100644
+--- a/src/compressor/snappy/SnappyCompressor.h
++++ b/src/compressor/snappy/SnappyCompressor.h
+@@ -96,7 +96,7 @@ class SnappyCompressor : public Compressor {
+ if (qat_enabled)
+ return qat_accel.decompress(p, compressed_len, dst);
+ #endif
+- snappy::uint32 res_len = 0;
++ uint32_t res_len = 0;
+ BufferlistSource source_1(p, compressed_len);
+ if (!snappy::GetUncompressedLength(&source_1, &res_len)) {
+ return -1;