summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-02-07 21:22:59 +0100
committerMichał Górny <mgorny@gentoo.org>2020-02-09 17:37:07 +0100
commit1d1ea42437e5468eecc707d5503a9f5b612ee393 (patch)
treec09a582064f37c9d41a1ccc6ce43364e6fec64ad /sys-cluster
parentsys-cluster/charliecloud: Switch to PYTHON_MULTI_USEDEP API (diff)
downloadgentoo-1d1ea42437e5468eecc707d5503a9f5b612ee393.tar.gz
gentoo-1d1ea42437e5468eecc707d5503a9f5b612ee393.tar.bz2
gentoo-1d1ea42437e5468eecc707d5503a9f5b612ee393.zip
sys-cluster/rdma-core: Switch to PYTHON_MULTI_USEDEP API
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/rdma-core/rdma-core-26.0-r1.ebuild (renamed from sys-cluster/rdma-core/rdma-core-26.0.ebuild)6
-rw-r--r--sys-cluster/rdma-core/rdma-core-26.1.ebuild6
-rw-r--r--sys-cluster/rdma-core/rdma-core-27.0-r1.ebuild (renamed from sys-cluster/rdma-core/rdma-core-27.0.ebuild)6
-rw-r--r--sys-cluster/rdma-core/rdma-core-9999.ebuild6
4 files changed, 20 insertions, 4 deletions
diff --git a/sys-cluster/rdma-core/rdma-core-26.0.ebuild b/sys-cluster/rdma-core/rdma-core-26.0-r1.ebuild
index 01d4ceade5f6..39c6e4a73b19 100644
--- a/sys-cluster/rdma-core/rdma-core-26.0.ebuild
+++ b/sys-cluster/rdma-core/rdma-core-26.0-r1.ebuild
@@ -31,7 +31,11 @@ COMMON_DEPEND="
python? ( ${PYTHON_DEPS} )"
DEPEND="${COMMON_DEPEND}
- python? ( dev-python/cython[${PYTHON_USEDEP}] )"
+ python? (
+ $(python_gen_cond_dep '
+ dev-python/cython[${PYTHON_MULTI_USEDEP}]
+ ')
+ )"
RDEPEND="${COMMON_DEPEND}
!sys-fabric/infiniband-diags
diff --git a/sys-cluster/rdma-core/rdma-core-26.1.ebuild b/sys-cluster/rdma-core/rdma-core-26.1.ebuild
index ef62e9d9e81b..39537f768f10 100644
--- a/sys-cluster/rdma-core/rdma-core-26.1.ebuild
+++ b/sys-cluster/rdma-core/rdma-core-26.1.ebuild
@@ -31,7 +31,11 @@ COMMON_DEPEND="
python? ( ${PYTHON_DEPS} )"
DEPEND="${COMMON_DEPEND}
- python? ( dev-python/cython[${PYTHON_USEDEP}] )"
+ python? (
+ $(python_gen_cond_dep '
+ dev-python/cython[${PYTHON_MULTI_USEDEP}]
+ ')
+ )"
RDEPEND="${COMMON_DEPEND}
!sys-fabric/infiniband-diags
diff --git a/sys-cluster/rdma-core/rdma-core-27.0.ebuild b/sys-cluster/rdma-core/rdma-core-27.0-r1.ebuild
index be00b10a0c1f..9313f938a56d 100644
--- a/sys-cluster/rdma-core/rdma-core-27.0.ebuild
+++ b/sys-cluster/rdma-core/rdma-core-27.0-r1.ebuild
@@ -31,7 +31,11 @@ COMMON_DEPEND="
python? ( ${PYTHON_DEPS} )"
DEPEND="${COMMON_DEPEND}
- python? ( dev-python/cython[${PYTHON_USEDEP}] )"
+ python? (
+ $(python_gen_cond_dep '
+ dev-python/cython[${PYTHON_MULTI_USEDEP}]
+ ')
+ )"
RDEPEND="${COMMON_DEPEND}
!sys-fabric/infiniband-diags
diff --git a/sys-cluster/rdma-core/rdma-core-9999.ebuild b/sys-cluster/rdma-core/rdma-core-9999.ebuild
index a72f49a1997d..a8c381b38698 100644
--- a/sys-cluster/rdma-core/rdma-core-9999.ebuild
+++ b/sys-cluster/rdma-core/rdma-core-9999.ebuild
@@ -31,7 +31,11 @@ COMMON_DEPEND="
python? ( ${PYTHON_DEPS} )"
DEPEND="${COMMON_DEPEND}
- python? ( dev-python/cython[${PYTHON_USEDEP}] )"
+ python? (
+ $(python_gen_cond_dep '
+ dev-python/cython[${PYTHON_MULTI_USEDEP}]
+ ')
+ )"
RDEPEND="${COMMON_DEPEND}
!!sys-fabric/infiniband-diags