summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-03-07 01:54:21 +0000
committerSam James <sam@gentoo.org>2022-03-07 01:54:52 +0000
commit33650b0188bc349f12c62bab24856c2d3ccf9bdb (patch)
tree0b916ebfd84de8293624584050149f2a1c0f4c18 /sys-cluster/torque
parentdev-python/rtimulib: drop 7.2.1-r1 (diff)
downloadgentoo-33650b0188bc349f12c62bab24856c2d3ccf9bdb.tar.gz
gentoo-33650b0188bc349f12c62bab24856c2d3ccf9bdb.tar.bz2
gentoo-33650b0188bc349f12c62bab24856c2d3ccf9bdb.zip
sys-cluster/torque: fix more pthread issues
Possibly only an issue with glibc 2.33 (not 2.34) somehow? Fixed now anyway. Bug: https://bugs.gentoo.org/827474 Bug: https://bugs.gentoo.org/689876 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-cluster/torque')
-rw-r--r--sys-cluster/torque/files/torque-6.0.4-pthreads-deux.patch13
-rw-r--r--sys-cluster/torque/torque-6.0.4-r2.ebuild4
2 files changed, 16 insertions, 1 deletions
diff --git a/sys-cluster/torque/files/torque-6.0.4-pthreads-deux.patch b/sys-cluster/torque/files/torque-6.0.4-pthreads-deux.patch
new file mode 100644
index 000000000000..f9b7046daeac
--- /dev/null
+++ b/sys-cluster/torque/files/torque-6.0.4-pthreads-deux.patch
@@ -0,0 +1,13 @@
+Additional pthread/glibc 2.34 patch.
+
+https://bugs.gentoo.org/827474
+--- a/src/lib/Libpbs/Makefile.am
++++ b/src/lib/Libpbs/Makefile.am
+@@ -7,6 +7,7 @@ CLEANFILES = *.gcda *.gcno *.gcov
+ lib_LTLIBRARIES = libtorque.la
+
+ libtorque_la_LDFLAGS = -version-info 2:0:0
++libtorque_la_LIBADD = $(PTHREAD_LIBS)
+
+ libtorque_la_SOURCES = ../Libcsv/csv.c ../Libdis/dis.c \
+ ../Libdis/discui_.c ../Libdis/discul_.c \
diff --git a/sys-cluster/torque/torque-6.0.4-r2.ebuild b/sys-cluster/torque/torque-6.0.4-r2.ebuild
index a9c2d9cf37c6..41b0211bd754 100644
--- a/sys-cluster/torque/torque-6.0.4-r2.ebuild
+++ b/sys-cluster/torque/torque-6.0.4-r2.ebuild
@@ -54,6 +54,7 @@ PATCHES=(
"${FILESDIR}"/${P}-no-openssl.patch
"${FILESDIR}"/${P}-error_buf_overflow_prevent.patch
"${WORKDIR}"/${P}-glibc-2.34-pthread.patch
+ "${FILESDIR}"/${P}-pthreads-deux.patch
)
pkg_setup() {
@@ -98,7 +99,8 @@ src_prepare() {
src_configure() {
append-cflags "-fpermissive"
- econf \
+ # Force Bash for configure as there's a lot of issues with configure.ac and such here
+ CONFIG_SHELL="${BROOT}/bin/bash" econf \
$(use_enable tk gui) \
$(use_enable tk tcl-qstat) \
$(use_enable syslog) \