summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2017-09-17 23:44:29 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2017-09-17 23:55:05 -0500
commit315a294356e3aff439c7bb0e4fae462111dfb2c0 (patch)
tree5c3f9332c50ca054f087b164716abe76cb0e2347 /sys-cluster/heat
parentsys-cluster/cinder: updating init again (diff)
downloadgentoo-315a294356e3aff439c7bb0e4fae462111dfb2c0.tar.gz
gentoo-315a294356e3aff439c7bb0e4fae462111dfb2c0.tar.bz2
gentoo-315a294356e3aff439c7bb0e4fae462111dfb2c0.zip
sys-cluster/heat: updating init
Package-Manager: Portage-2.3.8, Repoman-2.3.3
Diffstat (limited to 'sys-cluster/heat')
-rw-r--r--sys-cluster/heat/files/heat.initd-216
-rw-r--r--sys-cluster/heat/heat-2017.2.9999.ebuild2
-rw-r--r--sys-cluster/heat/heat-9.0.0.ebuild2
3 files changed, 18 insertions, 2 deletions
diff --git a/sys-cluster/heat/files/heat.initd-2 b/sys-cluster/heat/files/heat.initd-2
new file mode 100644
index 000000000000..2161aa9918ee
--- /dev/null
+++ b/sys-cluster/heat/files/heat.initd-2
@@ -0,0 +1,16 @@
+#!/sbin/openrc-run
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+description="Starts ${SVCNAME} service for OpenStack"
+
+command=/usr/bin/${SVCNAME}
+command_user="${HEAT_USER:-heat}"
+command_background=yes
+command_args="--config-file /etc/heat/heat.conf --log-file ${HEAT_LOGDIR:-/var/log/heat}/${SVCNAME}.log"
+pidfile=/run/${SVCNAME}.pid
+required_files=/etc/heat/heat.conf
+
+depend() {
+ need net
+}
diff --git a/sys-cluster/heat/heat-2017.2.9999.ebuild b/sys-cluster/heat/heat-2017.2.9999.ebuild
index 66ec5b6da472..04ed5348102c 100644
--- a/sys-cluster/heat/heat-2017.2.9999.ebuild
+++ b/sys-cluster/heat/heat-2017.2.9999.ebuild
@@ -145,7 +145,7 @@ python_install_all() {
dodir /etc/heat/templates
for svc in api api-cfn engine; do
- newinitd "${FILESDIR}/heat.initd" heat-${svc}
+ newinitd "${FILESDIR}/heat.initd-2" heat-${svc}
done
insinto /etc/heat
diff --git a/sys-cluster/heat/heat-9.0.0.ebuild b/sys-cluster/heat/heat-9.0.0.ebuild
index d1e8a595c47c..77fbb01c85d9 100644
--- a/sys-cluster/heat/heat-9.0.0.ebuild
+++ b/sys-cluster/heat/heat-9.0.0.ebuild
@@ -144,7 +144,7 @@ python_install_all() {
dodir /etc/heat/templates
for svc in api api-cfn engine; do
- newinitd "${FILESDIR}/heat.initd" heat-${svc}
+ newinitd "${FILESDIR}/heat.initd-2" heat-${svc}
done
insinto /etc/heat