summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2024-01-16 12:39:58 -0500
committerMike Gilbert <floppym@gentoo.org>2024-01-16 12:39:58 -0500
commite33d4b0286c7ba1ade27f66ff352ce18e1e3273f (patch)
tree19333a6e4415972499b0b3cd15636861ad14f0cf /sys-boot
parentsys-boot/grub: drop 2.06-r8 (diff)
downloadgentoo-e33d4b0286c7ba1ade27f66ff352ce18e1e3273f.tar.gz
gentoo-e33d4b0286c7ba1ade27f66ff352ce18e1e3273f.tar.bz2
gentoo-e33d4b0286c7ba1ade27f66ff352ce18e1e3273f.zip
sys-boot/grub: set QA_CONFIG_IMPL_DECL_SKIP
Closes: https://bugs.gentoo.org/900348 Signed-off-by: Mike Gilbert <floppym@gentoo.org>
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/grub/grub-2.06-r9.ebuild5
-rw-r--r--sys-boot/grub/grub-2.12-r1.ebuild5
-rw-r--r--sys-boot/grub/grub-9999.ebuild5
3 files changed, 15 insertions, 0 deletions
diff --git a/sys-boot/grub/grub-2.06-r9.ebuild b/sys-boot/grub/grub-2.06-r9.ebuild
index 49676a74f04d..31dc1e97ca87 100644
--- a/sys-boot/grub/grub-2.06-r9.ebuild
+++ b/sys-boot/grub/grub-2.06-r9.ebuild
@@ -310,6 +310,11 @@ src_install() {
# https://bugs.gentoo.org/231935
dostrip -x /usr/lib/grub
+
+ if use elibc_musl; then
+ # https://bugs.gentoo.org/900348
+ QA_CONFIG_IMPL_DECL_SKIP=( re_set_syntax re_compile_pattern re_search )
+ fi
}
pkg_postinst() {
diff --git a/sys-boot/grub/grub-2.12-r1.ebuild b/sys-boot/grub/grub-2.12-r1.ebuild
index 80ebc54a6379..95e5fdb5c08e 100644
--- a/sys-boot/grub/grub-2.12-r1.ebuild
+++ b/sys-boot/grub/grub-2.12-r1.ebuild
@@ -314,6 +314,11 @@ src_install() {
# https://bugs.gentoo.org/231935
dostrip -x /usr/lib/grub
+
+ if use elibc_musl; then
+ # https://bugs.gentoo.org/900348
+ QA_CONFIG_IMPL_DECL_SKIP=( re_set_syntax re_compile_pattern re_search )
+ fi
}
pkg_postinst() {
diff --git a/sys-boot/grub/grub-9999.ebuild b/sys-boot/grub/grub-9999.ebuild
index a8801791925e..4146c10c16ea 100644
--- a/sys-boot/grub/grub-9999.ebuild
+++ b/sys-boot/grub/grub-9999.ebuild
@@ -310,6 +310,11 @@ src_install() {
# https://bugs.gentoo.org/231935
dostrip -x /usr/lib/grub
+
+ if use elibc_musl; then
+ # https://bugs.gentoo.org/900348
+ QA_CONFIG_IMPL_DECL_SKIP=( re_set_syntax re_compile_pattern re_search )
+ fi
}
pkg_postinst() {