summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolić <jsmolic@gentoo.org>2023-01-08 13:21:10 +0100
committerJakov Smolić <jsmolic@gentoo.org>2023-01-08 13:21:10 +0100
commit00a8f5c02b970e437ba0e739ffa39484c87372a4 (patch)
tree6aee77482ae03f4f6af5aae6faaeb03b01e22b9b /sys-boot
parentdev-ruby/logue: treeclean (diff)
downloadgentoo-00a8f5c02b970e437ba0e739ffa39484c87372a4.tar.gz
gentoo-00a8f5c02b970e437ba0e739ffa39484c87372a4.tar.bz2
gentoo-00a8f5c02b970e437ba0e739ffa39484c87372a4.zip
sys-boot/mbr-gpt: treeclean
Closes: https://bugs.gentoo.org/884371 Closes: https://bugs.gentoo.org/832025 Signed-off-by: Jakov Smolić <jsmolic@gentoo.org>
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/mbr-gpt/Manifest1
-rw-r--r--sys-boot/mbr-gpt/mbr-gpt-0.0.1-r1.ebuild72
-rw-r--r--sys-boot/mbr-gpt/mbr-gpt-0.0.1-r2.ebuild74
-rw-r--r--sys-boot/mbr-gpt/metadata.xml11
4 files changed, 0 insertions, 158 deletions
diff --git a/sys-boot/mbr-gpt/Manifest b/sys-boot/mbr-gpt/Manifest
deleted file mode 100644
index 11ccdc8ea92d..000000000000
--- a/sys-boot/mbr-gpt/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST mbr-gpt_0.0.1.tar.gz 15861 BLAKE2B 00c6741fa5543af435cee97132510126d0301db2fb50712d438703165507125b4981844cb4a841b11bad075af5effb746fd3aa04e6834fb051536b250c01f7ad SHA512 eaabd84fc749ddee8fa40632ad49e15e894bf35a881fb7c35ba22796c2459a886e9bda601595e58d29567ff26959ae2befe6aec5db397d15e1dc5a292dafe165
diff --git a/sys-boot/mbr-gpt/mbr-gpt-0.0.1-r1.ebuild b/sys-boot/mbr-gpt/mbr-gpt-0.0.1-r1.ebuild
deleted file mode 100644
index 1b062d5e5648..000000000000
--- a/sys-boot/mbr-gpt/mbr-gpt-0.0.1-r1.ebuild
+++ /dev/null
@@ -1,72 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit toolchain-funcs
-
-DESCRIPTION="An MBR that can handle BIOS-based boot on GPT"
-MY_P="${PN}_${PV}"
-HOMEPAGE="https://web.archive.org/web/20080704173538/http://aybabtu.com/mbr-gpt/"
-SRC_URI="https://dev.gentoo.org/~robbat2/distfiles/${MY_P}.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0"
-# This should probably NEVER go to stable. It's crazy advanced dangerous magic.
-# It's also pure ASM, so not suitable for elsewhere anyway.
-# Please don't remove it, robbat2 has a box that depends on it for # booting!
-KEYWORDS="~amd64 ~x86"
-
-# It only depends on binutils/gcc/make, and doesn't link against libc even.
-DEPEND=""
-RDEPEND=""
-
-# It's a mostly an MBR block and it does use the executable stack.
-QA_WX_LOAD="usr/lib/${PN}/boot.elf"
-QA_PRESTRIPPED="${QA_WX_LOAD}"
-QA_FLAGS_IGNORED="${QA_WX_LOAD}"
-
-# Don't strip it either; this binary reboots your host!
-RESTRICT="binchecks strip"
-
-src_prepare() {
- default
-
- # Messy upstream
- emake clean
-
- # Need to build it 32-bit for the MBR
- # Btw, no CFLAGS are respected, it's ASM!
- if use amd64 ; then
- sed -i -e 's/-Wall/-Wall -m32/g' "${S}"/Makefile || die
- fi
-}
-
-src_compile() {
- emake CC="$(tc-getCC)"
- # validate the size, it MUST fit into an MBR (440 bytes!)
- size=$(stat --printf='%s' mbr)
- if test $size -gt 440; then
- die "Compiled MBR is too large! Must be at most 440 bytes, was $size"
- fi
-}
-
-src_install() {
- # get_libdir is not correct here. We want this to go into a 32-bit library
- # location.
- insinto /usr/lib/${PN}
- doins mbr
-
- exeinto /usr/lib/${PN}
- exeopts -m 700
- doexe boot.elf
-
- dodoc AUTHORS
-}
-
-pkg_postinst() {
- einfo "See the instructions on the homepage, and make sure you know what"
- einfo "you are doing before touching this. The mbr file does into your"
- einfo "MBR, or alternatively you can do a creative reboot utilizing the"
- einfo "boot.elf binary."
-}
diff --git a/sys-boot/mbr-gpt/mbr-gpt-0.0.1-r2.ebuild b/sys-boot/mbr-gpt/mbr-gpt-0.0.1-r2.ebuild
deleted file mode 100644
index 9359c8200a24..000000000000
--- a/sys-boot/mbr-gpt/mbr-gpt-0.0.1-r2.ebuild
+++ /dev/null
@@ -1,74 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit toolchain-funcs
-
-DESCRIPTION="An MBR that can handle BIOS-based boot on GPT"
-MY_P="${PN}_${PV}"
-HOMEPAGE="https://web.archive.org/web/20080704173538/http://aybabtu.com/mbr-gpt/"
-SRC_URI="https://dev.gentoo.org/~robbat2/distfiles/${MY_P}.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0"
-# This should probably NEVER go to stable. It's crazy advanced dangerous magic.
-# It's also pure ASM, so not suitable for elsewhere anyway.
-# Please don't remove it, robbat2 has a box that depends on it for # booting!
-KEYWORDS="~amd64 ~x86"
-
-# It only depends on binutils/gcc/make, and doesn't link against libc even.
-DEPEND=""
-RDEPEND=""
-
-# It's a mostly an MBR block and it does use the executable stack.
-QA_WX_LOAD="usr/lib/${PN}/boot.elf"
-QA_PRESTRIPPED="${QA_WX_LOAD}"
-QA_FLAGS_IGNORED="${QA_WX_LOAD}"
-
-# Don't strip it either; this binary reboots your host!
-RESTRICT="strip"
-
-src_prepare() {
- default
-
- # Messy upstream
- emake clean
-
- # Need to build it 32-bit for the MBR
- # Btw, no CFLAGS are respected, it's ASM!
- #
- # This is not meant to be used by a dynamic linker either!
- # https://inbox.sourceware.org/binutils/20200222023739.GB5570@bubble.grove.modra.org/T/#u
- # Shows the --no-dynamic-linker option to ld
- sed -i -e 's/-Wall/-Wall -m32 -Wl,--no-dynamic-linker/g' "${S}"/Makefile || die
-}
-
-src_compile() {
- emake CC="$(tc-getCC)"
- # validate the size, it MUST fit into an MBR (440 bytes!)
- size=$(stat --printf='%s' mbr)
- if test $size -gt 440; then
- die "Compiled MBR is too large! Must be at most 440 bytes, was $size"
- fi
-}
-
-src_install() {
- # get_libdir is not correct here. We want this to go into a 32-bit library
- # location.
- insinto /usr/lib/${PN}
- doins mbr
-
- exeinto /usr/lib/${PN}
- exeopts -m 700
- doexe boot.elf
-
- dodoc AUTHORS
-}
-
-pkg_postinst() {
- einfo "See the instructions on the homepage, and make sure you know what"
- einfo "you are doing before touching this. The mbr file does into your"
- einfo "MBR, or alternatively you can do a creative reboot utilizing the"
- einfo "boot.elf binary."
-}
diff --git a/sys-boot/mbr-gpt/metadata.xml b/sys-boot/mbr-gpt/metadata.xml
deleted file mode 100644
index 43abbb35dc1e..000000000000
--- a/sys-boot/mbr-gpt/metadata.xml
+++ /dev/null
@@ -1,11 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
-<maintainer type="person">
- <email>robbat2@gentoo.org</email>
-</maintainer>
-<longdescription lang="en">
- Bootable MBR including fake partition records, for legacy BIOS without any GPT support, and usable without hybrid disk layouts.
- Install directly at the start of a disk, create GPT, ensure at least one partition has GUID set to BIOS Boot Partition (21686148-6449-6e6f-744e-656564454649).
-</longdescription>
-</pkgmetadata>