summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2016-04-24 11:48:31 -0400
committerMike Gilbert <floppym@gentoo.org>2016-04-24 11:48:31 -0400
commit785cabb3a442da2490f2d356f1bd2c36ab7bde61 (patch)
tree10a8629478a14034ef0dc78a5456027a28b16f20 /sys-boot/gummiboot
parentsys-boot/grub: backport sysmacros fix (diff)
downloadgentoo-785cabb3a442da2490f2d356f1bd2c36ab7bde61.tar.gz
gentoo-785cabb3a442da2490f2d356f1bd2c36ab7bde61.tar.bz2
gentoo-785cabb3a442da2490f2d356f1bd2c36ab7bde61.zip
sys-boot/gummiboot: bump to 48
This is actually a tarball generated from commit 2bcd919c, post tag 48. Bug: https://bugs.gentoo.org/569204 Package-Manager: portage-2.2.28_p71
Diffstat (limited to 'sys-boot/gummiboot')
-rw-r--r--sys-boot/gummiboot/Manifest1
-rw-r--r--sys-boot/gummiboot/gummiboot-48.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/sys-boot/gummiboot/Manifest b/sys-boot/gummiboot/Manifest
index eab13032a2d0..97fa2d15ff10 100644
--- a/sys-boot/gummiboot/Manifest
+++ b/sys-boot/gummiboot/Manifest
@@ -1 +1,2 @@
DIST gummiboot-45.tar.xz 126376 SHA256 e3a6734c4c5acd3b42ec72dfc1214147c9f0ca74f08eeb44f969eb0d9b6d1e50 SHA512 09472a34ef8697a605c65462dde41ef09b1528a63b3a006f73a179ebeb16ac236adf9aaf8c8d7d3c411f3e3e029eb47ad916dc13f69ad9558c4277b1fa3d0619 WHIRLPOOL 04418cb9fd20df1a2bf77264bb766dc8542df8c1b05038ae780fbaa5dfb83e84f02cfd1adb20e22a032e9b0ad6e4654f40e25a67e5edf6b09e918c257930b9e1
+DIST gummiboot-48.tar.xz 131284 SHA256 e6b4b58c79cf600948d4d89a5324ced5736d7f20f7d3de74b2be8221123a9d40 SHA512 c3b3176f1b2fc0f5c8e196c9e63cf6ff6111d009c46a6311bd96367256cf4fbc28b46e3ae9ab4452cdc3b41d92fa978052b9803274b01ec3da72562076ea7737 WHIRLPOOL a9f2751a64a53b07a4d3fff17760f9ff38aed7ad4c0f60772b4b039d8b9a4ba50a9ef7006d28fc96d2653253ea9c65cb1e50391a467cb148684322e956d6fe05
diff --git a/sys-boot/gummiboot/gummiboot-48.ebuild b/sys-boot/gummiboot/gummiboot-48.ebuild
new file mode 100644
index 000000000000..a4b017d2b6d7
--- /dev/null
+++ b/sys-boot/gummiboot/gummiboot-48.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit linux-info
+
+DESCRIPTION="Minimalistic UEFI bootloader"
+HOMEPAGE="https://freedesktop.org/wiki/Software/gummiboot/"
+SRC_URI="https://dev.gentoo.org/~floppym/dist/${P}.tar.xz"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="sys-apps/util-linux"
+DEPEND="${RDEPEND}
+ app-arch/xz-utils
+ app-text/docbook-xsl-stylesheets
+ dev-libs/libxslt
+ >=sys-boot/gnu-efi-3.0.2"
+
+pkg_pretend() {
+ # CONFIG_EFI_STUB is required to boot a kernel with gummiboot
+ local CONFIG_CHECK="~EFI_STUB"
+ check_extra_config
+}