summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2016-02-08 16:12:15 -0800
committerRobin H. Johnson <robbat2@gentoo.org>2016-02-08 16:13:16 -0800
commitf6afcf81e3bb4e02f5960c3737d7f4ccd1674ab0 (patch)
tree53b1eb416f4363fa3190c1649326c43e9065be15 /sys-block
parentx11-misc/xdotool: bump (diff)
downloadgentoo-f6afcf81e3bb4e02f5960c3737d7f4ccd1674ab0.tar.gz
gentoo-f6afcf81e3bb4e02f5960c3737d7f4ccd1674ab0.tar.bz2
gentoo-f6afcf81e3bb4e02f5960c3737d7f4ccd1674ab0.zip
sys-block/megacli: per bug #563218 and sys-block/lsiutil, upstream does not fetch-restrict anymore.
Package-Manager: portage-2.2.27
Diffstat (limited to 'sys-block')
-rw-r--r--sys-block/megacli/Manifest1
-rw-r--r--sys-block/megacli/megacli-8.07.14-r1.ebuild81
2 files changed, 82 insertions, 0 deletions
diff --git a/sys-block/megacli/Manifest b/sys-block/megacli/Manifest
index 347179176647..bb4616fe4a6c 100644
--- a/sys-block/megacli/Manifest
+++ b/sys-block/megacli/Manifest
@@ -1,3 +1,4 @@
+DIST 8-07-14_MegaCLI.zip 7939395 SHA256 d9b152ae3dab76a334b9251702dba3311ceed91b58aaf52d916eb4ba1c2ab6e9 SHA512 ee2b66b69dc41bb678e54f5ccf4908a51e6fde147b2118844ff6248127aa51f12af0e7562c74461d52ea8e9b4345877b21c87fc89210208d80cf2fd3402a93e3 WHIRLPOOL 6720e246590a89ca6914f38a87aea83fe78f3986cee931bc2b133185c686574b80cf298a805c0412de6fc8fdd4e14a56e70ea5591446a1547a15b5487af245ae
DIST 8.02.21_MegaCLI.zip 12939353 SHA256 e5fdaff341b3cd8c3b5bbe334f5e819f9eb167e141337ce92a47a73c3fd7ac0b
DIST 8.07.10_MegaCLI_Linux.zip 1543709 SHA256 631b58c1a51815c1c01db4d4d7b7b8c1099e3dff2c7ae6f1c2bf32a9aae6aca4 SHA512 ee83910dac54b653f5c33703555c51d37b33e1672c6de6473950ca21ff19518b7de921cfa07a50e1c7f26054c7075c6bc241b52f89757cc1e0e0f4251a07bcd7 WHIRLPOOL 5a045a113aee047b9d30f58029ba5c039c721f16d7e6ce0958de2273d0024e475bc1aeee786dfee95342f595fc13c050a7bb45a374851cc73dee60b335c276be
DIST 8.07.14_MegaCLI.zip 7939395 SHA256 d9b152ae3dab76a334b9251702dba3311ceed91b58aaf52d916eb4ba1c2ab6e9 SHA512 ee2b66b69dc41bb678e54f5ccf4908a51e6fde147b2118844ff6248127aa51f12af0e7562c74461d52ea8e9b4345877b21c87fc89210208d80cf2fd3402a93e3 WHIRLPOOL 6720e246590a89ca6914f38a87aea83fe78f3986cee931bc2b133185c686574b80cf298a805c0412de6fc8fdd4e14a56e70ea5591446a1547a15b5487af245ae
diff --git a/sys-block/megacli/megacli-8.07.14-r1.ebuild b/sys-block/megacli/megacli-8.07.14-r1.ebuild
new file mode 100644
index 000000000000..ca44b0c178ce
--- /dev/null
+++ b/sys-block/megacli/megacli-8.07.14-r1.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit rpm
+MY_PV="${PV//./-}"
+MY_P=${MY_PV}_MegaCLI
+
+DESCRIPTION="LSI Logic MegaRAID Command Line Interface management tool"
+# Avagotech now owns LSI
+HOMEPAGE="http://www.www.avagotech.com/"
+SRC_URI="http://docs.avagotech.com/docs-and-downloads/raid-controllers/raid-controllers-common-files/${MY_P}.zip"
+
+LICENSE="LSI"
+SLOT="0"
+# This package can never enter stable, it can't be mirrored and upstream
+# can remove the distfiles from their mirror anytime.
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="app-arch/unzip
+ app-admin/chrpath"
+RDEPEND=""
+
+S=${WORKDIR}
+
+# Previous releases from LSI directly required a click-through EULA; but the
+# upstream website no longer requires this consistently: most old files have
+# two or more download pages, and while one of the pages has a generic
+# click-through download form, the file-specific download page only requires
+# click-through on some items. See also sys-block/lsiutil
+RESTRICT="mirror bindist"
+QA_PREBUILT="/opt/${PN}/${PN}
+ /opt/${PN}/lib/*"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ rpm_unpack ./Linux/MegaCli-${PV}-1.noarch.rpm
+}
+
+src_install() {
+ newdoc "${PV}_MegaCLI.txt" RELEASE.txt
+
+ exeinto /opt/megacli
+ libsysfs=libstorelibir-2.so.14.07-0
+ case ${ARCH} in
+ amd64) MegaCli=MegaCli64;;
+ x86) MegaCli=MegaCli;;
+ *) die "invalid ARCH";;
+ esac
+ newexe opt/MegaRAID/MegaCli/${MegaCli} ${PN}
+
+ exeinto /opt/${PN}/lib
+ doexe opt/MegaRAID/MegaCli/${libsysfs}
+
+ into /opt
+ newbin "${FILESDIR}"/${PN}-wrapper ${PN}
+ dosym ${PN} /opt/bin/MegaCli
+
+ # Remove DT_RPATH
+ chrpath -d "${D}"/opt/${PN}/${PN}
+}
+
+pkg_postinst() {
+ einfo
+ einfo "See /usr/share/doc/${PF}/RELEASE.txt for a list of supported controllers"
+ einfo "(contains LSI model names only, not those sold by 3rd parties"
+ einfo "under custom names like Dell PERC etc)."
+ einfo
+ einfo "As there's no dedicated manual, you might want to have"
+ einfo "a look at the following cheat sheet (originally written"
+ einfo "for Dell PowerEdge Expandable RAID Controllers):"
+ einfo "http://tools.rapidsoft.de/perc/perc-cheat-sheet.html"
+ einfo
+ einfo "For more information about working with Dell PERCs see:"
+ einfo "http://tools.rapidsoft.de/perc/"
+ einfo
+}