summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2022-08-06 12:31:28 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2022-08-06 12:31:45 -0500
commite683425233a821b15585311a53db9d5bffcf01fd (patch)
tree4b33dfa770532732dbd93f0986e2f6e0e6ef4752 /sys-block
parentsys-boot/plymouth: cleanup and remove genkernel-next references (diff)
downloadgentoo-e683425233a821b15585311a53db9d5bffcf01fd.tar.gz
gentoo-e683425233a821b15585311a53db9d5bffcf01fd.tar.bz2
gentoo-e683425233a821b15585311a53db9d5bffcf01fd.zip
sys-block/tgt: add 1.0.84
Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'sys-block')
-rw-r--r--sys-block/tgt/Manifest1
-rw-r--r--sys-block/tgt/tgt-1.0.84.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/sys-block/tgt/Manifest b/sys-block/tgt/Manifest
index 04e2adcecd7e..241000dfdaff 100644
--- a/sys-block/tgt/Manifest
+++ b/sys-block/tgt/Manifest
@@ -2,3 +2,4 @@ DIST tgt-1.0.79.tar.gz 297825 BLAKE2B 5b48e8390ce092d2b34a7ce4bb5845ba8beb0bd696
DIST tgt-1.0.80.tar.gz 298256 BLAKE2B 3a678730b3c492832b96e160e9672354aa32a3cc463e2845b1b475c238172b99c1706d3d387697c199c4f3004d8b2c4230d17bd356ce9103028525f8007c89a9 SHA512 6e48013a7da527799f25dc224bb261f7c5cf0aa3893bc337b9f4878a45d116be701a373c533ab6fa79771ccd633501c83b48084828bf6167af72e35795bb1c4f
DIST tgt-1.0.82.tar.gz 304687 BLAKE2B 42b43e7f9c23ddacba1c573b189480fc7e34bd5bcc58a8267e56b79d7e5a54d65c5624ac33ed7334c32085ea2fbd3c0719f82188262934658eda291c059e53c9 SHA512 e81a56fae8010ee2af8643b6accc1e51f6667e27b07c986e6a5412dcb483b46ccc0e4fe1aeb399c352282284fe516f3fc1cab5d8cbb431cc9f97f00d5faa0430
DIST tgt-1.0.83.tar.gz 304631 BLAKE2B 64374e3ffa0fd73f25172e24b233d001dc2b70cbc08116f167de9d625d493dca330e84f73683d6cc74ea76f5bd9fa940cec54d43ebc9c41ed1ff54f5dc3a6e39 SHA512 0c97900aada010b84585a7ad2b1c4654db0fdbc4caed1dea05d00518340b23691ba91f4bb3c677b420a3f4e67f4b061055f877c050ea1d758f2ebb75771b1cf5
+DIST tgt-1.0.84.tar.gz 304641 BLAKE2B d5a28547ba637d951b4096ae3e2b49794aac0a7e517f185331fdfa7df9a1715ce82d498f88538fe08a71ba3958a6972251dbebafdddfeb649318c2ff13a72f95 SHA512 a194d95fac7c4525b22257af3977b1ca680d81bbf1aa4c75444f30a6d8d8db22eca3b29b2ece314fe3b0c0d18152e048c912347c9db1146c9f38419be5116971
diff --git a/sys-block/tgt/tgt-1.0.84.ebuild b/sys-block/tgt/tgt-1.0.84.ebuild
new file mode 100644
index 000000000000..43d1f60ba296
--- /dev/null
+++ b/sys-block/tgt/tgt-1.0.84.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit toolchain-funcs systemd
+
+DESCRIPTION="Linux SCSI target framework (tgt)"
+HOMEPAGE="http://stgt.sourceforge.net"
+SRC_URI="https://github.com/fujita/tgt/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="fcoe fcp ibmvio infiniband rbd"
+
+DEPEND="
+ app-text/docbook-xsl-stylesheets
+ dev-libs/libxslt
+ dev-perl/Config-General
+ rbd? ( sys-cluster/ceph )
+ infiniband? ( sys-cluster/rdma-core )
+"
+RDEPEND="${DEPEND}
+ dev-libs/libaio
+ sys-apps/sg3_utils"
+
+pkg_setup() {
+ tc-export CC
+}
+
+src_prepare() {
+ default
+ sed -i -e 's:\($(CC)\) $^:\1 $(LDFLAGS) $^:' usr/Makefile || die
+ # make sure xml docs are generated before trying to install them
+ sed -i -e "s@install: @& all @g" doc/Makefile || die
+ sed -i -e 's|-Werror||g' usr/Makefile || die
+}
+
+src_compile() {
+ local myconf
+ use ibmvio && myconf="${myconf} IBMVIO=1"
+ use infiniband && myconf="${myconf} ISCSI_RDMA=1"
+ use fcp && myconf="${myconf} FCP=1"
+ use fcoe && myconf="${myconf} FCOE=1"
+ use rbd && myconf="${myconf} CEPH_RBD=1"
+
+ emake -C usr/ KERNELSRC="${KERNEL_DIR}" ISCSI=1 ${myconf}
+ emake -C doc
+}
+
+src_install() {
+ emake install-programs install-scripts install-doc DESTDIR="${D}" docdir=/usr/share/doc/${PF}
+ newinitd "${FILESDIR}"/tgtd.initd tgtd
+ newconfd "${FILESDIR}"/tgtd.confd tgtd
+ systemd_dounit "${S}"/scripts/tgtd.service
+ dodir /etc/tgt
+ keepdir /etc/tgt
+}