summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-06-01 01:39:08 +0100
committerSam James <sam@gentoo.org>2022-06-01 02:25:09 +0100
commitc8a350785778feb0ced49ff5077174e0ea10c195 (patch)
tree1b8c9e67373e0def89a1e3db3fb0cadd495aa8e2 /sys-block
parentmedia-fonts/lxgw-wenkai: add 1.235.1, drop 1.235 (diff)
downloadgentoo-c8a350785778feb0ced49ff5077174e0ea10c195.tar.gz
gentoo-c8a350785778feb0ced49ff5077174e0ea10c195.tar.bz2
gentoo-c8a350785778feb0ced49ff5077174e0ea10c195.zip
sys-block/nbd: add 3.24
Bug: https://bugs.gentoo.org/834678 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-block')
-rw-r--r--sys-block/nbd/Manifest1
-rw-r--r--sys-block/nbd/nbd-3.24.ebuild75
-rw-r--r--sys-block/nbd/nbd-9999.ebuild22
3 files changed, 91 insertions, 7 deletions
diff --git a/sys-block/nbd/Manifest b/sys-block/nbd/Manifest
index deee3965f712..acfc433a02e0 100644
--- a/sys-block/nbd/Manifest
+++ b/sys-block/nbd/Manifest
@@ -1 +1,2 @@
DIST nbd-3.21.tar.xz 523472 BLAKE2B 8601306966b75e5000e34d784175f287553d478e8367d488b9a3c1c11bcb7345a4ba898f02a94b8e927fbded1d3a563a4f0369ad7b49b14dcb6f5ea8d91812f3 SHA512 5dc238e6f45eb230a6f92493a8c3b4891dee98fc47e120e59c3ca31c0a698537ca03f78e43c5e7089d93d548a22b5e3853ba228536d2fc688c3edf4a590fdb3f
+DIST nbd-3.24.tar.xz 556928 BLAKE2B a07b0d8ce18cdea2e0778afbf9adfbc49f4fdc5746ec6f304f46d390adfc0a9ffb199e7c5cb6a72b3073a12a37f598e3780f0a1374b25c0e0a546653f7657d28 SHA512 b542733ca8bdfb6883591acd5cc82fd8fa64fed7ca85b01a961e0ad69b9655750e5317df9ec510b4147cc8b0b5cdfa0b43da53dd06c42863553555d710a3c85d
diff --git a/sys-block/nbd/nbd-3.24.ebuild b/sys-block/nbd/nbd-3.24.ebuild
new file mode 100644
index 000000000000..04319fda899d
--- /dev/null
+++ b/sys-block/nbd/nbd-3.24.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit systemd
+
+DESCRIPTION="Userland client/server for kernel network block device"
+HOMEPAGE="https://nbd.sourceforge.net/"
+if [[ ${PV} = 9999 ]] ; then
+ inherit autotools git-r3
+ EGIT_REPO_URI="https://github.com/NetworkBlockDevice/nbd.git"
+else
+ SRC_URI="https://github.com/NetworkBlockDevice/nbd/releases/download/${P}/${P}.tar.xz
+ mirror://sourceforge/nbd/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="debug gnutls netlink zlib"
+
+BDEPEND="virtual/pkgconfig"
+
+RDEPEND="
+ >=dev-libs/glib-2.26.0
+ gnutls? ( >=net-libs/gnutls-2.12.0 )
+ netlink? ( >=dev-libs/libnl-3.1 )
+ zlib? ( sys-libs/zlib )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="sys-devel/bison"
+
+if [[ ${PV} = 9999 ]] ; then
+ BDEPEND+="
+ app-text/docbook-sgml-dtd:4.5
+ app-text/docbook-sgml-utils
+ sys-devel/autoconf-archive
+ "
+fi
+
+src_prepare() {
+ default
+
+ if [[ ${PV} = 9999 ]] ; then
+ emake -C man -f Makefile.am \
+ nbd-server.1.sh.in \
+ nbd-server.5.sh.in \
+ nbd-client.8.sh.in \
+ nbd-trdump.1.sh.in \
+ nbdtab.5.sh.in
+
+ emake -C systemd -f Makefile.am nbd@.service.sh.in
+
+ eautoreconf
+ fi
+}
+
+src_configure() {
+ local myeconfargs=(
+ --enable-lfs
+ $(use_enable !debug syslog)
+ $(use_enable debug)
+ $(use_enable zlib gznbd)
+ $(use_with gnutls)
+ $(use_with netlink libnl)
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+ systemd_dounit systemd/nbd@.service
+}
diff --git a/sys-block/nbd/nbd-9999.ebuild b/sys-block/nbd/nbd-9999.ebuild
index 732367ad8970..04319fda899d 100644
--- a/sys-block/nbd/nbd-9999.ebuild
+++ b/sys-block/nbd/nbd-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -6,14 +6,16 @@ EAPI=7
inherit systemd
DESCRIPTION="Userland client/server for kernel network block device"
-HOMEPAGE="http://nbd.sourceforge.net/"
-if [[ "${PV}" = 9999 ]] ; then
+HOMEPAGE="https://nbd.sourceforge.net/"
+if [[ ${PV} = 9999 ]] ; then
inherit autotools git-r3
EGIT_REPO_URI="https://github.com/NetworkBlockDevice/nbd.git"
else
- SRC_URI="mirror://sourceforge/nbd/${P}.tar.xz"
+ SRC_URI="https://github.com/NetworkBlockDevice/nbd/releases/download/${P}/${P}.tar.xz
+ mirror://sourceforge/nbd/${P}.tar.xz"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
fi
+
LICENSE="GPL-2"
SLOT="0"
IUSE="debug gnutls netlink zlib"
@@ -27,24 +29,29 @@ RDEPEND="
zlib? ( sys-libs/zlib )
"
DEPEND="${RDEPEND}"
+BDEPEND="sys-devel/bison"
-if [[ "${PV}" = 9999 ]] ; then
- DEPEND+="
+if [[ ${PV} = 9999 ]] ; then
+ BDEPEND+="
app-text/docbook-sgml-dtd:4.5
app-text/docbook-sgml-utils
+ sys-devel/autoconf-archive
"
fi
src_prepare() {
default
- if [[ "${PV}" = 9999 ]] ; then
+
+ if [[ ${PV} = 9999 ]] ; then
emake -C man -f Makefile.am \
nbd-server.1.sh.in \
nbd-server.5.sh.in \
nbd-client.8.sh.in \
nbd-trdump.1.sh.in \
nbdtab.5.sh.in
+
emake -C systemd -f Makefile.am nbd@.service.sh.in
+
eautoreconf
fi
}
@@ -58,6 +65,7 @@ src_configure() {
$(use_with gnutls)
$(use_with netlink libnl)
)
+
econf "${myeconfargs[@]}"
}