summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiogo Pereira <sir.suriv@gmail.com>2020-08-17 00:14:05 +0100
committerSam James <sam@gentoo.org>2020-08-25 00:06:07 +0000
commit934814f627d542bae52f0500ad6cf003525e23f2 (patch)
tree8b683d2ba02a34dd23aceb257836633b611a163c /sys-block
parentsys-block/targetcli-fb: mark ALLARCHES (diff)
downloadgentoo-934814f627d542bae52f0500ad6cf003525e23f2.tar.gz
gentoo-934814f627d542bae52f0500ad6cf003525e23f2.tar.bz2
gentoo-934814f627d542bae52f0500ad6cf003525e23f2.zip
sys-block/targetcli-fb: bump to 2.1.53
Bug: https://bugs.gentoo.org/722674 Bug: https://bugs.gentoo.org/736086 Closes: https://bugs.gentoo.org/718528 Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Diogo Pereira <sir.suriv@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/17142 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-block')
-rw-r--r--sys-block/targetcli-fb/Manifest1
-rw-r--r--sys-block/targetcli-fb/targetcli-fb-2.1.53.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/sys-block/targetcli-fb/Manifest b/sys-block/targetcli-fb/Manifest
index 4f1d7366f5e8..bb1027c99cfc 100644
--- a/sys-block/targetcli-fb/Manifest
+++ b/sys-block/targetcli-fb/Manifest
@@ -1,2 +1,3 @@
DIST targetcli-fb-2.1.49.tar.gz 34147 BLAKE2B 49ed4a610282af30308373cdf806832a3441dcab9a52cddb3f59bacdecb79f7308f316cc65f526d6ea1f9bb875d05e049e6cd7d99eb243f25546395ba6aaa38c SHA512 05fb6f638f808bf09089bdd110592b3ed3be49fc70cc1a71680de7bff40dc88425e69e9a99fdfcab712646cf131f78071edae46f214fdfee4b7090f47933c93a
DIST targetcli-fb-2.1.51.tar.gz 38577 BLAKE2B 0cc1cc920ec7bcefb987fac0397aa7c5a994cf47966971238a6c469e87b2dffc00dc09a55279b5ba0fda776a32a129ad3170b861e6309ea30f271ddc32f690f6 SHA512 a94f251889913888c430cfe2b2fa1b27e4cd01f05627f1c3f0d4c72145b23081be189b7ca5d381bffa0da74ba6a53146e7ca964ff864cb532f132e24bc205b9a
+DIST targetcli-fb-2.1.53.tar.gz 39586 BLAKE2B 35e5cea72580ba26b8397027e92446c129af5a94ab9458eed63ec731289065bcce759a77558a022c41b4ed73eefe865000e60b4e17816836f13056cb07071069 SHA512 acefa7f8df8ee901cae8f04cbeb264d6024100e2d8b8343024bc52842af88a23d1bf5dd880ff2c77046bd8da8493630b4e357103617c02d1a90947e42c3a7c92
diff --git a/sys-block/targetcli-fb/targetcli-fb-2.1.53.ebuild b/sys-block/targetcli-fb/targetcli-fb-2.1.53.ebuild
new file mode 100644
index 000000000000..e751a62d6674
--- /dev/null
+++ b/sys-block/targetcli-fb/targetcli-fb-2.1.53.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+inherit distutils-r1
+
+DESCRIPTION="Command shell for managing Linux LIO kernel target"
+HOMEPAGE="https://github.com/open-iscsi/targetcli-fb"
+SRC_URI="https://github.com/open-iscsi/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-python/configshell-fb[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ >=dev-python/rtslib-fb-2.1.73[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ sys-apps/dbus"
+
+src_install() {
+ distutils-r1_src_install
+
+ keepdir /etc/target /etc/target/backup
+ doman targetcli.8
+}