summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Maier <tamiko@gentoo.org>2022-06-02 13:46:10 -0500
committerMatthias Maier <tamiko@gentoo.org>2022-06-02 13:46:16 -0500
commit7f9a51764f45836dd4532ff899684c9a92390a91 (patch)
tree385eb7573bb78482c650584fac9df2c5f3361a33 /sys-block/open-iscsi
parentsys-block/open-iscsi: fix installation (diff)
downloadgentoo-7f9a51764f45836dd4532ff899684c9a92390a91.tar.gz
gentoo-7f9a51764f45836dd4532ff899684c9a92390a91.tar.bz2
gentoo-7f9a51764f45836dd4532ff899684c9a92390a91.zip
sys-block/open-iscsi: fix pkg_postinst
Signed-off-by: Matthias Maier <tamiko@gentoo.org>
Diffstat (limited to 'sys-block/open-iscsi')
-rw-r--r--sys-block/open-iscsi/open-iscsi-2.1.7.ebuild4
1 files changed, 3 insertions, 1 deletions
diff --git a/sys-block/open-iscsi/open-iscsi-2.1.7.ebuild b/sys-block/open-iscsi/open-iscsi-2.1.7.ebuild
index 08efea3d8711..552d373862e7 100644
--- a/sys-block/open-iscsi/open-iscsi-2.1.7.ebuild
+++ b/sys-block/open-iscsi/open-iscsi-2.1.7.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit autotools linux-info flag-o-matic toolchain-funcs systemd
+inherit autotools linux-info flag-o-matic toolchain-funcs systemd udev
DESCRIPTION="A performant, transport independent, multi-platform implementation of RFC3720"
HOMEPAGE="https://www.open-iscsi.com/"
@@ -140,4 +140,6 @@ pkg_postinst() {
echo "InitiatorName=$(${ROOT}/usr/sbin/iscsi-iname)"
} >> "${EROOT}${in}.tmp" && mv -f "${EROOT}${in}.tmp" "${EROOT}${in}"
fi
+
+ udev_reload
}