summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <mmk@levelnine.at>2023-07-11 14:55:58 +0200
committerConrad Kostecki <conikost@gentoo.org>2023-07-15 02:51:19 +0200
commitb0a915f211ccb97476f690a791a660558581a881 (patch)
tree4415b460cba50d75f48a29e15b7b5525fae09d72 /sys-block/f3
parentsys-libs/cracklib: remove unused patch(es) (diff)
downloadgentoo-b0a915f211ccb97476f690a791a660558581a881.tar.gz
gentoo-b0a915f211ccb97476f690a791a660558581a881.tar.bz2
gentoo-b0a915f211ccb97476f690a791a660558581a881.zip
sys-block/f3: EAPI8 bump, remove broken HOMEPAGE
Signed-off-by: Michael Mair-Keimberger <mmk@levelnine.at> Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'sys-block/f3')
-rw-r--r--sys-block/f3/f3-8.0-r1.ebuild62
1 files changed, 62 insertions, 0 deletions
diff --git a/sys-block/f3/f3-8.0-r1.ebuild b/sys-block/f3/f3-8.0-r1.ebuild
new file mode 100644
index 000000000000..69e189a0304e
--- /dev/null
+++ b/sys-block/f3/f3-8.0-r1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit flag-o-matic toolchain-funcs
+
+DESCRIPTION="Utilities to detect broken or counterfeit flash storage"
+HOMEPAGE="https://github.com/AltraMayor/f3"
+
+if [[ ${PV} == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/AltraMayor/${PN}.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/AltraMayor/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+IUSE="extra"
+
+RDEPEND="elibc_musl? ( sys-libs/argp-standalone )"
+DEPEND="${RDEPEND}
+ extra? (
+ sys-block/parted
+ virtual/udev
+ )"
+
+DOCS=( changelog README.rst )
+
+src_prepare() {
+ default
+
+ sed -i \
+ -e 's:-ggdb::' \
+ -e 's:^PREFIX =:PREFIX ?=:' \
+ Makefile || die
+
+ # bug #715518
+ use elibc_musl && append-ldflags -largp
+
+ tc-export CC
+}
+
+src_compile() {
+ default
+
+ if use extra; then
+ emake V=1 extra
+ fi
+}
+
+src_install() {
+ emake PREFIX="${ED}/usr" install
+
+ if use extra; then
+ emake PREFIX="${ED}/usr" install-extra
+ fi
+
+ einstalldocs
+}