summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOleksandr Trotsenko <oleksandr.trotsenko@gmail.com>2018-08-28 19:01:13 -0500
committerCraig Andrews <candrews@gentoo.org>2018-08-31 14:22:27 -0400
commitdd2af693f55ad8ba61d04d6c468eb36e03818f59 (patch)
tree15f67fef5b45d4fa93a2cb1478526bfc65519a43 /sys-auth
parentdev-python/pyzbar: Introducing support for Python3.7 (diff)
downloadgentoo-dd2af693f55ad8ba61d04d6c468eb36e03818f59.tar.gz
gentoo-dd2af693f55ad8ba61d04d6c468eb36e03818f59.tar.bz2
gentoo-dd2af693f55ad8ba61d04d6c468eb36e03818f59.zip
sys-auth/authenticator: Move package from gnome-extra/ category
Moving the recently introduced package to a more appropriate category, namely from gnome-extra/authenticator to sys-auth/authenticator. Also drop Python 3.4 Closes: https://bugs.gentoo.org/663820 Package-Manager: Portage-2.3.48, Repoman-2.3.10
Diffstat (limited to 'sys-auth')
-rw-r--r--sys-auth/authenticator/Manifest1
-rw-r--r--sys-auth/authenticator/authenticator-0.2.1.ebuild55
-rw-r--r--sys-auth/authenticator/authenticator-9999.ebuild55
-rw-r--r--sys-auth/authenticator/files/disable-failing-tests.patch24
-rw-r--r--sys-auth/authenticator/metadata.xml19
5 files changed, 154 insertions, 0 deletions
diff --git a/sys-auth/authenticator/Manifest b/sys-auth/authenticator/Manifest
new file mode 100644
index 000000000000..2029d165c909
--- /dev/null
+++ b/sys-auth/authenticator/Manifest
@@ -0,0 +1 @@
+DIST authenticator-0.2.1.tar.gz 147693 BLAKE2B b9f3a7fd5b3b7867120b9ed17b90cea4c07a271dc4d75a845ad539e15453a606d48e8637d44d12cecf9b91e5fb351d081c1add48c1a4a955444f39addd51b075 SHA512 aebf3ce147d5ccd404de6af52e130e9a85a3d5d86140d73026dac00219853652e7aa1e67db5838f9ac4d147021cd07b3ebfb86a1ab4b413ec3b98360097d1d6e
diff --git a/sys-auth/authenticator/authenticator-0.2.1.ebuild b/sys-auth/authenticator/authenticator-0.2.1.ebuild
new file mode 100644
index 000000000000..f11556202d24
--- /dev/null
+++ b/sys-auth/authenticator/authenticator-0.2.1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_{5,6} )
+inherit gnome2-utils meson python-r1 virtualx xdg-utils
+
+DESCRIPTION="Two-factor authentication code generator for GNOME"
+HOMEPAGE="https://github.com/bilelmoussaoui/Authenticator"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ SRC_URI=""
+ EGIT_REPO_URI="${HOMEPAGE}"
+else
+ SRC_URI="https://github.com/bilelmoussaoui/Authenticator/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/Authenticator-${PV}"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-2+"
+SLOT="0"
+
+DEPEND="
+ app-crypt/libsecret
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/pyotp[${PYTHON_USEDEP}]
+ dev-python/pyzbar[${PYTHON_USEDEP}]
+ media-gfx/gnome-screenshot
+ x11-libs/gtk+:3
+"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}/disable-failing-tests.patch" )
+
+pkg_preinst() {
+ gnome2_icon_savelist
+ gnome2_schemas_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+ gnome2_schemas_update
+}
+
+src_test() {
+ xdg_environment_reset
+ virtx meson_src_test
+}
diff --git a/sys-auth/authenticator/authenticator-9999.ebuild b/sys-auth/authenticator/authenticator-9999.ebuild
new file mode 100644
index 000000000000..f11556202d24
--- /dev/null
+++ b/sys-auth/authenticator/authenticator-9999.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_{5,6} )
+inherit gnome2-utils meson python-r1 virtualx xdg-utils
+
+DESCRIPTION="Two-factor authentication code generator for GNOME"
+HOMEPAGE="https://github.com/bilelmoussaoui/Authenticator"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ SRC_URI=""
+ EGIT_REPO_URI="${HOMEPAGE}"
+else
+ SRC_URI="https://github.com/bilelmoussaoui/Authenticator/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/Authenticator-${PV}"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-2+"
+SLOT="0"
+
+DEPEND="
+ app-crypt/libsecret
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/pyotp[${PYTHON_USEDEP}]
+ dev-python/pyzbar[${PYTHON_USEDEP}]
+ media-gfx/gnome-screenshot
+ x11-libs/gtk+:3
+"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}/disable-failing-tests.patch" )
+
+pkg_preinst() {
+ gnome2_icon_savelist
+ gnome2_schemas_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+ gnome2_schemas_update
+}
+
+src_test() {
+ xdg_environment_reset
+ virtx meson_src_test
+}
diff --git a/sys-auth/authenticator/files/disable-failing-tests.patch b/sys-auth/authenticator/files/disable-failing-tests.patch
new file mode 100644
index 000000000000..0c17070d9106
--- /dev/null
+++ b/sys-auth/authenticator/files/disable-failing-tests.patch
@@ -0,0 +1,24 @@
+diff --git a/data/meson.build b/data/meson.build
+index d21a6d1..b2a849b 100644
+--- a/data/meson.build
++++ b/data/meson.build
+@@ -50,10 +50,12 @@ endif
+
+ appstreamcli = find_program(['appstreamcli', 'appstream-util'], required:false)
+
+-if appstreamcli.found()
+- test (
+- 'Validate appdata file',
+- appstreamcli,
+- args: ['validate', join_paths(meson.current_build_dir (), meson.project_name() + '.appdata.xml')]
+- )
+-endif
++# This test fails because screenshot images do not comply with restrictions.
++# See https://github.com/bilelmoussaoui/Authenticator/issues/67
++#if appstreamcli.found()
++# test (
++# 'Validate appdata file',
++# appstreamcli,
++# args: ['validate', join_paths(meson.current_build_dir (), meson.project_name() + '.appdata.xml')]
++# )
++#endif
diff --git a/sys-auth/authenticator/metadata.xml b/sys-auth/authenticator/metadata.xml
new file mode 100644
index 000000000000..3950af1a3351
--- /dev/null
+++ b/sys-auth/authenticator/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>oleksandr.trotsenko@gmail.com</email>
+ <name>Oleksandr Trotsenko</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">bilelmoussaoui/Authenticator</remote-id>
+ <maintainer>
+ <name>Bilal Elmoussaoui</name>
+ </maintainer>
+ <bugs-to>https://github.com/bilelmoussaoui/Authenticator/issues</bugs-to>
+ </upstream>
+</pkgmetadata>