summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHaelwenn (lanodan) Monnier <contact@hacktivis.me>2021-09-13 03:00:04 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2021-09-13 09:40:59 +0300
commit25bd48291cdc23496b89e835bdffc69f0dfb8397 (patch)
treee0b494620df55a9ca174e552d7c6c322e89be5e1 /sys-auth
parentapp-crypt/swtpm: keyword 0.6.0-r1 for ~x86 (diff)
downloadgentoo-25bd48291cdc23496b89e835bdffc69f0dfb8397.tar.gz
gentoo-25bd48291cdc23496b89e835bdffc69f0dfb8397.tar.bz2
gentoo-25bd48291cdc23496b89e835bdffc69f0dfb8397.zip
sys-auth/seatd: Version bump, 0.6.0
Signed-off-by: Haelwenn (lanodan) Monnier <contact@hacktivis.me> Closes: https://github.com/gentoo/gentoo/pull/22279 Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'sys-auth')
-rw-r--r--sys-auth/seatd/Manifest1
-rw-r--r--sys-auth/seatd/seatd-0.6.0.ebuild53
-rw-r--r--sys-auth/seatd/seatd-9999.ebuild6
3 files changed, 57 insertions, 3 deletions
diff --git a/sys-auth/seatd/Manifest b/sys-auth/seatd/Manifest
index 51725b0badd2..a45cc62360be 100644
--- a/sys-auth/seatd/Manifest
+++ b/sys-auth/seatd/Manifest
@@ -1 +1,2 @@
DIST seatd-0.5.0.tar.gz 34762 BLAKE2B 054bd64800b734f6092f856540217e5ea4872c5a363960bac6c5aa7dac5355bdbd982232efd2f8078ad326ec0e6257f3ee7643384c88a3bbe15255d65f02540c SHA512 a6b1f11313411fe99e8bdd64aa493fc19bde7b0b927f21e2c3ec8a7fadc6cf2f04fcefa73fa033d971d1dc482665d3dc927ec168026289fe88b2593a45adbc0f
+DIST seatd-0.6.0.tar.gz 37418 BLAKE2B 0598191cd5988ec24506a5b70f2011b1ec1691f5e32108c4c44e79d5527527cae4da8bfbe934ca64efbb1a1dd8471b35589c33399cf85dc89b4cec92d2ef1192 SHA512 9b0b67a028cf9bba63a6c4630c66b21dd2cb87de0d290bfc51245727cda72964fbd0ffee709eded1e81c28f403db6bae8926a257fdd9267e154fbe8697d22a2b
diff --git a/sys-auth/seatd/seatd-0.6.0.ebuild b/sys-auth/seatd/seatd-0.6.0.ebuild
new file mode 100644
index 000000000000..5631c945732b
--- /dev/null
+++ b/sys-auth/seatd/seatd-0.6.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 2020-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson systemd
+
+DESCRIPTION="Minimal seat management daemon and universal library"
+HOMEPAGE="https://sr.ht/~kennylevinsen/seatd"
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://git.sr.ht/~kennylevinsen/seatd"
+else
+ KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+ SRC_URI="https://git.sr.ht/~kennylevinsen/seatd/archive/${PV}.tar.gz -> ${P}.tar.gz"
+fi
+LICENSE="MIT"
+SLOT="0/1"
+IUSE="builtin elogind +server systemd"
+REQUIRED_USE="?? ( elogind systemd )"
+
+DEPEND="
+ elogind? ( sys-auth/elogind )
+ systemd? ( sys-apps/systemd )
+"
+RDEPEND="${DEPEND}"
+BDEPEND=">=app-text/scdoc-1.9.7"
+
+src_configure() {
+ local emesonargs=(
+ -Dman-pages=enabled
+ -Dwerror=false
+ $(meson_feature builtin libseat-builtin)
+ $(meson_feature server)
+ )
+
+ if use elogind || use systemd; then
+ emesonargs+=( -Dlibseat-logind=enabled )
+ else
+ emesonargs+=( -Dlibseat-logind=disabled )
+ fi
+
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+
+ if use server; then
+ newinitd "${FILESDIR}/seatd.initd" seatd
+ systemd_dounit contrib/systemd/seatd.service
+ fi
+}
diff --git a/sys-auth/seatd/seatd-9999.ebuild b/sys-auth/seatd/seatd-9999.ebuild
index c826e115f27c..5631c945732b 100644
--- a/sys-auth/seatd/seatd-9999.ebuild
+++ b/sys-auth/seatd/seatd-9999.ebuild
@@ -1,7 +1,7 @@
# Copyright 2020-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit meson systemd
@@ -35,9 +35,9 @@ src_configure() {
)
if use elogind || use systemd; then
- emesonargs+=( -Dlogind=enabled )
+ emesonargs+=( -Dlibseat-logind=enabled )
else
- emesonargs+=( -Dlogind=disabled )
+ emesonargs+=( -Dlibseat-logind=disabled )
fi
meson_src_configure