summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-10-11 17:26:18 +0200
committerMichał Górny <mgorny@gentoo.org>2019-10-11 17:26:18 +0200
commit21fec2010fe4bf1e95ab0b63ee06b472d9035dce (patch)
treea1887f5bdd4d0a0ba3925e2ce4d72ca8fc8b774a /sys-auth/pambase
parentprofiles: Remove FreeBSD profiles (diff)
downloadgentoo-21fec2010fe4bf1e95ab0b63ee06b472d9035dce.tar.gz
gentoo-21fec2010fe4bf1e95ab0b63ee06b472d9035dce.tar.bz2
gentoo-21fec2010fe4bf1e95ab0b63ee06b472d9035dce.zip
sys-auth/pambase: Remove old fbsd-only version
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sys-auth/pambase')
-rw-r--r--sys-auth/pambase/Manifest1
-rw-r--r--sys-auth/pambase/pambase-20101024-r2.ebuild94
2 files changed, 0 insertions, 95 deletions
diff --git a/sys-auth/pambase/Manifest b/sys-auth/pambase/Manifest
index 35262a7385b9..1bdf9ee2a0ba 100644
--- a/sys-auth/pambase/Manifest
+++ b/sys-auth/pambase/Manifest
@@ -1,3 +1,2 @@
-DIST pambase-20101024.tar.bz2 3201 BLAKE2B 714da8dd0b354cee29ad175a0ed2094fba8f3bfb5839319a515ed133991eb224ae280928177dcb0524f52193f44a68064a2413ae47d380472bc7b5da0b13f1bf SHA512 8d2a89b38d94d2e423a033ea6922c0a0039a0fb64d60c05991d877b4fa893954723fe1c1763f3f67ed6fbc3639282a4ee1d76824f7f29025b6050632a6984b6f
DIST pambase-20150213.tar.xz 3480 BLAKE2B 7c59774bb8888fd2c4656264f1d8ea8cdd5ffffff4dc5d03091592726c8bd7775ba1573091c8616aa891298a1fe309b19885b5ec21efb45fe38900b7c959aaf5 SHA512 3b49dd3f06a0942fcced95527f62cbc4ff723c48dc896a0b57ecd19736d2892db974c782be3fe24e8e6e17294869a772ae9ee6118af96dfdc7a3a6561dc3f3e5
DIST pambase-20190402.tar.gz 3679 BLAKE2B 992d7bf6b6f74ef22a8808b57dd6faffb6c351eaa8be4172f320031334ca6def698b2cb17005b58ac3c18e89a94012e279b0f27cc2bea5040ae8ddc3233cba2d SHA512 565d64653e9898b9bd231c1461ec0988a19dbc9500ff1417a7197ac75804abeb13ca543121ae4afb29017c1e99073a16137e5c876f43dcc01e2641218760f4ae
diff --git a/sys-auth/pambase/pambase-20101024-r2.ebuild b/sys-auth/pambase/pambase-20101024-r2.ebuild
deleted file mode 100644
index 71c40477c574..000000000000
--- a/sys-auth/pambase/pambase-20101024-r2.ebuild
+++ /dev/null
@@ -1,94 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=4
-
-inherit eutils
-
-DESCRIPTION="PAM base configuration files"
-HOMEPAGE="https://github.com/gentoo/pambase"
-SRC_URI="https://dev.gentoo.org/~flameeyes/${PN}/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64-fbsd ~x86-fbsd"
-IUSE="debug +cracklib passwdqc consolekit gnome-keyring selinux mktemp pam_ssh +sha512 pam_krb5 minimal"
-RESTRICT="binchecks"
-
-RDEPEND="
- || (
- >=sys-libs/pam-0.99.9.0-r1
- ( sys-auth/openpam sys-freebsd/freebsd-pam-modules )
- )
- cracklib? ( >=sys-libs/pam-0.99[cracklib] )
- consolekit? ( >=sys-auth/consolekit-0.3[pam] )
- gnome-keyring? ( >=gnome-base/gnome-keyring-2.20[pam] )
- selinux? ( >=sys-libs/pam-0.99[selinux] )
- passwdqc? ( >=sys-auth/pam_passwdqc-1.0.4 )
- mktemp? ( sys-auth/pam_mktemp )
- pam_ssh? ( sys-auth/pam_ssh )
- sha512? ( >=sys-libs/pam-1.0.1 )
- pam_krb5? (
- || ( >=sys-libs/pam-1.1.0 sys-auth/openpam )
- >=sys-auth/pam_krb5-4.3
- )
- !<sys-freebsd/freebsd-pam-modules-6.2-r1
- !<sys-libs/pam-0.99.9.0-r1"
-DEPEND="app-portage/portage-utils"
-
-src_compile() {
- local implementation=
- local linux_pam_version=
- if has_version sys-libs/pam; then
- implementation="linux-pam"
- local ver_str=$(qatom `best_version sys-libs/pam` | cut -d ' ' -f 3)
- linux_pam_version=$(printf "0x%02x%02x%02x" ${ver_str//\./ })
- elif has_version sys-auth/openpam; then
- implementation="openpam"
- else
- die "PAM implementation not identified"
- fi
-
- use_var() {
- local varname=$(echo $1 | tr [a-z] [A-Z])
- local usename=${2-$(echo $1 | tr [A-Z] [a-z])}
- local varvalue=$(use $usename && echo yes || echo no)
- echo "${varname}=${varvalue}"
- }
-
- emake \
- GIT=true \
- $(use_var debug) \
- $(use_var cracklib) \
- $(use_var passwdqc) \
- $(use_var consolekit) \
- $(use_var GNOME_KEYRING gnome-keyring) \
- $(use_var selinux) \
- $(use_var mktemp) \
- $(use_var PAM_SSH pam_ssh) \
- $(use_var sha512) \
- $(use_var KRB5 pam_krb5) \
- $(use_var minimal) \
- IMPLEMENTATION=${implementation} \
- LINUX_PAM_VERSION=${linux_pam_version}
-}
-
-src_test() { :; }
-
-src_install() {
- emake GIT=true DESTDIR="${ED}" install
-}
-
-pkg_postinst() {
- if use sha512; then
- elog "Starting from version 20080801, pambase optionally enables"
- elog "SHA512-hashed passwords. For this to work, you need sys-libs/pam-1.0.1"
- elog "built against sys-libs/glibc-2.7 or later."
- elog "If you don't have support for this, it will automatically fallback"
- elog "to MD5-hashed passwords, just like before."
- elog
- elog "Please note that the change only affects the newly-changed passwords"
- elog "and that SHA512-hashed passwords will not work on earlier versions"
- elog "of glibc or Linux-PAM."
- fi
-}