summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-auth/pam-afs-session
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-auth/pam-afs-session')
-rw-r--r--sys-auth/pam-afs-session/Manifest3
-rw-r--r--sys-auth/pam-afs-session/metadata.xml5
-rw-r--r--sys-auth/pam-afs-session/pam-afs-session-1.3.ebuild28
-rw-r--r--sys-auth/pam-afs-session/pam-afs-session-1.5.ebuild28
-rw-r--r--sys-auth/pam-afs-session/pam-afs-session-1.6.ebuild28
5 files changed, 92 insertions, 0 deletions
diff --git a/sys-auth/pam-afs-session/Manifest b/sys-auth/pam-afs-session/Manifest
new file mode 100644
index 000000000000..6d51c4a1437d
--- /dev/null
+++ b/sys-auth/pam-afs-session/Manifest
@@ -0,0 +1,3 @@
+DIST pam-afs-session-1.3.tar.gz 98643 SHA256 f8cfaf01d0f3025ab6d51c55cf26746a4ddd63dd9156577981ee4cbb453856a9
+DIST pam-afs-session-1.5.tar.gz 101464 SHA256 473b8b1904f0ed1c3748667b037f92aff765f9c8f60e650d81452c6394e26768
+DIST pam-afs-session-1.6.tar.gz 115666 SHA256 c6ecfc69dc8e901f881f0a931797b44a10f47c8c35206e9289336d9435a9f2f8
diff --git a/sys-auth/pam-afs-session/metadata.xml b/sys-auth/pam-afs-session/metadata.xml
new file mode 100644
index 000000000000..81ada335fc94
--- /dev/null
+++ b/sys-auth/pam-afs-session/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>pam</herd>
+</pkgmetadata>
diff --git a/sys-auth/pam-afs-session/pam-afs-session-1.3.ebuild b/sys-auth/pam-afs-session/pam-afs-session-1.3.ebuild
new file mode 100644
index 000000000000..33d10d6f4f9f
--- /dev/null
+++ b/sys-auth/pam-afs-session/pam-afs-session-1.3.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit pam
+
+DESCRIPTION="OpenAFS PAM Module"
+HOMEPAGE="http://www.eyrie.org/~eagle/software/pam-afs-session/"
+SRC_URI="http://archives.eyrie.org/software/afs/${P}.tar.gz"
+
+LICENSE="HPND openafs-krb5-a"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="virtual/krb5 virtual/pam"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ econf --with-kerberos || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ dopammod pam_afs_session.so
+ doman pam_afs_session.5
+ dodoc CHANGES NEWS README TODO
+}
diff --git a/sys-auth/pam-afs-session/pam-afs-session-1.5.ebuild b/sys-auth/pam-afs-session/pam-afs-session-1.5.ebuild
new file mode 100644
index 000000000000..33d10d6f4f9f
--- /dev/null
+++ b/sys-auth/pam-afs-session/pam-afs-session-1.5.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit pam
+
+DESCRIPTION="OpenAFS PAM Module"
+HOMEPAGE="http://www.eyrie.org/~eagle/software/pam-afs-session/"
+SRC_URI="http://archives.eyrie.org/software/afs/${P}.tar.gz"
+
+LICENSE="HPND openafs-krb5-a"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="virtual/krb5 virtual/pam"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ econf --with-kerberos || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ dopammod pam_afs_session.so
+ doman pam_afs_session.5
+ dodoc CHANGES NEWS README TODO
+}
diff --git a/sys-auth/pam-afs-session/pam-afs-session-1.6.ebuild b/sys-auth/pam-afs-session/pam-afs-session-1.6.ebuild
new file mode 100644
index 000000000000..33d10d6f4f9f
--- /dev/null
+++ b/sys-auth/pam-afs-session/pam-afs-session-1.6.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit pam
+
+DESCRIPTION="OpenAFS PAM Module"
+HOMEPAGE="http://www.eyrie.org/~eagle/software/pam-afs-session/"
+SRC_URI="http://archives.eyrie.org/software/afs/${P}.tar.gz"
+
+LICENSE="HPND openafs-krb5-a"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="virtual/krb5 virtual/pam"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ econf --with-kerberos || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ dopammod pam_afs_session.so
+ doman pam_afs_session.5
+ dodoc CHANGES NEWS README TODO
+}