summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-auth/libnss-pgsql
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-auth/libnss-pgsql')
-rw-r--r--sys-auth/libnss-pgsql/Manifest2
-rw-r--r--sys-auth/libnss-pgsql/files/libnss-pgsql-1.4.0-gentoo.patch12
-rw-r--r--sys-auth/libnss-pgsql/files/libnss-pgsql-1.4.0-schema.patch22
-rw-r--r--sys-auth/libnss-pgsql/files/libnss-pgsql-1.5.0_beta-gentoo.patch44
-rw-r--r--sys-auth/libnss-pgsql/libnss-pgsql-1.4.0.ebuild55
-rw-r--r--sys-auth/libnss-pgsql/libnss-pgsql-1.5.0_beta.ebuild54
-rw-r--r--sys-auth/libnss-pgsql/metadata.xml5
7 files changed, 194 insertions, 0 deletions
diff --git a/sys-auth/libnss-pgsql/Manifest b/sys-auth/libnss-pgsql/Manifest
new file mode 100644
index 000000000000..dbf0ad6b1070
--- /dev/null
+++ b/sys-auth/libnss-pgsql/Manifest
@@ -0,0 +1,2 @@
+DIST libnss-pgsql-1.4.0.tgz 244076 SHA256 776efc43b21323380f9b1cf32b4463eddd7050d19912418ea58b856b96c9ee25
+DIST libnss-pgsql-1.5.0-beta.tgz 305543 SHA256 84808c47fd21a09e2c487a0efc72cc18b352275082335be8c6de39d325e6c000
diff --git a/sys-auth/libnss-pgsql/files/libnss-pgsql-1.4.0-gentoo.patch b/sys-auth/libnss-pgsql/files/libnss-pgsql-1.4.0-gentoo.patch
new file mode 100644
index 000000000000..7a2a938b5c78
--- /dev/null
+++ b/sys-auth/libnss-pgsql/files/libnss-pgsql-1.4.0-gentoo.patch
@@ -0,0 +1,12 @@
+diff -Nur libnss-pgsql-1.4.0.orig/src/backend.c libnss-pgsql-1.4.0/src/backend.c
+--- libnss-pgsql-1.4.0.orig/src/backend.c 2001-10-18 13:32:52.000000000 +0200
++++ libnss-pgsql-1.4.0/src/backend.c 2003-11-28 16:14:38.000000000 +0100
+@@ -9,7 +9,7 @@
+ */
+
+ #include "nss-pgsql.h"
+-#include <postgresql/libpq-fe.h>
++#include <libpq-fe.h>
+ #include <stdlib.h>
+ #include <string.h>
+ #include <stdio.h>
diff --git a/sys-auth/libnss-pgsql/files/libnss-pgsql-1.4.0-schema.patch b/sys-auth/libnss-pgsql/files/libnss-pgsql-1.4.0-schema.patch
new file mode 100644
index 000000000000..6d2b338f45cf
--- /dev/null
+++ b/sys-auth/libnss-pgsql/files/libnss-pgsql-1.4.0-schema.patch
@@ -0,0 +1,22 @@
+--- conf/dbschema.sql.orig 2005-05-04 04:27:51.000000000 +0200
++++ conf/dbschema.sql 2006-11-11 22:37:01.000000000 +0100
+@@ -19,15 +19,16 @@
+ "gecos" character varying(128),
+ "homedir" character varying(256) NOT NULL,
+ "shell" character varying DEFAULT '/bin/bash' NOT NULL,
+- PRIMARY KEY ("username")
++ PRIMARY KEY ("username"),
++ UNIQUE ("uid")
+ );
+
+ CREATE TABLE "usergroups" (
+ "gid" int4 NOT NULL,
+ "uid" int4 NOT NULL,
+ PRIMARY KEY ("gid", "uid"),
+- CONSTRAINT "ug_gid_fkey" FOREIGN KEY ("gid") REFERENCES "groups"("gid"),
+- CONSTRAINT "ug_uid_fkey" FOREIGN KEY ("uid") REFERENCES "accounts"("uid")
++ CONSTRAINT "ug_gid_fkey" FOREIGN KEY ("gid") REFERENCES "group_table"("gid"),
++ CONSTRAINT "ug_uid_fkey" FOREIGN KEY ("uid") REFERENCES "passwd_table"("uid")
+ );
+
+ CREATE TABLE "shadow_table" (
diff --git a/sys-auth/libnss-pgsql/files/libnss-pgsql-1.5.0_beta-gentoo.patch b/sys-auth/libnss-pgsql/files/libnss-pgsql-1.5.0_beta-gentoo.patch
new file mode 100644
index 000000000000..69aefa8c6064
--- /dev/null
+++ b/sys-auth/libnss-pgsql/files/libnss-pgsql-1.5.0_beta-gentoo.patch
@@ -0,0 +1,44 @@
+Index: libnss-pgsql-1.5.0-beta/src/backend.c
+===================================================================
+--- libnss-pgsql-1.5.0-beta.orig/src/backend.c
++++ libnss-pgsql-1.5.0-beta/src/backend.c
+@@ -11,7 +11,7 @@
+ */
+
+ #include "nss-pgsql.h"
+-#include <postgresql/libpq-fe.h>
++#include <libpq-fe.h>
+ #include <stdlib.h>
+ #include <string.h>
+ #include <stdio.h>
+Index: libnss-pgsql-1.5.0-beta/doc/Makefile.am
+===================================================================
+--- libnss-pgsql-1.5.0-beta.orig/doc/Makefile.am
++++ libnss-pgsql-1.5.0-beta/doc/Makefile.am
+@@ -1,14 +1,6 @@
+ TARGETS = nss-pgsql.html
+
+-all html: $(TARGETS)
+-
+-install-data-local: $(TARGETS)
+- $(mkinstalldirs) $(DESTDIR)$(docdir)
+- $(INSTALL_DATA) nss-pgsql.html $(DESTDIR)$(docdir)
+- $(INSTALL_DATA) $(srcdir)/caution.png $(DESTDIR)$(docdir)
+-
+-clean-local:
+- rm -f $(TARGETS)
++html_DATA = $(TARGETS) caution.png
+
+ nss-pgsql.html: config.xsl nss-pgsql.xml
+ xmlto xhtml-nochunks -m $(srcdir)/config.xsl $(srcdir)/nss-pgsql.xml
+Index: libnss-pgsql-1.5.0-beta/src/Makefile.am
+===================================================================
+--- libnss-pgsql-1.5.0-beta.orig/src/Makefile.am
++++ libnss-pgsql-1.5.0-beta/src/Makefile.am
+@@ -1,5 +1,5 @@
+ lib_LTLIBRARIES = libnss_pgsql.la
+ libnss_pgsql_la_SOURCES = interface.c config.c backend.c util.c
+-libnss_pgsql_la_LDFLAGS = -module -version-info 2
++libnss_pgsql_la_LDFLAGS = -module -version-info 2 -shared
+ EXTRA_DIST = nss-pgsql.h
+
diff --git a/sys-auth/libnss-pgsql/libnss-pgsql-1.4.0.ebuild b/sys-auth/libnss-pgsql/libnss-pgsql-1.4.0.ebuild
new file mode 100644
index 000000000000..3e0c2b5f0eaa
--- /dev/null
+++ b/sys-auth/libnss-pgsql/libnss-pgsql-1.4.0.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit autotools eutils multilib
+
+KEYWORDS="~x86"
+
+DESCRIPTION="Name Service Switch module for use with PostgreSQL"
+HOMEPAGE="http://pgfoundry.org/projects/sysauth/"
+SRC_URI="http://pgfoundry.org/frs/download.php/605/${P}.tgz"
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+DEPEND="dev-db/postgresql
+ app-text/xmlto"
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-gentoo.patch"
+ epatch "${FILESDIR}/${P}-schema.patch"
+ eautoreconf
+}
+
+src_compile() {
+ econf \
+ --libdir=/lib \
+ --with-docdir=/usr/share/doc/${PF}/html || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ insinto /$(get_libdir)
+ doins src/.libs/libnss_pgsql.so.2.0.0
+ dosym libnss_pgsql.so.2.0.0 /lib/libnss_pgsql.so.2
+ dosym libnss_pgsql.so.2.0.0 /lib/libnss_pgsql.so
+
+ dodoc AUTHORS ChangeLog NEWS README
+ dohtml doc/*.{png,html}
+ insinto /usr/share/doc/${PF}/examples
+ doins conf/*
+}
+
+pkg_postinst() {
+ elog "Next steps:"
+ elog "1. Create the required tables in the database:"
+ elog " $ psql a_database -f ${ROOT}usr/share/${PN}/conf/dbschema.sql"
+ elog "2. Create the configuration file '/etc/nss-pgsql.conf'"
+ elog " You can copy the example from ${ROOT}usr/share/doc/${PF}/examples/nss-pgsql.conf"
+ elog "3. Edit /etc/nsswitch.conf to use the NSS service 'pgsql'"
+ elog " An example is available here: ${ROOT}usr/share/doc/${PF}/examples/nsswitch.conf"
+}
diff --git a/sys-auth/libnss-pgsql/libnss-pgsql-1.5.0_beta.ebuild b/sys-auth/libnss-pgsql/libnss-pgsql-1.5.0_beta.ebuild
new file mode 100644
index 000000000000..c8e11122c607
--- /dev/null
+++ b/sys-auth/libnss-pgsql/libnss-pgsql-1.5.0_beta.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit autotools eutils multilib
+
+KEYWORDS="~amd64 ~x86"
+
+DESCRIPTION="Name Service Switch module for use with PostgreSQL"
+HOMEPAGE="http://pgfoundry.org/projects/sysauth/"
+
+MY_P="${P/_/-}"
+SRC_URI="http://pgfoundry.org/frs/download.php/1878/${MY_P}.tgz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+RDEPEND="dev-db/postgresql"
+DEPEND="${RDEPEND}
+ app-text/xmlto"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-gentoo.patch"
+ eautoreconf
+}
+
+src_compile() {
+ econf \
+ --htmldir=/usr/share/doc/${PF}/html || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ find "${D}" -name '*.la' -delete || die
+
+ dodoc AUTHORS ChangeLog NEWS README || die
+ insinto /usr/share/doc/${PF}/examples
+ doins conf/* || die
+}
+
+pkg_postinst() {
+ elog "Next steps:"
+ elog "1. Create the required tables in the database:"
+ elog " $ psql a_database -f /usr/share/doc/${PF}/examples/dbschema.sql"
+ elog "2. Create the configuration file '/etc/nss-pgsql.conf'"
+ elog " You can copy the example from /usr/share/doc/${PF}/examples/nss-pgsql.conf"
+ elog "3. Edit /etc/nsswitch.conf to use the NSS service 'pgsql'"
+ elog " An example is available here: /usr/share/doc/${PF}/examples/nsswitch.conf"
+}
diff --git a/sys-auth/libnss-pgsql/metadata.xml b/sys-auth/libnss-pgsql/metadata.xml
new file mode 100644
index 000000000000..309b51e9a965
--- /dev/null
+++ b/sys-auth/libnss-pgsql/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>postgresql</herd>
+</pkgmetadata>