summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2017-04-27 12:33:52 -0400
committerMike Gilbert <floppym@gentoo.org>2017-04-27 12:36:21 -0400
commitcda7cf95b9113c2054abd52069d24ae7259d7187 (patch)
treede0c4550beffdf9af25430d492f958dd8675e66a /sys-apps
parentnet-misc/tigervnc: reverted nls changes (diff)
downloadgentoo-cda7cf95b9113c2054abd52069d24ae7259d7187.tar.gz
gentoo-cda7cf95b9113c2054abd52069d24ae7259d7187.tar.bz2
gentoo-cda7cf95b9113c2054abd52069d24ae7259d7187.zip
sys-apps/systemd: add symlinks to ease rootprefix migration
systemd holds the path to systemd and systemd-shutdown in memory. The symlinks ensure that re-exec and reboot will work. Also, the bootloader init option will not need to be updated immediately. Package-Manager: Portage-2.3.5_p31, Repoman-2.3.2_p61
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/systemd/systemd-9999.ebuild8
1 files changed, 7 insertions, 1 deletions
diff --git a/sys-apps/systemd/systemd-9999.ebuild b/sys-apps/systemd/systemd-9999.ebuild
index 55c4ac98da38..8ab713955c87 100644
--- a/sys-apps/systemd/systemd-9999.ebuild
+++ b/sys-apps/systemd/systemd-9999.ebuild
@@ -203,7 +203,7 @@ multilib_src_configure() {
-Dbashcompletiondir="$(get_bashcompdir)"
# make sure we get /bin:/sbin in $PATH
-Dsplit-usr=true
- -Drootprefix="${ROOTPREFIX}"
+ -Drootprefix="${EPREFIX}${ROOTPREFIX}"
-Dsysvinit-path=
-Dsysvrcnd-path=
# no deps
@@ -326,6 +326,12 @@ multilib_src_install_all() {
rm -r "${ED%/}"/etc/systemd/system/sysinit.target.wants || die
rm -r "${ED%/}${ROOTPREFIX%/}/lib/udev/hwdb.d" || die
+
+ if [[ ! -e "${ED%/}"/usr/lib/systemd/systemd ]]; then
+ # Avoid breaking boot/reboot
+ dosym "../../..${ROOTPREFIX%/}/lib/systemd/systemd" /usr/lib/systemd/systemd
+ dosym "../../..${ROOTPREFIX%/}/lib/systemd/systemd-shutdown" /usr/lib/systemd/systemd-shutdown
+ fi
}
migrate_locale() {