summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorViorel Munteanu <ceamac@gentoo.org>2023-05-24 18:16:13 +0300
committerViorel Munteanu <ceamac@gentoo.org>2023-05-24 18:35:32 +0300
commitc153e982c2c2d6066a27e240484e2db08aaaf940 (patch)
tree07b263f8e15cef8dd26bda8352ecbbcf3f2af710 /sys-apps
parentsys-apps/busybox: add 1.36.1 (diff)
downloadgentoo-c153e982c2c2d6066a27e240484e2db08aaaf940.tar.gz
gentoo-c153e982c2c2d6066a27e240484e2db08aaaf940.tar.bz2
gentoo-c153e982c2c2d6066a27e240484e2db08aaaf940.zip
sys-apps/busybox: sync live
Sync live. Update EAPI 7 -> 8. Signed-off-by: Viorel Munteanu <ceamac@gentoo.org>
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/busybox/busybox-9999.ebuild28
-rw-r--r--sys-apps/busybox/files/busybox-1.36.0-fix-wx-sections.patch74
2 files changed, 11 insertions, 91 deletions
diff --git a/sys-apps/busybox/busybox-9999.ebuild b/sys-apps/busybox/busybox-9999.ebuild
index 51f115d22ffb..a9f3d85703c7 100644
--- a/sys-apps/busybox/busybox-9999.ebuild
+++ b/sys-apps/busybox/busybox-9999.ebuild
@@ -3,9 +3,9 @@
# See `man savedconfig.eclass` for info on how to use USE=savedconfig.
-EAPI=7
+EAPI=8
-inherit eapi8-dosym flag-o-matic savedconfig toolchain-funcs
+inherit flag-o-matic savedconfig toolchain-funcs
DESCRIPTION="Utilities for rescue and embedded systems"
HOMEPAGE="https://www.busybox.net/"
@@ -18,10 +18,11 @@ else
SRC_URI="https://www.busybox.net/downloads/${MY_P}.tar.bz2"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
fi
+S="${WORKDIR}/${MY_P}"
LICENSE="GPL-2" # GPL-2 only
SLOT="0"
-IUSE="debug ipv6 livecd make-symlinks math mdev pam selinux sep-usr static syslog systemd"
+IUSE="debug livecd make-symlinks math mdev pam selinux sep-usr static syslog systemd"
REQUIRED_USE="pam? ( !static )"
RESTRICT="test"
@@ -42,8 +43,6 @@ DEPEND="${RDEPEND}
sys-kernel/linux-headers"
BDEPEND="virtual/pkgconfig"
-S="${WORKDIR}/${MY_P}"
-
busybox_config_option() {
local flag=$1 ; shift
if [[ ${flag} != [yn] && ${flag} != \"* ]] ; then
@@ -76,7 +75,9 @@ busybox_config_enabled() {
PATCHES=(
"${FILESDIR}"/${PN}-1.26.2-bb.patch
"${FILESDIR}"/${PN}-1.34.1-skip-selinux-search.patch
- "${FILESDIR}"/${PN}-1.36.0-fix-wx-sections.patch
+
+ "${FILESDIR}"/${PN}-1.36.0-fortify-source-3-fixdep.patch
+
# "${FILESDIR}"/${P}-*.patch
)
@@ -173,14 +174,6 @@ src_configure() {
busybox_config_option '"/run"' PID_FILE_PATH
busybox_config_option '"/run/ifstate"' IFUPDOWN_IFSTATE_PATH
- # disable ipv6 applets
- if ! use ipv6; then
- busybox_config_option n FEATURE_IPV6
- busybox_config_option n TRACEROUTE6
- busybox_config_option n PING6
- busybox_config_option n UDHCPC6
- fi
-
busybox_config_option pam PAM
busybox_config_option static STATIC
busybox_config_option syslog {K,SYS}LOGD LOGGER
@@ -261,7 +254,8 @@ src_install() {
use make-symlinks || dosym /bin/bb /sbin/mdev
cp "${S}"/examples/mdev_fat.conf "${ED}"/etc/mdev.conf || die
if [[ ! "$(get_libdir)" == "lib" ]]; then
- sed -i -e "s:/lib/:/$(get_libdir)/:g" "${ED}"/etc/mdev.conf || die #831251 - replace lib with lib64 where appropriate
+ #831251 - replace lib with lib64 where appropriate
+ sed -i -e "s:/lib/:/$(get_libdir)/:g" "${ED}"/etc/mdev.conf || die
fi
exeinto /$(get_libdir)/mdev/
@@ -301,7 +295,7 @@ src_install() {
doins examples/udhcp/udhcpd.conf
fi
if busybox_config_enabled ASH && ! use make-symlinks; then
- dosym8 -r /bin/busybox /bin/ash
+ dosym -r /bin/busybox /bin/ash
fi
if busybox_config_enabled CROND; then
newconfd "${FILESDIR}"/crond.confd busybox-crond
@@ -310,12 +304,12 @@ src_install() {
# bundle up the symlink files for use later
emake DESTDIR="${ED}" install
- rm _install/bin/busybox || die
# for compatibility, provide /usr/bin/env
mkdir -p _install/usr/bin || die
if [[ ! -e _install/usr/bin/env ]]; then
ln -s /bin/env _install/usr/bin/env || die
fi
+ rm _install/bin/busybox || die
tar cf busybox-links.tar -C _install . || : #;die
insinto /usr/share/${PN}
use make-symlinks && doins busybox-links.tar
diff --git a/sys-apps/busybox/files/busybox-1.36.0-fix-wx-sections.patch b/sys-apps/busybox/files/busybox-1.36.0-fix-wx-sections.patch
deleted file mode 100644
index 16118cf9b95f..000000000000
--- a/sys-apps/busybox/files/busybox-1.36.0-fix-wx-sections.patch
+++ /dev/null
@@ -1,74 +0,0 @@
- * QA Notice: The following files contain writable and executable sections
- * Files with such sections will not work properly (or at all!) on some
- * architectures/operating systems. A bug should be filed at
- * https://bugs.gentoo.org/ to make sure the issue is fixed.
- * For more information, see:
- *
- * https://wiki.gentoo.org/wiki/Hardened/GNU_stack_quickstart
- *
- * Please include the following list of files in your report:
- * Note: Bugs should be filed for the respective maintainers
- * of the package in question and not hardened@gentoo.org.
- * RWX --- --- bin/busybox
-
-$ scanelf -qeR .
-RWX --- --- ./busybox
-RWX --- --- ./busybox_unstripped
-!WX --- --- ./libbb/hash_md5_sha_x86-64_shaNI.o
-!WX --- --- ./libbb/hash_md5_sha_x86-64.o
-!WX --- --- ./libbb/hash_md5_sha_x86-32_shaNI.o
-!WX --- --- ./libbb/hash_md5_sha256_x86-64_shaNI.o
-!WX --- --- ./libbb/hash_md5_sha256_x86-32_shaNI.o
-
-Try to fix this QA issue
-
---- a/libbb/hash_md5_sha256_x86-32_shaNI.S
-+++ b/libbb/hash_md5_sha256_x86-32_shaNI.S
-@@ -278,4 +278,7 @@
- PSHUFFLE_BSWAP32_FLIP_MASK:
- .octa 0x0c0d0e0f08090a0b0405060700010203
-
-+#if defined(__linux__) && defined(__ELF__)
-+ .section .note.GNU-stack, "", %progbits
-+#endif
- #endif
---- a/libbb/hash_md5_sha256_x86-64_shaNI.S
-+++ b/libbb/hash_md5_sha256_x86-64_shaNI.S
-@@ -284,4 +284,7 @@
- PSHUFFLE_BSWAP32_FLIP_MASK:
- .octa 0x0c0d0e0f08090a0b0405060700010203
-
-+#if defined(__linux__) && defined(__ELF__)
-+ .section .note.GNU-stack, "", %progbits
-+#endif
- #endif
---- a/libbb/hash_md5_sha_x86-32_shaNI.S
-+++ b/libbb/hash_md5_sha_x86-32_shaNI.S
-@@ -228,4 +228,7 @@
- PSHUFFLE_BYTE_FLIP_MASK:
- .octa 0x000102030405060708090a0b0c0d0e0f
-
-+#if defined(__linux__) && defined(__ELF__)
-+ .section .note.GNU-stack, "", %progbits
-+#endif
- #endif
---- a/libbb/hash_md5_sha_x86-64.S
-+++ b/libbb/hash_md5_sha_x86-64.S
-@@ -1483,4 +1483,7 @@
- .long 0x8F1BBCDC
- .long 0xCA62C1D6
-
-+#if defined(__linux__) && defined(__ELF__)
-+ .section .note.GNU-stack, "", %progbits
-+#endif
- #endif
---- a/libbb/hash_md5_sha_x86-64_shaNI.S
-+++ b/libbb/hash_md5_sha_x86-64_shaNI.S
-@@ -226,4 +226,7 @@
- PSHUFFLE_BYTE_FLIP_MASK:
- .octa 0x000102030405060708090a0b0c0d0e0f
-
-+#if defined(__linux__) && defined(__ELF__)
-+ .section .note.GNU-stack, "", %progbits
-+#endif
- #endif