summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2024-06-23 09:18:27 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2024-06-23 09:18:27 +0300
commitb19aef227efe1602ffe9e1586504000934b84194 (patch)
treed7e2f7c3e4e89e8b5b454fec3b6ebb0fcdddfd47 /sys-apps
parentnet-ftp/proftpd: Stabilize 1.3.8b ppc, #934755 (diff)
downloadgentoo-b19aef227efe1602ffe9e1586504000934b84194.tar.gz
gentoo-b19aef227efe1602ffe9e1586504000934b84194.tar.bz2
gentoo-b19aef227efe1602ffe9e1586504000934b84194.zip
sys-apps/paxctld: EAPI 6 -> 8
Closes: https://bugs.gentoo.org/829703 Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/paxctld/paxctld-1.2.5-r1.ebuild (renamed from sys-apps/paxctld/paxctld-1.2.5.ebuild)30
1 files changed, 12 insertions, 18 deletions
diff --git a/sys-apps/paxctld/paxctld-1.2.5.ebuild b/sys-apps/paxctld/paxctld-1.2.5-r1.ebuild
index c4650263e8b3..cba38e8e2631 100644
--- a/sys-apps/paxctld/paxctld-1.2.5.ebuild
+++ b/sys-apps/paxctld/paxctld-1.2.5-r1.ebuild
@@ -1,37 +1,31 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="6"
+EAPI=8
-inherit systemd
+inherit systemd toolchain-funcs
DESCRIPTION="PaX flags maintenance daemon"
HOMEPAGE="https://www.grsecurity.net/"
-SRC_URI="https://www.grsecurity.net/${PN}/${PN}_${PV}.orig.tar.gz
- https://dev.gentoo.org/~blueness/hardened-sources/${PN}/${PN}_${PV}.orig.tar.gz"
+SRC_URI="https://www.grsecurity.net/${PN}/${PN}_${PV}.orig.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
-IUSE="pam"
-
-RDEPEND=""
-DEPEND=""
src_prepare() {
# Respect Gentoo flags and don't strip
- sed -i \
- -e '/^CC/d' \
- -e '/^CFLAGS/d' \
- -e '/^LDFLAGS/d' \
- -e '/STRIP/d' \
- Makefile
-
- eapply_user
+ sed -i Makefile -e '/^CC=/d' -e '/^CFLAGS?=/d' -e '/^LDFLAGS=/d' -e '/STRIP/d' || die
+
+ default
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)"
}
src_install() {
default
- systemd_dounit "${S}"/rpm/${PN}.service
+ systemd_dounit rpm/${PN}.service
}