summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2022-04-17 09:56:05 -0400
committerMike Gilbert <floppym@gentoo.org>2022-04-17 09:56:54 -0400
commit841cfaa31184136b10b4b3c1ebc86320a831966f (patch)
tree71da9d7db7e43a564d262612d32ff7fcbb441ef1 /sys-apps
parentvirtual/perl-IO-Compress: Adapt for zlib fix (diff)
downloadgentoo-841cfaa31184136b10b4b3c1ebc86320a831966f.tar.gz
gentoo-841cfaa31184136b10b4b3c1ebc86320a831966f.tar.bz2
gentoo-841cfaa31184136b10b4b3c1ebc86320a831966f.zip
sys-apps/systemd-utils: fix test-systemd-tmpfiles
Signed-off-by: Mike Gilbert <floppym@gentoo.org>
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/systemd-utils/files/250.4-test-systemd-tmpfiles.standalone.patch40
-rw-r--r--sys-apps/systemd-utils/systemd-utils-250.4.ebuild3
2 files changed, 42 insertions, 1 deletions
diff --git a/sys-apps/systemd-utils/files/250.4-test-systemd-tmpfiles.standalone.patch b/sys-apps/systemd-utils/files/250.4-test-systemd-tmpfiles.standalone.patch
new file mode 100644
index 000000000000..a915cbb43115
--- /dev/null
+++ b/sys-apps/systemd-utils/files/250.4-test-systemd-tmpfiles.standalone.patch
@@ -0,0 +1,40 @@
+From 55bf689308ed00692494d3623bd2064f33c9bbbe Mon Sep 17 00:00:00 2001
+From: Mike Gilbert <floppym@gentoo.org>
+Date: Sun, 17 Apr 2022 09:48:28 -0400
+Subject: [PATCH] Add test support for systemd-tmpfiles.standalone
+
+---
+ meson.build | 10 +++++++++-
+ 1 file changed, 9 insertions(+), 1 deletion(-)
+
+diff --git a/meson.build b/meson.build
+index 458370e83d..d60be1b050 100644
+--- a/meson.build
++++ b/meson.build
+@@ -3451,7 +3451,7 @@ if conf.get('ENABLE_TMPFILES') == 1
+ endif
+
+ if have_standalone_binaries
+- public_programs += executable(
++ exe = executable(
+ 'systemd-tmpfiles.standalone',
+ systemd_tmpfiles_sources,
+ include_directories : includes,
+@@ -3463,6 +3463,14 @@ if conf.get('ENABLE_TMPFILES') == 1
+ dependencies : [libacl],
+ install : true,
+ install_dir : rootbindir)
++ public_programs += exe
++
++ if want_tests != 'false'
++ test('test-systemd-tmpfiles.standalone',
++ test_systemd_tmpfiles_py,
++ # https://github.com/mesonbuild/meson/issues/2681
++ args : exe.full_path())
++ endif
+ endif
+ endif
+
+--
+2.35.1
+
diff --git a/sys-apps/systemd-utils/systemd-utils-250.4.ebuild b/sys-apps/systemd-utils/systemd-utils-250.4.ebuild
index cda7180f1b83..aee6304e1eaa 100644
--- a/sys-apps/systemd-utils/systemd-utils-250.4.ebuild
+++ b/sys-apps/systemd-utils/systemd-utils-250.4.ebuild
@@ -98,6 +98,7 @@ QA_FLAGS_IGNORED="usr/lib/systemd/boot/efi/.*"
src_prepare() {
local PATCHES=(
+ "${FILESDIR}/250.4-test-systemd-tmpfiles.standalone.patch"
)
if use elibc_musl; then
PATCHES+=( "${WORKDIR}/${MUSL_PATCHSET}" )
@@ -325,7 +326,7 @@ multilib_src_test() {
fi
if use tmpfiles; then
tests+=(
- test-systemd-tmpfiles
+ test-systemd-tmpfiles.standalone
test-tmpfiles
)
fi