summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-07-30 23:31:28 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-07-30 23:31:28 +0300
commit51e94a89ceca9e623e9f8951a8c759d9f2cbf389 (patch)
tree5dc00ed3fe2589b0af6c057e564ea8b7bba6d367 /sys-apps
parentdev-java/jdbc-postgresql: drop 9.4_p1206-r1 (diff)
downloadgentoo-51e94a89ceca9e623e9f8951a8c759d9f2cbf389.tar.gz
gentoo-51e94a89ceca9e623e9f8951a8c759d9f2cbf389.tar.bz2
gentoo-51e94a89ceca9e623e9f8951a8c759d9f2cbf389.zip
sys-apps/pkgcore: add 0.12.12, Use PEP517
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/pkgcore/Manifest1
-rw-r--r--sys-apps/pkgcore/pkgcore-0.12.12.ebuild56
-rw-r--r--sys-apps/pkgcore/pkgcore-9999.ebuild7
3 files changed, 61 insertions, 3 deletions
diff --git a/sys-apps/pkgcore/Manifest b/sys-apps/pkgcore/Manifest
index 95d79f167062..5c1410d139f3 100644
--- a/sys-apps/pkgcore/Manifest
+++ b/sys-apps/pkgcore/Manifest
@@ -1 +1,2 @@
DIST pkgcore-0.12.11.tar.gz 625613 BLAKE2B f9bb17286cf30714d9f6f47ae6286031e418fd5f420e8921e1f1ed546cb1f293772e8d6e11ea2f4af8046d82fd166abb7c27f640f7f105c13a73d9ce19ccc52b SHA512 b98804603a9d14562efd56d01fa0b17ee1753d25b8c108d0d12eb47b103787f5fa7170f9924b473996817f31c31c40b5920db597974438cdc43215f5f83e43db
+DIST pkgcore-0.12.12.tar.gz 625488 BLAKE2B a1492b642447b8bf8fff6eb7cf85cf8d1355984afeb9d385383574327e3636aad7f9e7932a44a55649a64126b90d68de60e3653affb2753916fd439d15edcde9 SHA512 fe813d7e0be7b7ca0686ce4047211dc2a08e49d3b041ea6935e3cc905e1c8cf8f15fda2d4c0852bfaa191d898d774999b85bc9b440a5c32d438e2a8157caafbc
diff --git a/sys-apps/pkgcore/pkgcore-0.12.12.ebuild b/sys-apps/pkgcore/pkgcore-0.12.12.ebuild
new file mode 100644
index 000000000000..0919b8f2c070
--- /dev/null
+++ b/sys-apps/pkgcore/pkgcore-0.12.12.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+if [[ ${PV} == *9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/pkgcore/pkgcore.git"
+ inherit git-r3
+else
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+fi
+
+DESCRIPTION="a framework for package management"
+HOMEPAGE="https://github.com/pkgcore/pkgcore"
+
+LICENSE="BSD MIT"
+SLOT="0"
+
+RDEPEND="
+ >=app-shells/bash-5.0
+ dev-python/lxml[${PYTHON_USEDEP}]
+"
+if [[ ${PV} == *9999 ]]; then
+ RDEPEND+=" ~dev-python/snakeoil-9999[${PYTHON_USEDEP}]"
+else
+ RDEPEND+=" >=dev-python/snakeoil-0.9.11[${PYTHON_USEDEP}]"
+fi
+BDEPEND="
+ test? (
+ >=dev-python/pytest-6[${PYTHON_USEDEP}]
+ dev-vcs/git
+ )
+"
+
+distutils_enable_tests setup.py
+
+src_test() {
+ # With PYTHONDONTWRITEBYTECODE=, python will try rebuild all sorts of modules.
+ # https://bugs.gentoo.org/840266
+ local -x SANDBOX_PREDICT=${SANDBOX_PREDICT}
+ addpredict /
+
+ local -x PYTHONDONTWRITEBYTECODE=
+ distutils-r1_src_test
+}
+
+python_install_all() {
+ local DOCS=( NEWS.rst )
+ [[ ${PV} == *9999 ]] || doman man/*
+ distutils-r1_python_install_all
+}
diff --git a/sys-apps/pkgcore/pkgcore-9999.ebuild b/sys-apps/pkgcore/pkgcore-9999.ebuild
index 8ee26f5ac2e5..0919b8f2c070 100644
--- a/sys-apps/pkgcore/pkgcore-9999.ebuild
+++ b/sys-apps/pkgcore/pkgcore-9999.ebuild
@@ -3,8 +3,8 @@
EAPI=8
+DISTUTILS_USE_PEP517=setuptools
PYTHON_COMPAT=( python3_{8..10} )
-DISTUTILS_IN_SOURCE_BUILD=1
inherit distutils-r1
if [[ ${PV} == *9999 ]] ; then
@@ -23,11 +23,12 @@ SLOT="0"
RDEPEND="
>=app-shells/bash-5.0
- dev-python/lxml[${PYTHON_USEDEP}]"
+ dev-python/lxml[${PYTHON_USEDEP}]
+"
if [[ ${PV} == *9999 ]]; then
RDEPEND+=" ~dev-python/snakeoil-9999[${PYTHON_USEDEP}]"
else
- RDEPEND+=" >=dev-python/snakeoil-0.9.10[${PYTHON_USEDEP}]"
+ RDEPEND+=" >=dev-python/snakeoil-0.9.11[${PYTHON_USEDEP}]"
fi
BDEPEND="
test? (