summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-09-22 23:32:42 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2021-09-22 23:59:10 +0200
commite45aaa1c1877ebb24f4ac0431e89ab448825d95d (patch)
treefc81278ecb7ceb275f6a4da873b21b065c45135d /sys-apps/xdg-desktop-portal
parentkde-apps/konsole: (Final) fix(?) for window flashing on session close (diff)
downloadgentoo-e45aaa1c1877ebb24f4ac0431e89ab448825d95d.tar.gz
gentoo-e45aaa1c1877ebb24f4ac0431e89ab448825d95d.tar.bz2
gentoo-e45aaa1c1877ebb24f4ac0431e89ab448825d95d.zip
sys-apps/xdg-desktop-portal: 1.10.1 version bump
Package-Manager: Portage-3.0.23, Repoman-3.0.3 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'sys-apps/xdg-desktop-portal')
-rw-r--r--sys-apps/xdg-desktop-portal/Manifest1
-rw-r--r--sys-apps/xdg-desktop-portal/xdg-desktop-portal-1.10.1.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/sys-apps/xdg-desktop-portal/Manifest b/sys-apps/xdg-desktop-portal/Manifest
index 704e875657aa..5fbb2d137f07 100644
--- a/sys-apps/xdg-desktop-portal/Manifest
+++ b/sys-apps/xdg-desktop-portal/Manifest
@@ -1 +1,2 @@
+DIST xdg-desktop-portal-1.10.1.tar.xz 479660 BLAKE2B 88a2b8ea890036bf0d4192fae4ae143e350d903a528e09a0bd7ffc7bda2a58b5c04ae80f1cec4357bb05cba8db417b6193fc6ef7f7dd65bf414f80a8ac2800c5 SHA512 5db0bd866674ff016d864646ea7f91f09a1b8fbc5ec735e4c97165af71770d2c7d3333e771062644dd522b32f67ead72bc7ef99186e3b069671c174d4d601fdc
DIST xdg-desktop-portal-1.8.1.tar.xz 473052 BLAKE2B a7d0aa2aa1e8220ced3e4abff8a8284c521b983ce807cd3e0d7b5d22f98f6428b6de9a193ae3aced9c13473617f453d13d0af83c677e3d077906b6cf8a138d45 SHA512 447d287d6627a1086d97dc5ebda20dfb1d0ca8643cbe54a7af5f6205a122a7be9d1643fded592f922c015561b7e2f4c6b6df555db3e0d3c02aad5bbe944077b6
diff --git a/sys-apps/xdg-desktop-portal/xdg-desktop-portal-1.10.1.ebuild b/sys-apps/xdg-desktop-portal/xdg-desktop-portal-1.10.1.ebuild
new file mode 100644
index 000000000000..8f4d537d111c
--- /dev/null
+++ b/sys-apps/xdg-desktop-portal/xdg-desktop-portal-1.10.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit systemd
+
+DESCRIPTION="Desktop integration portal"
+HOMEPAGE="https://flatpak.org/ https://github.com/flatpak/xdg-desktop-portal"
+SRC_URI="https://github.com/flatpak/${PN}/releases/download/${PV}/${P}.tar.xz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+IUSE="geolocation screencast"
+
+BDEPEND="
+ dev-util/gdbus-codegen
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+DEPEND="
+ dev-libs/glib:2
+ dev-libs/json-glib
+ sys-fs/fuse:0
+ geolocation? ( >=app-misc/geoclue-2.5.3:2.0 )
+ screencast? ( >=media-video/pipewire-0.3:= )
+"
+RDEPEND="${DEPEND}
+ sys-apps/dbus
+"
+
+src_configure() {
+ local myeconfargs=(
+ --with-systemduserunitdir="$(systemd_get_userunitdir)"
+ $(use_enable geolocation geoclue)
+ $(use_enable screencast pipewire)
+ --disable-docbook-docs # requires flatpak
+ --disable-libportal # not packaged
+ )
+ econf "${myeconfargs[@]}"
+}