summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-05-22 19:01:43 +0200
committerMaciej Barć <xgqt@gentoo.org>2023-05-22 19:15:37 +0200
commit0081a6fe6a675aaa0c1bfe3624f5ef1530a5c985 (patch)
tree60f4d6e207e0cdcbb1b73227663cf3e8d7afd302 /sys-apps/system-monitoring-center
parentgames-emulation/ppsspp: bump to 1.15.4 (diff)
downloadgentoo-0081a6fe6a675aaa0c1bfe3624f5ef1530a5c985.tar.gz
gentoo-0081a6fe6a675aaa0c1bfe3624f5ef1530a5c985.tar.bz2
gentoo-0081a6fe6a675aaa0c1bfe3624f5ef1530a5c985.zip
sys-apps/system-monitoring-center: bump to 2.14.0
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'sys-apps/system-monitoring-center')
-rw-r--r--sys-apps/system-monitoring-center/Manifest1
-rw-r--r--sys-apps/system-monitoring-center/system-monitoring-center-2.14.0.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/sys-apps/system-monitoring-center/Manifest b/sys-apps/system-monitoring-center/Manifest
index 09f9e0d55fb7..98cc819f35b0 100644
--- a/sys-apps/system-monitoring-center/Manifest
+++ b/sys-apps/system-monitoring-center/Manifest
@@ -1,3 +1,4 @@
DIST system-monitoring-center-2.10.0.tar.gz 536051 BLAKE2B 198771c8ee79359644f2760954629026ce8edb4d451c83f8a2ca179f1ef59883ccb1dc9764388e6e778f5af9e5a96997ec70553be9bfefcbed60bce8a6e936b3 SHA512 ac46956b1e8cb1a21444f047c93ead522a1f99b2b2e63f342ac79e57c377cf3e7474e70d60410f7b657c9284f78ee00f3830fdd873e5ff9d2d500343077628c9
DIST system-monitoring-center-2.12.0.tar.gz 538699 BLAKE2B a7e610897fb814b8caa48d28c9b2595d95cfb25522977b908e286df51160d71d5df9e03d7c5ec29ed4f162f503c346769f5247e739840edd0e91ef8c1b098951 SHA512 e7216fc5765835380e6b9c2432c99f00a57e3ffe10638752360b3ec2ccf2edbf0a5e294560ade341329bc27bdacaadc77d32c0aff84261733d9f46428f1b1686
DIST system-monitoring-center-2.13.0.tar.gz 546649 BLAKE2B 2dc070f7309baf2e3914e0353de6174e4ac97109619d3053236d276a78aa52cde120a26400dc73796b1b3cac649d78984e8b47fb32efb869cd985b6ddaa06c48 SHA512 831c295396b970ee5b0114554cfb763d5fc726539549d3bca8adf6e4127dd4e323940549be83fa1984ec9ca027f055945ae288a51a2b8593f131ac2b39e150a4
+DIST system-monitoring-center-2.14.0.tar.gz 550257 BLAKE2B 3ea3b392c08bcbdba960f03b00a65dab94e1911b53f17fe38ccbd9a7c59f38094a928184a0db488fcd7c60d80ff31a7e59e2bfdf0efda43035cfd59b0f3e38e1 SHA512 4453709b1ef937ba8582ab76b25573f9e4975f4f905284c273dc3490ff2348800fb1c6ed3bca96db4952fc9c3b7fae2fd278ed945fe5c14f8dcfcec410eca415
diff --git a/sys-apps/system-monitoring-center/system-monitoring-center-2.14.0.ebuild b/sys-apps/system-monitoring-center/system-monitoring-center-2.14.0.ebuild
new file mode 100644
index 000000000000..1274d6fa96c9
--- /dev/null
+++ b/sys-apps/system-monitoring-center/system-monitoring-center-2.14.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit meson python-single-r1 xdg
+
+DESCRIPTION="Multi-featured system monitor GUI written in Python"
+HOMEPAGE="https://github.com/hakandundar34coding/system-monitoring-center/"
+SRC_URI="https://github.com/hakandundar34coding/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ gui-libs/gtk:4[introspection]
+ sys-apps/dmidecode
+ sys-apps/hwdata
+ $(python_gen_cond_dep '
+ dev-python/pycairo[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ ')
+"
+
+src_install() {
+ meson_src_install
+ python_optimize "${ED}"/usr/share/${PN}
+
+ mv "${ED}"/usr/share/appdata "${ED}"/usr/share/metainfo || die
+}