summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-12-20 01:27:07 +0000
committerSam James <sam@gentoo.org>2021-12-20 01:27:22 +0000
commitca1bb8531416b974b09efde5028ea46829e3c2c0 (patch)
tree4b5063ae8336bff0f5301dd92028cbae142c7d74 /sys-apps/shadow/files
parentx11-misc/skippy: drop project desktop-misc (diff)
downloadgentoo-ca1bb8531416b974b09efde5028ea46829e3c2c0.tar.gz
gentoo-ca1bb8531416b974b09efde5028ea46829e3c2c0.tar.bz2
gentoo-ca1bb8531416b974b09efde5028ea46829e3c2c0.zip
sys-apps/shadow: fix libsubid SONAME, add subslot for libsubid
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-apps/shadow/files')
-rw-r--r--sys-apps/shadow/files/shadow-4.10-libsubid-soname.patch27
1 files changed, 27 insertions, 0 deletions
diff --git a/sys-apps/shadow/files/shadow-4.10-libsubid-soname.patch b/sys-apps/shadow/files/shadow-4.10-libsubid-soname.patch
new file mode 100644
index 000000000000..dffffb9c917b
--- /dev/null
+++ b/sys-apps/shadow/files/shadow-4.10-libsubid-soname.patch
@@ -0,0 +1,27 @@
+https://github.com/shadow-maint/shadow/pull/463
+
+From: Sam James <sam@gentoo.org>
+Date: Mon, 20 Dec 2021 01:24:16 +0000
+Subject: [PATCH] libsubid: fix defining SONAME version
+
+We were overriding this when --enable-shared was passed. We can actually
+just dump the conditional logic as libtool will do the right thing for
+us here anyway.
+
+Without this patch, libsubid is installed as .0.
+
+Signed-off-by: Sam James <sam@gentoo.org>
+--- a/libsubid/Makefile.am
++++ b/libsubid/Makefile.am
+@@ -1,10 +1,6 @@
+ lib_LTLIBRARIES = libsubid.la
+-if ENABLE_SHARED
+-libsubid_la_LDFLAGS = -Wl,-soname,libsubid.so.@LIBSUBID_ABI@ \
+- -shared -version-info @LIBSUBID_ABI_MAJOR@
+-endif
+ libsubid_la_SOURCES = api.c
+-libsubid_la_LDFLAGS = -export-symbols-regex '^subid_'
++libsubid_la_LDFLAGS = -version-info @LIBSUBID_ABI_MAJOR@ -export-symbols-regex '^subid_'
+
+ pkginclude_HEADERS = subid.h
+