summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-apps/s6
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-apps/s6')
-rw-r--r--sys-apps/s6/Manifest1
-rw-r--r--sys-apps/s6/metadata.xml12
-rw-r--r--sys-apps/s6/s6-2.1.3.0.ebuild67
3 files changed, 80 insertions, 0 deletions
diff --git a/sys-apps/s6/Manifest b/sys-apps/s6/Manifest
new file mode 100644
index 000000000000..272611d7bf8a
--- /dev/null
+++ b/sys-apps/s6/Manifest
@@ -0,0 +1 @@
+DIST s6-2.1.3.0.tar.gz 181237 SHA256 73057df188f1ac8db186b96298c0cb6081199aa73d3f2f8d5fabdbbe21c3ea04 SHA512 f5b962fb9f36a910fd8b56b1158cc28d1dab808f22f6beb309b8c23dab1863409aaecd2e3806b51ec34aef1c70f117d3b8af4c7167e0e854f6925fe278cdcaca WHIRLPOOL 03283a6c2a8a9419bf7e27a9e6c46fe2fe9ad0cbb384f4da0efaec56f5066ab36d20b00aae7a81408ca7b94a1325625feb83173e99e9ff9e85f28be69e6ba2c7
diff --git a/sys-apps/s6/metadata.xml b/sys-apps/s6/metadata.xml
new file mode 100644
index 000000000000..86b621740cd9
--- /dev/null
+++ b/sys-apps/s6/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>williamh@gentoo.org</email>
+ <name>William Hubbs</name>
+ </maintainer>
+ <longdescription lang="en">
+ S6 is a small suite of programs for UNIX designed to allow
+ service supervision similar to daemontools or runit.
+ </longdescription>
+</pkgmetadata>
diff --git a/sys-apps/s6/s6-2.1.3.0.ebuild b/sys-apps/s6/s6-2.1.3.0.ebuild
new file mode 100644
index 000000000000..49d101fd644e
--- /dev/null
+++ b/sys-apps/s6/s6-2.1.3.0.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit multilib
+
+DESCRIPTION="skarnet.org's small and secure supervision software suite"
+HOMEPAGE="http://www.skarnet.org/software/s6/"
+SRC_URI="http://www.skarnet.org/software/${PN}/${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="amd64 ~x86"
+IUSE="static"
+
+DEPEND=">=sys-devel/make-4.0
+ static? (
+ >=dev-lang/execline-2.1.1.0[static-libs]
+ >=dev-libs/skalibs-2.3.2.0[static-libs]
+ )
+ !static? (
+ >=dev-lang/execline-2.1.1.0
+ >=dev-libs/skalibs-2.3.2.0
+ )
+ "
+RDEPEND="
+ !static? (
+ >=dev-lang/execline-2.1.1.0
+ >=dev-libs/skalibs-2.3.2.0
+ )
+ "
+
+src_prepare()
+{
+ # Remove QA warning about LDFLAGS addition
+ sed -i "s~tryldflag LDFLAGS_AUTO -Wl,--hash-style=both~:~" "${S}/configure" || die
+}
+
+src_configure()
+{
+ econf \
+ $(use_enable !static shared) \
+ $(use_enable static allstatic) \
+ $(use_enable static) \
+ --bindir=/bin \
+ --sbindir=/sbin \
+ --dynlibdir=/$(get_libdir) \
+ --libdir=/usr/$(get_libdir)/${PN} \
+ --datadir=/etc \
+ --sysdepdir=/usr/$(get_libdir)/${PN} \
+ --with-dynlib=/$(get_libdir) \
+ --with-sysdeps=/usr/$(get_libdir)/skalibs
+}
+
+src_compile()
+{
+ emake DESTDIR="${D}"
+}
+
+src_install()
+{
+ default
+ dodoc -r examples
+ dohtml -r doc/*
+}