summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2020-09-01 02:10:02 +0000
committerSam James <sam@gentoo.org>2020-09-01 02:10:02 +0000
commitbd98a6f60cbfc54571e446e06297832c506f9fe1 (patch)
treeb41197ac36e85fdc0e6c58d68fcf9139ea4349b1 /sys-apps/qcontrol
parentx11-libs/libnotify: Stabilize 0.7.9 sparc, #733592 (diff)
downloadgentoo-bd98a6f60cbfc54571e446e06297832c506f9fe1.tar.gz
gentoo-bd98a6f60cbfc54571e446e06297832c506f9fe1.tar.bz2
gentoo-bd98a6f60cbfc54571e446e06297832c506f9fe1.zip
sys-apps/qcontrol: respect LDFLAGS
Closes: https://bugs.gentoo.org/725604 Package-Manager: Portage-3.0.4, Repoman-2.3.23 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-apps/qcontrol')
-rw-r--r--sys-apps/qcontrol/qcontrol-0.4.2-r1.ebuild7
1 files changed, 5 insertions, 2 deletions
diff --git a/sys-apps/qcontrol/qcontrol-0.4.2-r1.ebuild b/sys-apps/qcontrol/qcontrol-0.4.2-r1.ebuild
index 3dfb69bbc9a2..2cf602ce5051 100644
--- a/sys-apps/qcontrol/qcontrol-0.4.2-r1.ebuild
+++ b/sys-apps/qcontrol/qcontrol-0.4.2-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -20,13 +20,16 @@ RDEPEND="${DEPEND}"
src_prepare() {
default
+
eapply "${WORKDIR}"/*.diff
eapply debian/patches/*.patch
eapply "${FILESDIR}"/${PV}-Makefile.patch
+
+ sed -i -e "s/LDFLAGS=/LDFLAGS ?=/" Makefile || die
}
src_compile() {
- emake CC="$(tc-getCC)" qcontrol
+ emake CC="$(tc-getCC)" LDFLAGS="-llua -lpthread ${LDFLAGS}" qcontrol
}
src_install() {