summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Zaman <perfinion@gentoo.org>2016-08-05 02:49:32 +0800
committerJason Zaman <perfinion@gentoo.org>2016-08-08 01:05:24 +0800
commit87252f91de0e61e8c2fe290371a2bff2b272228b (patch)
treeaecc3db99cfc16ef694bf75cc7c4602dae78b053 /sys-apps/policycoreutils
parentsys-apps/checkpolicy: update to eapi6 (diff)
downloadgentoo-87252f91de0e61e8c2fe290371a2bff2b272228b.tar.gz
gentoo-87252f91de0e61e8c2fe290371a2bff2b272228b.tar.bz2
gentoo-87252f91de0e61e8c2fe290371a2bff2b272228b.zip
sys-apps/policycoreutils: update to eapi6
Package-Manager: portage-2.2.28
Diffstat (limited to 'sys-apps/policycoreutils')
-rw-r--r--sys-apps/policycoreutils/policycoreutils-9999.ebuild23
1 files changed, 10 insertions, 13 deletions
diff --git a/sys-apps/policycoreutils/policycoreutils-9999.ebuild b/sys-apps/policycoreutils/policycoreutils-9999.ebuild
index a49b4a1e2171..8df62b452b40 100644
--- a/sys-apps/policycoreutils/policycoreutils-9999.ebuild
+++ b/sys-apps/policycoreutils/policycoreutils-9999.ebuild
@@ -2,11 +2,11 @@
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI="5"
-PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+EAPI="6"
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
PYTHON_REQ_USE="xml"
-inherit multilib python-r1 toolchain-funcs eutils bash-completion-r1
+inherit multilib python-r1 toolchain-funcs bash-completion-r1
MY_P="${P//_/-}"
@@ -78,12 +78,12 @@ src_prepare() {
cd "${S}" || die "Failed to switch to ${S}"
if [[ ${PV} != 9999 ]] ; then
# If needed for live ebuilds please use /etc/portage/patches
- epatch "${FILESDIR}/0010-remove-sesandbox-support.patch"
- epatch "${FILESDIR}/0020-disable-autodetection-of-pam-and-audit.patch"
- epatch "${FILESDIR}/0030-make-inotify-check-use-flag-triggered.patch"
- epatch "${FILESDIR}/0070-remove-symlink-attempt-fails-with-gentoo-sandbox-approach.patch"
- epatch "${FILESDIR}/0110-build-mcstrans-bug-472912.patch"
- epatch "${FILESDIR}/0120-build-failure-for-mcscolor-for-CONTEXT__CONTAINS.patch"
+ eapply "${FILESDIR}/0010-remove-sesandbox-support.patch"
+ eapply "${FILESDIR}/0020-disable-autodetection-of-pam-and-audit.patch"
+ eapply "${FILESDIR}/0030-make-inotify-check-use-flag-triggered.patch"
+ eapply "${FILESDIR}/0070-remove-symlink-attempt-fails-with-gentoo-sandbox-approach.patch"
+ eapply "${FILESDIR}/0110-build-mcstrans-bug-472912.patch"
+ eapply "${FILESDIR}/0120-build-failure-for-mcscolor-for-CONTEXT__CONTAINS.patch"
fi
# rlpkg is more useful than fixfiles
@@ -92,7 +92,7 @@ src_prepare() {
sed -i -e '/fixfiles/d' "${S}/scripts/Makefile" \
|| die "fixfiles sed 2 failed"
- epatch_user
+ eapply_user
sed -i 's/-Werror//g' "${S1}"/*/Makefile || die "Failed to remove Werror"
@@ -175,9 +175,6 @@ src_install() {
}
pkg_postinst() {
- # The selinux_gentoo init script is no longer needed with recent OpenRC
- elog "The selinux_gentoo init script has been removed in this version as it is not required after OpenRC 0.13."
-
for POLICY_TYPE in ${POLICY_TYPES} ; do
# There have been some changes to the policy store, rebuilding now.
# https://marc.info/?l=selinux&m=143757277819717&w=2