summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2016-01-17 14:46:46 +0100
committerMichał Górny <mgorny@gentoo.org>2016-01-17 16:22:51 +0100
commit7e9cbe9a47a7e3d463af992fc3d853b803283879 (patch)
tree4118dc38ef9f126032cbc9874d4e910a85ebcdee /sys-apps/paludis
parentsys-apps/paludis: Remove really old gcc checks in -9999 (diff)
downloadgentoo-7e9cbe9a47a7e3d463af992fc3d853b803283879.tar.gz
gentoo-7e9cbe9a47a7e3d463af992fc3d853b803283879.tar.bz2
gentoo-7e9cbe9a47a7e3d463af992fc3d853b803283879.zip
sys-apps/paludis: Add a safe snapshot
Diffstat (limited to 'sys-apps/paludis')
-rw-r--r--sys-apps/paludis/Manifest1
-rw-r--r--sys-apps/paludis/paludis-2.4.0_p20160112.ebuild154
2 files changed, 155 insertions, 0 deletions
diff --git a/sys-apps/paludis/Manifest b/sys-apps/paludis/Manifest
index cc1091304cef..3c4e861741be 100644
--- a/sys-apps/paludis/Manifest
+++ b/sys-apps/paludis/Manifest
@@ -2,3 +2,4 @@ DIST paludis-1.4.2.tar.bz2 1791385 SHA256 ac342d908572e97968abcdd806ba9f390585a0
DIST paludis-2.0.0.tar.bz2 1787616 SHA256 9e635d86e655658d31adde5813f5fcad2982b5fe8847c3c565eca7d28a1ec639 SHA512 e1df4d0617b4e021d1b63181517c0ecb9ece55669226c6ea0bba318b6899277c09a8d8ccc11ef673a3f27e77302c84702df4ae7568b44a87e0b138e346623728 WHIRLPOOL 90dcd765ebc864d14e569a01071fe3effae3c4424cf7f3004ce1f273c721c512697c6100e3b775d34732640bd770220fe5304f4d2b5e67f2de86c9f04c9ffe97
DIST paludis-2.2.0.tar.bz2 1786405 SHA256 0b0bcb14a6539874d274c72e6a7b9825aa80fa083c2b61e1d5b14daf24829346 SHA512 9b4dd4613ec31683021d6fc5b5eb094024ceada47c41e09d1f0cb86f1de5b621869756401ba14ec0ec5f5dd20a5f8bf5b596c3891724bb9c245400b5fef4961f WHIRLPOOL 9cd602561b38e1bb6fc3d9baa5452c63a394c1e51faf299d8d1e82dad9a53969f14be542dac3f90974fcdf08c16c267cfdf45273c5244f378f9a2b7b6288bd97
DIST paludis-2.4.0.tar.bz2 1787689 SHA256 f47b4bb5503dc127022453b15ca811dec22ee2f04c3c3b76ed1c5a83dbe1af1f SHA512 5fbb15d2285c892fdf19288b8838c51ec2439817a9abc685b8692ff4a3ddf76632d3ab51b2e0298c8eacf00f8b00f4e66b47b34db12844cd4eb77cbfb87ca32e WHIRLPOOL d9dc107886b8bf09bb203704d559dd030190b8390607964578c3f2e10a5c5cd4400146ffed894a968143761fc8149796d37597274b34b8414133b26c7252345b
+DIST paludis-2.4.0_p20160112.tar.xz 1296724 SHA256 2b209337b6a4667ffe8b3db431a88314b3b224cf0f9d57a6d4fdd8c2c00f4b19 SHA512 898853bf75e60dcfcb8aca7e45da3b7eeec2bb119db5b77a12e876282abe936bb3064bf52c27b7a7a949ab0865e7fbbfea78dc66408a09d00a02e1a2069153ae WHIRLPOOL 5167ad0d234f874ef304e0725ea78517c7bcd2e0ef09b5e8ac6b6cf4213fcbccd3b6057caf89274ed67bfd7b35efa0f33fc82d479f5b5f31937a0b7c48c37777
diff --git a/sys-apps/paludis/paludis-2.4.0_p20160112.ebuild b/sys-apps/paludis/paludis-2.4.0_p20160112.ebuild
new file mode 100644
index 000000000000..ef55347c6f8e
--- /dev/null
+++ b/sys-apps/paludis/paludis-2.4.0_p20160112.ebuild
@@ -0,0 +1,154 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+# matching profile defaults for now
+RUBY_VER=2.0
+
+inherit bash-completion-r1 eutils python-single-r1 user
+
+DESCRIPTION="paludis, the other package mangler"
+HOMEPAGE="http://paludis.exherbo.org/"
+SRC_URI="http://dev.gentoo.org/~mgorny/dist/${P}.tar.xz"
+
+IUSE="doc pbins pink python ruby search-index test +xml"
+LICENSE="GPL-2 vim"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+
+COMMON_DEPEND="
+ >=app-admin/eselect-1.2.13
+ >=app-shells/bash-3.2
+ dev-libs/libpcre[cxx]
+ sys-apps/file
+ pbins? ( >=app-arch/libarchive-3.1.2 )
+ python? (
+ ${PYTHON_DEPS}
+ >=dev-libs/boost-1.41.0[python,${PYTHON_USEDEP}] )
+ ruby? ( dev-lang/ruby:${RUBY_VER} )
+ search-index? ( >=dev-db/sqlite-3 )
+ xml? ( >=dev-libs/libxml2-2.6 )"
+
+DEPEND="${COMMON_DEPEND}
+ app-arch/xz-utils
+ >=app-text/asciidoc-8.6.3
+ app-text/htmltidy
+ app-text/xmlto
+ >=sys-devel/gcc-4.7
+ doc? (
+ || (
+ >=app-doc/doxygen-1.5.3
+ <=app-doc/doxygen-1.5.1 )
+ python? (
+ dev-python/sphinx[${PYTHON_USEDEP}] )
+ ruby? ( dev-ruby/syntax[ruby_targets_ruby${RUBY_VER/./}] )
+ )
+ virtual/pkgconfig
+ test? ( >=dev-cpp/gtest-1.6.0-r1 )"
+
+RDEPEND="${COMMON_DEPEND}
+ sys-apps/sandbox"
+
+PDEPEND="app-eselect/eselect-package-manager"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+pkg_pretend() {
+ if [[ ${MERGE_TYPE} != buildonly ]]; then
+ if id paludisbuild >/dev/null 2>/dev/null ; then
+ if ! groups paludisbuild | grep --quiet '\<tty\>' ; then
+ eerror "The 'paludisbuild' user is now expected to be a member of the"
+ eerror "'tty' group. You should add the user to this group before"
+ eerror "upgrading Paludis."
+ die "Please add paludisbuild to tty group"
+ fi
+ fi
+ fi
+
+}
+
+pkg_setup() {
+ enewgroup "paludisbuild"
+ enewuser "paludisbuild" -1 -1 "/var/tmp/paludis" "paludisbuild,tty"
+
+ use python && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ # Fix the script shebang on Ruby scripts.
+ # https://bugs.gentoo.org/show_bug.cgi?id=439372#c2
+ sed -i -e "1s/ruby/&${RUBY_VER/./}/" ruby/demos/*.rb || die
+
+ epatch_user
+}
+
+src_configure() {
+ local myconf=(
+ --htmldir=/usr/share/doc/${PF}/html
+
+ $(use_enable doc doxygen)
+ $(use_enable test gtest)
+ $(use_enable pbins)
+ $(use_enable pink)
+ $(use_enable python)
+ $(use python && use_enable doc python-doc)
+ $(use_enable ruby)
+ $(use ruby && use_enable doc ruby-doc)
+ --with-ruby-version="${RUBY_VER}"
+ $(use_enable search-index)
+ $(use_enable xml)
+
+ --enable-vim
+ --with-config-framework=eselect
+ --with-environments=default,portage
+ --with-vim-install-dir=/usr/share/vim/vimfiles
+ )
+
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+ prune_libtool_files
+
+ dobashcomp bash-completion/cave
+
+ insinto /usr/share/zsh/site-functions
+ doins zsh-completion/_cave
+}
+
+src_test() {
+ # Work around Portage bugs
+ local -x PALUDIS_DO_NOTHING_SANDBOXY="portage sucks"
+ local -x BASH_ENV=/dev/null
+
+ if [[ ${EUID} == 0 ]] ; then
+ # hate
+ local -x PALUDIS_REDUCED_UID=0
+ local -x PALUDIS_REDUCED_GID=0
+ fi
+
+ if ! nonfatal emake -k check ; then
+ eerror "Tests failed. Looking for files for you to add to your bug report..."
+ find "${S}" -type f -name '*.epicfail' -or -name '*.log' | while read a ; do
+ eerror " $a"
+ done
+ die "Make check failed"
+ fi
+}
+
+pkg_postinst() {
+ local pm
+ if [[ -f ${ROOT}/etc/env.d/50package-manager ]] ; then
+ pm=$( source "${ROOT}"/etc/env.d/50package-manager ; echo "${PACKAGE_MANAGER}" )
+ fi
+
+ if [[ ${pm} != paludis ]] ; then
+ elog "If you are using paludis or cave as your primary package manager,"
+ elog "you should consider running:"
+ elog " eselect package-manager set paludis"
+ fi
+}