summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2020-01-21 16:09:06 +0100
committerLars Wendler <polynomial-c@gentoo.org>2020-01-21 16:09:26 +0100
commite57d1cbf7ce66d038de706ac8a64809b485b56b6 (patch)
tree8d25f13e84f8a2698ebcaefc3b3bf35f3c87a47b /sys-apps/less
parentnet-vpn/wireguard-tools: version bump to 1.0.20200121 (diff)
downloadgentoo-e57d1cbf7ce66d038de706ac8a64809b485b56b6.tar.gz
gentoo-e57d1cbf7ce66d038de706ac8a64809b485b56b6.tar.bz2
gentoo-e57d1cbf7ce66d038de706ac8a64809b485b56b6.zip
sys-apps/less: Bump to version 554
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'sys-apps/less')
-rw-r--r--sys-apps/less/Manifest1
-rw-r--r--sys-apps/less/less-554.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/sys-apps/less/Manifest b/sys-apps/less/Manifest
index 0b4db6a37fad..285a80711f1c 100644
--- a/sys-apps/less/Manifest
+++ b/sys-apps/less/Manifest
@@ -2,3 +2,4 @@ DIST less-530.tar.gz 339723 BLAKE2B 9321548b06330c0b1b5b5a36147f5b9348619ff15d90
DIST less-531.tar.gz 340466 BLAKE2B 6ac75b623fce478114d18cff429659499fedf4ef1a7bb067465ace91c28a7968efb224a4994a1e376a8cf40b110492f10ecda634628029107b38187044a0cd1e SHA512 180b665f194d7cc40d4bbb37bd64b10be463c0705e81795bef84b20dbba1c61825bb3e3da8bcd79f9176bb3af7b1f4e4c3dfe0829a5a2195a11f5b42294daca1
DIST less-550.tar.gz 347026 BLAKE2B b033cb09d1bb9624c56db14084c73e5154e36cebd3f757dd2cb1b012b8797e7647d152bb67ce4ea9c2d188b1252fd7ddfd8a113656af5ec9a1e688145d4d9265 SHA512 a3d2769d90589a8e6afbfc9ac10cd1b544e0b0bbe28884e5ad980a71c541a37545c11d3450984b346b516fe082dfc0cf89d246c5a2d6002a7a2b4a4296a15494
DIST less-551.tar.gz 347007 BLAKE2B 033a043340f888616c8342703597b9232ae1c8e62775d3ee0187599c3d9d9824fdbc7543ca90cdc535b2077a8bcbefe322887ad29289620191d8cf6ff86ddd04 SHA512 ef5296b9ebd72f83c05cad8a0f7a5eec2290e9b358ee725e09e8541bd95f94c0e14ea22aa04b287a0654079338eaeae813f2235b8e9f819fbbc9040dd65a9585
+DIST less-554.tar.gz 334708 BLAKE2B 3d7bd6376eb21060f16f52848b3ba96cdec4d5229c390ef24871eac91e4f35634e159e58c8c6db06072b5e943456deff49a25e99264e9283643966daef687bf8 SHA512 c37c645d1fa59d64414ebcded1b7faccd339a4d67654b14ec5862b2fe795dbd052ba9b65aaafd06f83a5c276d11e9cef5be4fb49329d14955bf2533dfcffd540
diff --git a/sys-apps/less/less-554.ebuild b/sys-apps/less/less-554.ebuild
new file mode 100644
index 000000000000..826f236b361b
--- /dev/null
+++ b/sys-apps/less/less-554.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Excellent text file viewer"
+HOMEPAGE="http://www.greenwoodsoftware.com/less/"
+SRC_URI="http://www.greenwoodsoftware.com/less/${P}.tar.gz"
+
+LICENSE="|| ( GPL-3 BSD-2 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="pcre unicode"
+
+DEPEND=">=app-misc/editor-wrapper-3
+ >=sys-libs/ncurses-5.2:0=
+ pcre? ( dev-libs/libpcre2 )"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ export ac_cv_lib_ncursesw_initscr=$(usex unicode)
+ export ac_cv_lib_ncurses_initscr=$(usex !unicode)
+ local myeconfargs=(
+ --with-regex=$(usex pcre pcre2 posix)
+ --with-editor="${EPREFIX}"/usr/libexec/editor
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+
+ newbin "${FILESDIR}"/lesspipe.sh lesspipe
+ newenvd "${FILESDIR}"/less.envd 70less
+}
+
+pkg_preinst() {
+ if has_version "<${CATEGORY}/${PN}-483-r1" ; then
+ elog "The lesspipe.sh symlink has been dropped. If you are still setting"
+ elog "LESSOPEN to that, you will need to update it to '|lesspipe %s'."
+ elog "Colorization support has been dropped. If you want that, check out"
+ elog "the new app-text/lesspipe package."
+ fi
+}