summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-apps/lcdtest
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-apps/lcdtest')
-rw-r--r--sys-apps/lcdtest/Manifest1
-rw-r--r--sys-apps/lcdtest/files/1.18-build-system.patch62
-rw-r--r--sys-apps/lcdtest/lcdtest-1.18.ebuild61
-rw-r--r--sys-apps/lcdtest/metadata.xml14
4 files changed, 138 insertions, 0 deletions
diff --git a/sys-apps/lcdtest/Manifest b/sys-apps/lcdtest/Manifest
new file mode 100644
index 000000000000..1c98bfd6f1a7
--- /dev/null
+++ b/sys-apps/lcdtest/Manifest
@@ -0,0 +1 @@
+DIST lcdtest-1.18.tar.gz 26886 SHA256 f0b3fa9c5a4bc86eb2713f85f422d328a673ca8f541a6403bfe156afd631200e SHA512 74b0739c5dcc5ff9307ca526b4a6bbd92d6e58a83ceeed5a37a4064e3e4ed0cbdfe7a2a70cd56ba1a7305c3fd72510e10a02098aab11828062a3999cac944ab7 WHIRLPOOL 96abd5864323c45aa2ee6927f96c7f9e401a0007dd6361ffbc14d6609ff75cc55ec2ec93782c732aca6aade645dd3ee94ec49996bf88975fa6bd82fe6106e120
diff --git a/sys-apps/lcdtest/files/1.18-build-system.patch b/sys-apps/lcdtest/files/1.18-build-system.patch
new file mode 100644
index 000000000000..429067259c54
--- /dev/null
+++ b/sys-apps/lcdtest/files/1.18-build-system.patch
@@ -0,0 +1,62 @@
+diff -uNr lcdtest-1.18.ORIG/SConstruct lcdtest-1.18/SConstruct
+--- lcdtest-1.18.ORIG/SConstruct 2013-04-17 14:32:37.735358663 +0100
++++ lcdtest-1.18/SConstruct 2013-04-17 14:33:52.706359788 +0100
+@@ -119,10 +119,10 @@
+ # code
+ #-----------------------------------------------------------------------------
+
+-build_dir = 'build/'
++variant_dir = 'build/'
+
+ SConscript ('src/SConscript',
+- build_dir = build_dir,
++ variant_dir = variant_dir,
+ duplicate = 0,
+ exports = {'env' : env})
+
+@@ -137,7 +137,7 @@
+ #-----------------------------------------------------------------------------
+
+ SConscript ('desktop/SConscript',
+- build_dir = build_dir + '/desktop',
++ variant_dir = variant_dir + '/desktop',
+ duplicate = 0)
+
+ #-----------------------------------------------------------------------------
+diff -uNr lcdtest-1.18.ORIG/src/SConscript lcdtest-1.18/src/SConscript
+--- lcdtest-1.18.ORIG/src/SConscript 2013-04-17 14:32:37.734358663 +0100
++++ lcdtest-1.18/src/SConscript 2013-04-17 14:32:54.194358910 +0100
+@@ -17,6 +17,7 @@
+ # along with this program. If not, see see <http://www.gnu.org/licenses/>.
+
+ import os
++import SCons.Util
+
+ Import('env')
+
+@@ -29,13 +30,18 @@
+
+ objs = [env.Object(src) for src in srcs]
+
+-# respect the environment CFLAGS if given
+-if 'CFLAGS' in ARGUMENTS:
+- env.MergeFlags (ARGUMENTS ['CFLAGS'])
+-elif 'CFLAGS' in os.environ:
+- env.MergeFlags (os.environ ['CFLAGS'])
+-else:
+- env.Append (CCFLAGS = ['-g', '-Wall', '-Wextra'])
++# respect the environments flags if given
++
++if os.environ.has_key('CC'):
++ env['CC'] = os.environ['CC']
++if os.environ.has_key('CFLAGS'):
++ env['CCFLAGS'] += SCons.Util.CLVar(os.environ['CFLAGS'])
++if os.environ.has_key('CXX'):
++ env['CXX'] = os.environ['CXX']
++if os.environ.has_key('CXXFLAGS'):
++ env['CXXFLAGS'] += SCons.Util.CLVar(os.environ['CXXFLAGS'])
++if os.environ.has_key('LDFLAGS'):
++ env['LINKFLAGS'] += SCons.Util.CLVar(os.environ['LDFLAGS'])
+
+ env.Append (LIBS = ['SDL', 'SDL_image', 'SDL_ttf']);
+
diff --git a/sys-apps/lcdtest/lcdtest-1.18.ebuild b/sys-apps/lcdtest/lcdtest-1.18.ebuild
new file mode 100644
index 000000000000..fbf054bee2be
--- /dev/null
+++ b/sys-apps/lcdtest/lcdtest-1.18.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit scons-utils eutils toolchain-funcs gnome2-utils
+
+DESCRIPTION="Displays test patterns to spot dead/hot pixels on LCD screens"
+HOMEPAGE="http://www.brouhaha.com/~eric/software/lcdtest/"
+SRC_URI="http://www.brouhaha.com/~eric/software/lcdtest/download/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+ >=media-libs/libsdl-1.2.7-r2[X,video]
+ >=media-libs/sdl-image-1.2.3-r1
+ >=media-libs/sdl-ttf-2.0.9
+"
+RDEPEND="${DEPEND}
+ media-fonts/liberation-fonts
+"
+
+src_prepare() {
+ epatch "${FILESDIR}/${PV}-build-system.patch"
+ epatch_user
+ sed -i -e \
+ "s|/usr/share/fonts/liberation/|/usr/share/fonts/liberation-fonts/|" \
+ src/lcdtest.c || die
+}
+
+src_configure() {
+ tc-export CC
+ myesconsargs=(
+ --prefix="${EPREFIX}/usr"
+ )
+}
+
+src_compile() {
+ escons
+}
+
+src_install() {
+ escons --buildroot="${D}" install
+ dodoc README
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}
diff --git a/sys-apps/lcdtest/metadata.xml b/sys-apps/lcdtest/metadata.xml
new file mode 100644
index 000000000000..63248665e28f
--- /dev/null
+++ b/sys-apps/lcdtest/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>base-system</herd>
+<herd>proxy-maintainers</herd>
+<maintainer>
+ <email>chainsaw@gentoo.org</email>
+ <name>Tony Vroon</name>
+</maintainer>
+<maintainer>
+ <email>nikoli@gmx.us</email>
+ <name>Nikoli</name>
+</maintainer>
+</pkgmetadata>