summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2018-03-31 10:27:58 -0400
committerAnthony G. Basile <blueness@gentoo.org>2018-03-31 10:28:15 -0400
commit9bc74ef2bb91373de0beb13c6e2acad4dab7d993 (patch)
tree04707004ad678b8ee4fa50cb6328fd5dac4ce52c /sys-apps/haveged
parentsys-libs/glibc-2.25-r11: alpha stable (diff)
downloadgentoo-9bc74ef2bb91373de0beb13c6e2acad4dab7d993.tar.gz
gentoo-9bc74ef2bb91373de0beb13c6e2acad4dab7d993.tar.bz2
gentoo-9bc74ef2bb91373de0beb13c6e2acad4dab7d993.zip
sys-apps/haveged: bump 1.9.2 to EAPI=6
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'sys-apps/haveged')
-rw-r--r--sys-apps/haveged/haveged-1.9.2-r1.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/sys-apps/haveged/haveged-1.9.2-r1.ebuild b/sys-apps/haveged/haveged-1.9.2-r1.ebuild
new file mode 100644
index 000000000000..8b3a59788d33
--- /dev/null
+++ b/sys-apps/haveged/haveged-1.9.2-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit systemd
+
+DESCRIPTION="A simple entropy daemon using the HAVEGE algorithm"
+HOMEPAGE="http://www.issihosts.com/haveged/"
+SRC_URI="http://www.issihosts.com/haveged/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~x86"
+IUSE="selinux"
+
+DEPEND=""
+RDEPEND="!<sys-apps/openrc-0.11.8
+ selinux? ( sec-policy/selinux-entropyd )"
+
+# threads are broken right now, but eventually
+# we should add $(use_enable threads)
+src_configure() {
+ econf \
+ --bindir=/usr/sbin \
+ --enable-nistest \
+ --disable-static \
+ --disable-threads
+}
+
+src_install() {
+ default
+
+ # Install gentoo ones instead
+ newinitd "${FILESDIR}"/haveged-init.d.3 haveged
+ newconfd "${FILESDIR}"/haveged-conf.d haveged
+
+ systemd_newunit "${FILESDIR}"/service.gentoo ${PN}.service
+ insinto /etc
+ doins "${FILESDIR}"/haveged.conf
+}