summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Wegener <swegener@gentoo.org>2020-01-15 20:28:54 +0100
committerSven Wegener <swegener@gentoo.org>2020-01-15 20:51:04 +0100
commit68c0777bf9cab5614994e0e2663985ca90a46e74 (patch)
treefc0d9a0e5c7671c545f52f1c1dd8359b96daaba5 /sys-apps/flashrom
parentsys-apps/flashrom: Ignore ni845x-spi (windows-only) (diff)
downloadgentoo-68c0777bf9cab5614994e0e2663985ca90a46e74.tar.gz
gentoo-68c0777bf9cab5614994e0e2663985ca90a46e74.tar.bz2
gentoo-68c0777bf9cab5614994e0e2663985ca90a46e74.zip
sys-apps/flashrom: Force C locale for sorting, bug #624474
Closes: https://bugs.gentoo.org/624474 Package-Manager: Portage-2.3.79, Repoman-2.3.16 Signed-off-by: Sven Wegener <swegener@gentoo.org>
Diffstat (limited to 'sys-apps/flashrom')
-rw-r--r--sys-apps/flashrom/flashrom-0.9.8.ebuild4
-rw-r--r--sys-apps/flashrom/flashrom-1.0.ebuild4
-rw-r--r--sys-apps/flashrom/flashrom-1.1.ebuild4
-rw-r--r--sys-apps/flashrom/flashrom-9999.ebuild2
4 files changed, 7 insertions, 7 deletions
diff --git a/sys-apps/flashrom/flashrom-0.9.8.ebuild b/sys-apps/flashrom/flashrom-0.9.8.ebuild
index 91f745052628..11d55eafa946 100644
--- a/sys-apps/flashrom/flashrom-0.9.8.ebuild
+++ b/sys-apps/flashrom/flashrom-0.9.8.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -99,7 +99,7 @@ src_compile() {
# Help keep things in sync.
local sprogs=$(echo $(
grep -o 'CONFIG_[A-Z0-9_]*' flashrom.c | \
- sort -u | \
+ LC_ALL=C sort -u | \
sed 's:^CONFIG_::' | \
tr '[:upper:]_' '[:lower:]-'))
local eprogs=$(echo ${IUSE_PROGRAMMERS} | sed -E 's/\B[-+]\b//g')
diff --git a/sys-apps/flashrom/flashrom-1.0.ebuild b/sys-apps/flashrom/flashrom-1.0.ebuild
index cd57ee3d0f68..766fefcc7255 100644
--- a/sys-apps/flashrom/flashrom-1.0.ebuild
+++ b/sys-apps/flashrom/flashrom-1.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -95,7 +95,7 @@ src_compile() {
# Help keep things in sync.
local sprogs=$(echo $(
grep -o 'CONFIG_[A-Z0-9_]*' flashrom.c | \
- sort -u | \
+ LC_ALL=C sort -u | \
sed 's:^CONFIG_::' | \
tr '[:upper:]_' '[:lower:]-'))
local eprogs=$(echo ${IUSE_PROGRAMMERS} | sed -E 's/\B[-+]\b//g')
diff --git a/sys-apps/flashrom/flashrom-1.1.ebuild b/sys-apps/flashrom/flashrom-1.1.ebuild
index 873ed5612b84..210c82d3c759 100644
--- a/sys-apps/flashrom/flashrom-1.1.ebuild
+++ b/sys-apps/flashrom/flashrom-1.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -105,7 +105,7 @@ src_compile() {
# Help keep things in sync.
local sprogs=$(echo $(
grep -o 'CONFIG_[A-Z0-9_]*' flashrom.c | \
- sort -u | \
+ LC_ALL=C sort -u | \
sed 's:^CONFIG_::' | \
tr '[:upper:]_' '[:lower:]-'))
local eprogs=$(echo ${IUSE_PROGRAMMERS} | sed -E 's/\B[-+]\b//g')
diff --git a/sys-apps/flashrom/flashrom-9999.ebuild b/sys-apps/flashrom/flashrom-9999.ebuild
index 1edc15288959..44446c7c4e17 100644
--- a/sys-apps/flashrom/flashrom-9999.ebuild
+++ b/sys-apps/flashrom/flashrom-9999.ebuild
@@ -107,7 +107,7 @@ src_compile() {
# Help keep things in sync.
local sprogs=$(echo $(
grep -o 'CONFIG_[A-Z0-9_]*' flashrom.c | \
- sort -u | \
+ LC_ALL=C sort -u | \
sed 's:^CONFIG_::' | \
tr '[:upper:]_' '[:lower:]-' | \
grep -v ni845x-spi))