summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-apps/entropy
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-apps/entropy')
-rw-r--r--sys-apps/entropy/Manifest1
-rw-r--r--sys-apps/entropy/entropy-254.ebuild112
-rw-r--r--sys-apps/entropy/metadata.xml11
3 files changed, 124 insertions, 0 deletions
diff --git a/sys-apps/entropy/Manifest b/sys-apps/entropy/Manifest
new file mode 100644
index 000000000000..520d012e476c
--- /dev/null
+++ b/sys-apps/entropy/Manifest
@@ -0,0 +1 @@
+DIST entropy-254.tar.bz2 18516662 SHA256 5e411472eaf7016a68a4aa81ef92dd3aad8403fc65a0ffb09c57b91c959ca3a6 SHA512 3b3e82abad8008720e370b7892b7be1c48aaa6605914db977f68b9a108ada0a4adbaa5b7b50a9a02ba9c8b0bdefadcda1eceee2c7c2abc385b3daf669649e2da WHIRLPOOL 593469b858707e4ceca56146fa1d608141e44dda0a0921ed6a3ec566878c1e3c153410233f088d57db4f8bd9d1c796bd945cbea3ba455572efc05eca42023ce5
diff --git a/sys-apps/entropy/entropy-254.ebuild b/sys-apps/entropy/entropy-254.ebuild
new file mode 100644
index 000000000000..4fe9e8d7b03a
--- /dev/null
+++ b/sys-apps/entropy/entropy-254.ebuild
@@ -0,0 +1,112 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="sqlite"
+
+inherit eutils python-single-r1 user
+
+DESCRIPTION="Entropy Package Manager foundation library"
+HOMEPAGE="http://www.sabayon.org"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ia64 ~ppc ~ppc64 ~x86"
+
+IUSE=""
+SRC_URI="mirror://sabayon/${CATEGORY}/${P}.tar.bz2"
+
+RDEPEND=">=app-misc/pax-utils-0.7
+ dev-db/sqlite:3[soundex(+)]
+ net-misc/rsync
+ sys-apps/diffutils
+ sys-apps/sandbox
+ >=sys-apps/portage-2.1.9[${PYTHON_USEDEP}]
+ sys-devel/gettext
+ ${PYTHON_DEPS}"
+DEPEND="${RDEPEND}
+ dev-util/intltool"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+S="${S}/lib"
+
+REPO_CONFPATH="${ROOT}/etc/entropy/repositories.conf"
+REPO_D_CONFPATH="${ROOT}/etc/entropy/repositories.conf.d"
+ENTROPY_CACHEDIR="${ROOT}/var/lib/entropy/caches"
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+ # Can:
+ # - update repos
+ # - update security advisories
+ # - handle on-disk cache (atm)
+ enewgroup entropy || die "failed to create entropy group"
+ # Create unprivileged entropy user
+ enewgroup entropy-nopriv || die "failed to create entropy-nopriv group"
+ enewuser entropy-nopriv -1 -1 -1 entropy-nopriv || die "failed to create entropy-nopriv user"
+}
+
+src_install() {
+ emake DESTDIR="${D}" LIBDIR="usr/lib" install || die "make install failed"
+
+ python_optimize "${D}/usr/lib/entropy/lib/entropy"
+}
+
+pkg_postinst() {
+ for ex_conf in "${REPO_D_CONFPATH}"/_entropy_sabayon-limbo.example; do
+ real_conf="${ex_conf%.example}"
+ if [ -f "${real_conf}" ] || [ -f "${real_conf/_}" ]; then
+ # skip installation then
+ continue
+ fi
+ elog "Installing: ${real_conf}"
+ cp "${ex_conf}" "${real_conf}" -p
+ done
+
+ # Copy config file over
+ if [ -f "${REPO_CONFPATH}.example" ] && [ ! -f "${REPO_CONFPATH}" ]; then
+ elog "Copying ${REPO_CONFPATH}.example over to ${REPO_CONFPATH}"
+ cp "${REPO_CONFPATH}.example" "${REPO_CONFPATH}" -p
+ fi
+
+ if [ -d "${ENTROPY_CACHEDIR}" ]; then
+ einfo "Purging current Entropy cache"
+ rm -rf "${ENTROPY_CACHEDIR}"/*
+ fi
+
+ # Fixup Entropy Resources Lock, and /etc/entropy/packages
+ # files permissions. This fixes unprivileged Entropy Library usage
+ local res_file="${ROOT}"/var/lib/entropy/client/database/*/.using_resources
+ if [ -f "${res_file}" ]; then
+ chown root:entropy "${res_file}"
+ chmod g+rw "${res_file}"
+ chmod o+r "${res_file}"
+ fi
+ local pkg_files="package.mask package.unmask package.mask.d package.unmask.d"
+ local pkg_file
+ for pkg_file in ${pkg_files}; do
+ pkg_file="${ROOT}/etc/entropy/packages/${pkg_file}"
+ recursive=""
+ if [ -d "${pkg_file}" ]; then
+ recursive="-R"
+ fi
+ if [ -e "${pkg_file}" ]; then
+ chown ${recursive} root:entropy "${pkg_file}"
+ chmod ${recursive} go+r "${pkg_file}"
+ fi
+ done
+
+ # Setup Entropy Library directories ownership
+ chown root:entropy "${ROOT}/var/lib/entropy" # no recursion
+ chown root:entropy "${ROOT}/var/lib/entropy/client/packages" # no recursion
+ chown root:entropy "${ROOT}/var/log/entropy" # no recursion
+
+ echo
+ elog "If you want to enable Entropy packages delta download support, please"
+ elog "install dev-util/bsdiff."
+ echo
+}
diff --git a/sys-apps/entropy/metadata.xml b/sys-apps/entropy/metadata.xml
new file mode 100644
index 000000000000..187f7a710efe
--- /dev/null
+++ b/sys-apps/entropy/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>lxnay@gentoo.org</email>
+ <name>Fabio Erculiani</name>
+ </maintainer>
+ <use>
+ </use>
+</pkgmetadata>
+