summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-apps/dmidecode
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-apps/dmidecode')
-rw-r--r--sys-apps/dmidecode/Manifest1
-rw-r--r--sys-apps/dmidecode/dmidecode-2.12-r1.ebuild44
-rw-r--r--sys-apps/dmidecode/files/2.12-supported-smbios-version.patch55
-rw-r--r--sys-apps/dmidecode/metadata.xml5
4 files changed, 105 insertions, 0 deletions
diff --git a/sys-apps/dmidecode/Manifest b/sys-apps/dmidecode/Manifest
new file mode 100644
index 000000000000..8e527c5702dd
--- /dev/null
+++ b/sys-apps/dmidecode/Manifest
@@ -0,0 +1 @@
+DIST dmidecode-2.12.tar.bz2 55191 SHA256 913ff3055d563a62a420789b8ee33b038de9afa18ea61254760ddf8ab87a5088 SHA512 15d5a6dca04de48267f969f6866079915964a8a3abad083b1720a4425723f9c100770d05c0d475df9609c5b54741f231a587761d1beb1ae6de4b2836d60724c4 WHIRLPOOL 139841a9efd07ecfcb012a24e2c3ea00c79d66828a5d5aa1eeb8b230c1b84f310e5f9282403af9f530f7ead41922f7a3e8a6e8b93e46d7403d69975b95d6a406
diff --git a/sys-apps/dmidecode/dmidecode-2.12-r1.ebuild b/sys-apps/dmidecode/dmidecode-2.12-r1.ebuild
new file mode 100644
index 000000000000..fffd494439e1
--- /dev/null
+++ b/sys-apps/dmidecode/dmidecode-2.12-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit flag-o-matic toolchain-funcs eutils
+
+DESCRIPTION="DMI (Desktop Management Interface) table related utilities"
+HOMEPAGE="http://www.nongnu.org/dmidecode/"
+SRC_URI="http://savannah.nongnu.org/download/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* amd64 arm ia64 ppc ppc64 sparc x86 ~amd64-fbsd ~x86-fbsd ~x86-solaris"
+IUSE="selinux"
+
+RDEPEND="selinux? ( sec-policy/selinux-dmidecode )"
+DEPEND=""
+
+src_prepare() {
+ epatch "${FILESDIR}/${PV}-supported-smbios-version.patch"
+ sed -i \
+ -e "/^prefix/s:/usr/local:${EPREFIX}/usr:" \
+ -e "/^docdir/s:dmidecode:${PF}:" \
+ -e '/^PROGRAMS !=/d' \
+ Makefile || die
+}
+
+src_compile() {
+ emake \
+ CFLAGS="${CFLAGS} ${CPPFLAGS}" \
+ LDFLAGS="${LDFLAGS}" \
+ CC="$(tc-getCC)"
+}
+
+pkg_postinst() {
+ if [[ ${CHOST} == *-solaris* ]] ; then
+ einfo "dmidecode needs root privileges to read /dev/xsvc"
+ einfo "To make dmidecode useful, either run as root, or chown and setuid the binary."
+ einfo "Note that /usr/sbin/ptrconf and /usr/sbin/ptrdiag give similar"
+ einfo "information without requiring root privileges."
+ fi
+}
diff --git a/sys-apps/dmidecode/files/2.12-supported-smbios-version.patch b/sys-apps/dmidecode/files/2.12-supported-smbios-version.patch
new file mode 100644
index 000000000000..84feaca79ef9
--- /dev/null
+++ b/sys-apps/dmidecode/files/2.12-supported-smbios-version.patch
@@ -0,0 +1,55 @@
+diff -uNr dmidecode-2.12.ORIG/dmidecode.c dmidecode-2.12/dmidecode.c
+--- dmidecode-2.12.ORIG/dmidecode.c 2014-05-06 14:24:27.703057950 +0100
++++ dmidecode-2.12/dmidecode.c 2014-05-06 14:24:43.136058719 +0100
+@@ -69,7 +69,7 @@
+ #define out_of_spec "<OUT OF SPEC>"
+ static const char *bad_index = "<BAD INDEX>";
+
+-#define SUPPORTED_SMBIOS_VER 0x0207
++#define SUPPORTED_SMBIOS_VER 0x0208
+
+ /*
+ * Type-independant Stuff
+@@ -712,7 +712,6 @@
+ { 0x3D, "Opteron 6200" },
+ { 0x3E, "Opteron 4200" },
+ { 0x3F, "FX" },
+-
+ { 0x40, "MIPS" },
+ { 0x41, "MIPS R4000" },
+ { 0x42, "MIPS R4200" },
+@@ -729,7 +728,6 @@
+ { 0x4D, "Opteron 6300" },
+ { 0x4E, "Opteron 3300" },
+ { 0x4F, "FirePro" },
+-
+ { 0x50, "SPARC" },
+ { 0x51, "SuperSPARC" },
+ { 0x52, "MicroSPARC II" },
+@@ -1176,7 +1174,7 @@
+ "Socket LGA1356-3" /* 0x2C */
+ };
+
+- if (code >= 0x01 && code <= 0x2A)
++ if (code >= 0x01 && code <= 0x2C)
+ return upgrade[code - 0x01];
+ return out_of_spec;
+ }
+@@ -2236,7 +2234,7 @@
+ if (code == 0)
+ printf(" Unknown");
+ else
+- printf(" %.3f V", (float)(i16)code / 1000);
++ printf(" %.3f V", (float)code / 1000);
+ }
+
+ static const char *dmi_memory_device_form_factor(u8 code)
+@@ -2338,7 +2336,7 @@
+ {
+ int i;
+
+- for (i = 1; i <= 14; i++)
++ for (i = 1; i <= 15; i++)
+ if (code & (1 << i))
+ printf(" %s", detail[i - 1]);
+ }
diff --git a/sys-apps/dmidecode/metadata.xml b/sys-apps/dmidecode/metadata.xml
new file mode 100644
index 000000000000..96a2d586367d
--- /dev/null
+++ b/sys-apps/dmidecode/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>base-system</herd>
+</pkgmetadata>