summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-03-15 05:11:03 +0000
committerSam James <sam@gentoo.org>2023-03-15 05:44:58 +0000
commit240c51a78863d454e416c3bdb96acde20e91ca56 (patch)
tree980cc8441f77fc3d040b960533c4f01c2aefa4a6 /sys-apps/dmidecode
parentwww-apps/wordpress: drop 6.2_rc1 (diff)
downloadgentoo-240c51a78863d454e416c3bdb96acde20e91ca56.tar.gz
gentoo-240c51a78863d454e416c3bdb96acde20e91ca56.tar.bz2
gentoo-240c51a78863d454e416c3bdb96acde20e91ca56.zip
sys-apps/dmidecode: add 3.5
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-apps/dmidecode')
-rw-r--r--sys-apps/dmidecode/Manifest1
-rw-r--r--sys-apps/dmidecode/dmidecode-3.5.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/sys-apps/dmidecode/Manifest b/sys-apps/dmidecode/Manifest
index c411b41d00d9..7a7bd062f49f 100644
--- a/sys-apps/dmidecode/Manifest
+++ b/sys-apps/dmidecode/Manifest
@@ -1 +1,2 @@
DIST dmidecode-3.4.tar.xz 61420 BLAKE2B f9f0429c5128692c2d1d560580552285ea900c1c9ef6f68f0e2133ae1ef05b85a943e882f915d3ef969b7a7e3f3f6bbc4ec391e7bd3d98092976ddbf02421c49 SHA512 62990b6159e5a7c8688d37e44957e7948391d2c6afeabaa4514ba9dad2d08b020297676e2dbbfcb6471efc6fb6f3682750422931a953f78f358bb3dd3745e95b
+DIST dmidecode-3.5.tar.xz 65068 BLAKE2B 07cc4c069dc1cba36160de158c4d0390df9b77b4192f5847df0756f9e097a7fbc751cd7b5b073df7661267ab78ea0d9be2831d70ddda8d1981c628f3cfee8802 SHA512 690c9bea391f6bbfc8cd48e8db408a61d5b551a07a2823c29d03a09607fc2043cc1bea44ee9fd27fd0e7bc0b287bf9de9f22a1a66053f5b1e63d77c03d93e1ae
diff --git a/sys-apps/dmidecode/dmidecode-3.5.ebuild b/sys-apps/dmidecode/dmidecode-3.5.ebuild
new file mode 100644
index 000000000000..fd9962c60623
--- /dev/null
+++ b/sys-apps/dmidecode/dmidecode-3.5.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# Upstream often give "recommended patches" at https://www.nongnu.org/dmidecode/
+# Check regularly after releases!
+inherit toolchain-funcs
+
+DESCRIPTION="DMI (Desktop Management Interface) table related utilities"
+HOMEPAGE="https://www.nongnu.org/dmidecode/"
+SRC_URI="https://savannah.nongnu.org/download/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* ~alpha ~amd64 ~arm ~arm64 ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~x86 ~x86-solaris"
+IUSE="selinux"
+
+RDEPEND="selinux? ( sec-policy/selinux-dmidecode )"
+
+src_prepare() {
+ default
+
+ sed -i \
+ -e "/^prefix/s:/usr/local:${EPREFIX}/usr:" \
+ -e "/^docdir/s:dmidecode:${PF}:" \
+ -e '/^PROGRAMS !=/d' \
+ Makefile || die
+}
+
+src_compile() {
+ emake \
+ CFLAGS="${CFLAGS} ${CPPFLAGS}" \
+ LDFLAGS="${LDFLAGS}" \
+ CC="$(tc-getCC)"
+}
+
+pkg_postinst() {
+ if [[ ${CHOST} == *-solaris* ]] ; then
+ einfo "dmidecode needs root privileges to read /dev/xsvc"
+ einfo "To make dmidecode useful, either run as root, or chown and setuid the binary."
+ einfo "Note that /usr/sbin/ptrconf and /usr/sbin/ptrdiag give similar"
+ einfo "information without requiring root privileges."
+ fi
+}