summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Zaman <perfinion@gentoo.org>2020-10-12 20:22:51 -0700
committerJason Zaman <perfinion@gentoo.org>2020-10-12 20:22:51 -0700
commit198726fcc4ff4420bbd8c32bb3e4754b1741ac0d (patch)
tree13f2dcafe4332840c845d0a394fd4c49d0f29f3a /sec-policy/apparmor-profiles
parentdev-libs/libgit2: Bump to 1.1.0 (diff)
downloadgentoo-198726fcc4ff4420bbd8c32bb3e4754b1741ac0d.tar.gz
gentoo-198726fcc4ff4420bbd8c32bb3e4754b1741ac0d.tar.bz2
gentoo-198726fcc4ff4420bbd8c32bb3e4754b1741ac0d.zip
sec-policy: Release of SELinux policies 2.20200818-r1
Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Jason Zaman <perfinion@gentoo.org>
Diffstat (limited to 'sec-policy/apparmor-profiles')
-rw-r--r--sec-policy/apparmor-profiles/apparmor-profiles-2.20200818-r1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/sec-policy/apparmor-profiles/apparmor-profiles-2.20200818-r1.ebuild b/sec-policy/apparmor-profiles/apparmor-profiles-2.20200818-r1.ebuild
new file mode 100644
index 000000000000..e4e81d4bcbd3
--- /dev/null
+++ b/sec-policy/apparmor-profiles/apparmor-profiles-2.20200818-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit git-r3
+
+DESCRIPTION="A collection of profiles for the AppArmor application security system"
+HOMEPAGE="https://gitlab.com/apparmor/apparmor/wikis/home"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS=""
+IUSE="minimal vanilla"
+
+RESTRICT="test"
+
+S=${WORKDIR}/${P}/profiles
+
+pkg_setup() {
+ if use vanilla; then
+ EGIT_REPO_URI="https://gitlab.com/apparmor/apparmor.git"
+ EGIT_BRANCH="master"
+ else
+ EGIT_REPO_URI="https://github.com/kensington/apparmor.git"
+ EGIT_BRANCH="gentoo"
+ fi
+}
+
+src_install() {
+ if use minimal ; then
+ insinto /etc/apparmor.d
+ doins -r apparmor.d/{abstractions,tunables}
+ else
+ default
+ fi
+}