summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2023-05-05 23:12:13 +0200
committerAndreas K. Hüttel <dilfridge@gentoo.org>2023-05-05 23:12:13 +0200
commit8dd8ded8b0a3f091e712ebb148b5c452853afaff (patch)
tree546ecd9b43cb496e7c0dfc3d1a0ca42d9e6b9bd1 /sci-visualization
parentsci-visualization/gr: drop 0.53.0-r2 (diff)
downloadgentoo-8dd8ded8b0a3f091e712ebb148b5c452853afaff.tar.gz
gentoo-8dd8ded8b0a3f091e712ebb148b5c452853afaff.tar.bz2
gentoo-8dd8ded8b0a3f091e712ebb148b5c452853afaff.zip
sci-visualization/gwyddion: properly enable openexr support
Closes: https://bugs.gentoo.org/878253 Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
Diffstat (limited to 'sci-visualization')
-rw-r--r--sci-visualization/gwyddion/files/gwyddion-2.62-automagic.patch35
-rw-r--r--sci-visualization/gwyddion/gwyddion-2.62-r1.ebuild89
2 files changed, 124 insertions, 0 deletions
diff --git a/sci-visualization/gwyddion/files/gwyddion-2.62-automagic.patch b/sci-visualization/gwyddion/files/gwyddion-2.62-automagic.patch
new file mode 100644
index 000000000000..67259e8e77c5
--- /dev/null
+++ b/sci-visualization/gwyddion/files/gwyddion-2.62-automagic.patch
@@ -0,0 +1,35 @@
+diff --git a/configure.ac b/configure.ac
+index 5a7465a..cc5a54d 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -660,11 +660,13 @@ AM_CONDITIONAL([HAVE_CXX],[test "x$have_cxx" != xno])
+ #############################################################################
+ # OpenEXR 2.x+
+ # Optional. Used for HDR greyscale OpenEXR pixmap import/export.
+-enable_exr=$have_cxx
+-PKG_CHECK_MODULES(EXR, [OpenEXR >= 2.0],
++GWY_WITH([exr],,[build with OpenEXR support])
++if test "x$enable_exr" != "xno"; then
++ PKG_CHECK_MODULES(EXR, [OpenEXR],
+ [AC_DEFINE(HAVE_EXR,1,
+ [Define if we have the OpenEXR 2.x+ package.])],
+ [enable_exr=no])
++fi
+ AM_CONDITIONAL([HAVE_EXR],[test "x$enable_exr" != xno])
+
+ #############################################################################
+@@ -679,10 +681,13 @@ AM_CONDITIONAL([HAVE_HDF5],[test "x$enable_hdf5" != xno])
+ #############################################################################
+ # CFITSIO
+ # Optional. Used for FITS image import.
+-PKG_CHECK_MODULES(CFITSIO, [cfitsio],
++GWY_WITH([cfitsio],,[build with cfitsio support])
++if test "x$enable_cfitsio" != "xno"; then
++ PKG_CHECK_MODULES(CFITSIO, [cfitsio],
+ [AC_DEFINE(HAVE_CFITSIO,1,
+ [Define if we have the cfitsio package.])],
+ [enable_cfitsio=no])
++fi
+ AM_CONDITIONAL([HAVE_CFITSIO],[test "x$enable_cfitsio" != xno])
+
+ #############################################################################
diff --git a/sci-visualization/gwyddion/gwyddion-2.62-r1.ebuild b/sci-visualization/gwyddion/gwyddion-2.62-r1.ebuild
new file mode 100644
index 000000000000..f3fb8344665c
--- /dev/null
+++ b/sci-visualization/gwyddion/gwyddion-2.62-r1.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools xdg
+
+DESCRIPTION="Framework for Scanning Mode Microscopy data analysis"
+HOMEPAGE="http://gwyddion.net/"
+SRC_URI="http://gwyddion.net/download/${PV}/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="bzip2 doc fits jansson hdf5 nls openexr openmp perl ruby sourceview unique xml X zlib"
+
+RDEPEND="
+ >=dev-libs/glib-2.32
+ dev-libs/libzip
+ media-libs/libpng:0=
+ >=sci-libs/fftw-3.1:3.0=[openmp?]
+ virtual/libiconv
+ virtual/libintl
+ x11-libs/cairo
+ >=x11-libs/gtk+-2.18:2
+ x11-libs/libXmu
+ x11-libs/pango
+ bzip2? ( app-arch/bzip2 )
+ fits? ( sci-libs/cfitsio[bzip2?] )
+ jansson? ( dev-libs/jansson )
+ hdf5? ( sci-libs/hdf5[hl,zlib?] )
+ openexr? ( media-libs/openexr:= )
+ perl? ( dev-lang/perl:= )
+ ruby? ( dev-ruby/narray )
+ unique? ( dev-libs/libunique:3 )
+ sourceview? ( x11-libs/gtksourceview:2.0 )
+ xml? ( dev-libs/libxml2:2 )
+ zlib? ( sys-libs/zlib )
+"
+
+DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+ doc? ( dev-util/gtk-doc )
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-2.62-automagic.patch"
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+# There are python bindings (--enable-pygwy) but they are py2 only
+# 3D opengl rendering requires deprecated GTK-2 x11-libs/gtkglext
+src_configure() {
+ # hack for bug 741840
+ use doc && export GTK_DOC_PATH=/usr/share/gtk-doc
+
+ econf \
+ --disable-rpath \
+ --without-kde4-thumbnailer \
+ $(use_enable doc gtk-doc) \
+ $(use_enable openmp) \
+ $(use_enable nls) \
+ --disable-pygwy \
+ --without-python \
+ $(use_with bzip2) \
+ $(use_with fits cfitsio) \
+ $(use_with hdf5) \
+ $(use_with jansson) \
+ $(use_with perl) \
+ $(use_with ruby) \
+ $(use_with openexr exr) \
+ --without-gl \
+ $(use_with sourceview gtksourceview) \
+ $(use_with unique) \
+ $(use_with xml libxml2) \
+ $(use_with X x) \
+ $(use_with zlib) \
+ --with-zip=libzip
+}
+
+src_install() {
+ default
+ find "${ED}" -type f -name "*.la" -delete || die
+}