summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2016-09-17 19:43:29 +0200
committerDavid Seifert <soap@gentoo.org>2016-09-17 19:43:59 +0200
commitcce130dabaa4e0c7acef43994faa909010b0f6c2 (patch)
tree09e39f083ce48931c2c12c433f8f1235b1115865 /sci-visualization/opendx
parentsci-chemistry/gelemental: Allow for compiling with GCC 6 (diff)
downloadgentoo-cce130dabaa4e0c7acef43994faa909010b0f6c2.tar.gz
gentoo-cce130dabaa4e0c7acef43994faa909010b0f6c2.tar.bz2
gentoo-cce130dabaa4e0c7acef43994faa909010b0f6c2.zip
sci-visualization/opendx: Allow for compiling with GCC 6
Gentoo-bug: 593932 * EAPI=6 Package-Manager: portage-2.3.0
Diffstat (limited to 'sci-visualization/opendx')
-rw-r--r--sci-visualization/opendx/Manifest1
-rw-r--r--sci-visualization/opendx/files/opendx-4.4.4-szip.patch4
-rw-r--r--sci-visualization/opendx/files/opendx-4.4.4-xdg.patch4
-rw-r--r--sci-visualization/opendx/opendx-4.4.4-r5.ebuild33
4 files changed, 24 insertions, 18 deletions
diff --git a/sci-visualization/opendx/Manifest b/sci-visualization/opendx/Manifest
index 5b25fc6a7a23..c94373456b48 100644
--- a/sci-visualization/opendx/Manifest
+++ b/sci-visualization/opendx/Manifest
@@ -1 +1,2 @@
DIST dx-4.4.4.tar.gz 9676049 SHA256 a9915e17d49c5499edd3df69ffeac0b7ba24f8b38ddf7509712b48eb3c21f1ff SHA512 e6ef0075a696c442fd4615eb32b9ebd3f85728321a33297e3402b19bbc6210953a6599d643fc0a20bc349fbc72411326c69187223ee0e65560603d8e6f7527ee WHIRLPOOL 6d6931fabfb054ff06464649b2b2ce5f094aa6d0c28f0f2e6ee22176ef4749d78f102ed9d0c27cf3c84ea10038d4502d908ec7a95a597d32f21574b277a54fa0
+DIST opendx-4.4.4_p20160917-fix-c++14.patch.bz2 3162 SHA256 306a3dcedee38dc61f27ce184a88018b78d541d168eb1b85f04a5964b527e02a SHA512 0d671e5a085b446969fbe57eb9d08e4dd103bc29058ce8c6167c3cad18f14b816a3f2cae329b194ef9827ff6590d31da95fc04176e0824f95bdf89761007bc6f WHIRLPOOL b8eecf3955acaa58c94d63a8781691bc4eb2ea62a82077052a1cf221e811cae586a691aff311e08633c70d80d9f15a3d162ad4bd4c4f5b8362fcbfc582a1bf9f
diff --git a/sci-visualization/opendx/files/opendx-4.4.4-szip.patch b/sci-visualization/opendx/files/opendx-4.4.4-szip.patch
index 5e63d4e6b210..488379b4f1b6 100644
--- a/sci-visualization/opendx/files/opendx-4.4.4-szip.patch
+++ b/sci-visualization/opendx/files/opendx-4.4.4-szip.patch
@@ -1,5 +1,5 @@
---- configure.ac.orig 2009-06-14 22:10:24.000000000 +1200
-+++ configure.ac 2009-06-14 22:26:29.000000000 +1200
+--- a/configure.ac
++++ b/configure.ac
@@ -148,6 +148,12 @@ AC_ARG_WITH(netcdf,
[with_netcdf=$withval],
[with_netcdf='yes'])
diff --git a/sci-visualization/opendx/files/opendx-4.4.4-xdg.patch b/sci-visualization/opendx/files/opendx-4.4.4-xdg.patch
index c5b38f274bcd..018dcd644b87 100644
--- a/sci-visualization/opendx/files/opendx-4.4.4-xdg.patch
+++ b/sci-visualization/opendx/files/opendx-4.4.4-xdg.patch
@@ -1,6 +1,6 @@
diff -up bin/url_handler.sh.orig bin/url_handler.sh
---- bin/url_handler.sh.orig 2009-05-02 23:21:08.000000000 +1200
-+++ bin/url_handler.sh 2009-05-02 23:24:25.000000000 +1200
+--- a/bin/url_handler.sh
++++ b/bin/url_handler.sh
@@ -27,21 +27,7 @@ case $method in
mailto) mutt `echo "$url" | sed 's;^[^:]*:\(.*\);\1;'`
;;
diff --git a/sci-visualization/opendx/opendx-4.4.4-r5.ebuild b/sci-visualization/opendx/opendx-4.4.4-r5.ebuild
index 2261c3026ca7..5c02453d732d 100644
--- a/sci-visualization/opendx/opendx-4.4.4-r5.ebuild
+++ b/sci-visualization/opendx/opendx-4.4.4-r5.ebuild
@@ -2,14 +2,16 @@
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=5
+EAPI=6
MYP=dx-${PV}
-inherit eutils flag-o-matic autotools multilib
+
+inherit autotools eutils flag-o-matic
DESCRIPTION="3D data visualization tool"
HOMEPAGE="http://www.opendx.org/"
-SRC_URI="http://opendx.sdsc.edu/source/${MYP}.tar.gz"
+SRC_URI="http://opendx.sdsc.edu/source/${MYP}.tar.gz
+ https://dev.gentoo.org/~soap/distfiles/${PN}-4.4.4_p20160917-fix-c++14.patch.bz2"
LICENSE="IBM"
SLOT="0"
@@ -34,18 +36,22 @@ DEPEND="${RDEPEND}
virtual/pkgconfig"
S="${WORKDIR}/${MYP}"
+PATCHES=(
+ "${FILESDIR}/${PN}-4.3.2-sys.h.patch"
+ "${FILESDIR}/${P}-installpaths.patch"
+ "${FILESDIR}/${P}-xdg.patch"
+ "${FILESDIR}/${P}-gcc43.patch"
+ "${FILESDIR}/${P}-dx-errno.patch"
+ "${FILESDIR}/${P}-libtool.patch"
+ "${FILESDIR}/${P}-concurrent-make-fix.patch"
+ "${FILESDIR}/${P}-open.patch"
+ "${FILESDIR}/${P}-szip.patch"
+ "${FILESDIR}/${P}-null.patch"
+ "${WORKDIR}/${PN}-4.4.4_p20160917-fix-c++14.patch"
+)
src_prepare() {
- epatch "${FILESDIR}/${PN}-4.3.2-sys.h.patch"
- epatch "${FILESDIR}/${P}-installpaths.patch"
- epatch "${FILESDIR}/${P}-xdg.patch"
- epatch "${FILESDIR}/${P}-gcc43.patch"
- epatch "${FILESDIR}/${P}-dx-errno.patch"
- epatch "${FILESDIR}/${P}-libtool.patch"
- epatch "${FILESDIR}/${P}-concurrent-make-fix.patch"
- epatch "${FILESDIR}/${P}-open.patch"
- epatch "${FILESDIR}/${P}-szip.patch"
- epatch "${FILESDIR}/${P}-null.patch"
+ default
eautoreconf
}
@@ -63,7 +69,6 @@ src_configure() {
# javadx is currently broken. we may try to fix it someday.
econf \
- --libdir="${EPREFIX}"/usr/$(get_libdir) \
--with-x \
--without-javadx \
$(use_with szip szlib) \