summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <junghans@gentoo.org>2018-07-15 15:38:20 -0600
committerChristoph Junghans <junghans@gentoo.org>2018-07-15 15:38:20 -0600
commite35f966afb138fd76c1d49add181c5ee5f45e524 (patch)
tree9a3ac8e0765f4bb881a99d55b574f5a3119e593e /sci-physics
parentsys-kernel/git-sources: Linux patch 4.18-rc5 (diff)
downloadgentoo-e35f966afb138fd76c1d49add181c5ee5f45e524.tar.gz
gentoo-e35f966afb138fd76c1d49add181c5ee5f45e524.tar.bz2
gentoo-e35f966afb138fd76c1d49add181c5ee5f45e524.zip
sci-physics/espresso++: version bump
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'sci-physics')
-rw-r--r--sci-physics/espresso++/Manifest1
-rw-r--r--sci-physics/espresso++/espresso++-2.0.ebuild60
-rw-r--r--sci-physics/espresso++/espresso++-9999.ebuild6
3 files changed, 65 insertions, 2 deletions
diff --git a/sci-physics/espresso++/Manifest b/sci-physics/espresso++/Manifest
index b41cf6edbb14..06b0cbcf75d9 100644
--- a/sci-physics/espresso++/Manifest
+++ b/sci-physics/espresso++/Manifest
@@ -1 +1,2 @@
DIST espresso++-1.9.4.tar.gz 23954404 BLAKE2B b2bb7940db21acb64771fc387d22cec49fc39bae58b9d4ff683eccdbba63981e7ba5c6d64ce938f53e125e74db0423d40ac3c60e33a5589b64a20527437027c6 SHA512 0b5c8ad81c1d6b742909533c58cd791f1702270778f6f140e84108f0da8313418f7fa39d83de2e24f8308e887a1c41d2fcdd0a33ef505d08244a235f95fe611d
+DIST espresso++-2.0.tar.gz 26352105 BLAKE2B 1e35f20a781be36b15a587adcfbe461ea2eaaa2be5fffb86906283b1b7327596e94a5c33f4dcb41288fa7d1262ede1655192652d8eb80f8f866d25e5a4ec654c SHA512 97c7fb45091d09c1b131b462b010d7e082589ae1746dd9fedfd6affdbcdd384d5c9beaeaec3e08cec88750d0a1db8a1f8e68adb01f45dd8b92a1cb34c69386dc
diff --git a/sci-physics/espresso++/espresso++-2.0.ebuild b/sci-physics/espresso++/espresso++-2.0.ebuild
new file mode 100644
index 000000000000..3bae0551d9b2
--- /dev/null
+++ b/sci-physics/espresso++/espresso++-2.0.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+CMAKE_MAKEFILE_GENERATOR="ninja"
+
+inherit cmake-utils python-r1
+
+DESCRIPTION="A Modern Multiscale Simulation Package for Soft Matter Systems"
+HOMEPAGE="https://www.espresso-pp.de"
+
+MY_PN="${PN//+/p}"
+if [[ ${PV} = 9999 ]]; then
+ EGIT_REPO_URI="https://github.com/${MY_PN}/${MY_PN}.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/${MY_PN}/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-macos"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="test"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ virtual/mpi
+ dev-libs/boost:=[python,mpi,${PYTHON_USEDEP}]
+ sci-libs/fftw:3.0
+ >=dev-python/mpi4py-2[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+src_configure() {
+ src_configure_internal() {
+ local mycmakeargs=(
+ -DEXTERNAL_BOOST=ON
+ -DEXTERNAL_MPI4PY=ON
+ -DWITH_RC_FILES=OFF
+ )
+ cmake-utils_src_configure
+ }
+ python_foreach_impl src_configure_internal
+}
+
+src_compile() {
+ python_foreach_impl cmake-utils_src_make
+}
+
+src_test() {
+ python_foreach_impl cmake-utils_src_test
+}
+
+src_install() {
+ python_foreach_impl cmake-utils_src_install
+}
diff --git a/sci-physics/espresso++/espresso++-9999.ebuild b/sci-physics/espresso++/espresso++-9999.ebuild
index 2f9ecca51ed3..3bae0551d9b2 100644
--- a/sci-physics/espresso++/espresso++-9999.ebuild
+++ b/sci-physics/espresso++/espresso++-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -30,9 +30,11 @@ RDEPEND="${PYTHON_DEPS}
virtual/mpi
dev-libs/boost:=[python,mpi,${PYTHON_USEDEP}]
sci-libs/fftw:3.0
- dev-python/mpi4py[${PYTHON_USEDEP}]"
+ >=dev-python/mpi4py-2[${PYTHON_USEDEP}]"
DEPEND="${RDEPEND}"
+S="${WORKDIR}/${MY_PN}-${PV}"
+
src_configure() {
src_configure_internal() {
local mycmakeargs=(